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1 Safety requirement                             

1.1 Summary of General Security Issues                

Read the following safety precautions carefully to avoid injury and to prevent damage to 

this product or any product connected. To avoid possible dangers, please use this 

product in accordance with the regulations. 

 Only professionally authorized personnel can perform repairs. 

 Use the right power cable. 

Use the power cable approved by the country in which the product is used only. 

 Connect and disconnect correctly. 

Before connecting the probe to the circuit being measured, please connect the 

probe to the oscilloscope first. Before disconnecting the probe from the oscilloscope, 

please disconnect the probe and the circuit under test first. 

 Ground the product. 

To avoid electric shocks, the product is grounded through a grounding conductor of 

the power cable. The grounding conductor must be connected to the ground before 

connecting the input or output terminals of the product. Ensure that the product is 

properly grounded. 

 Connect the probe properly. 

The ground wire of the probe is the same as the ground potential. Do not connect 

the ground wire to high voltage. 

 View all terminal rating values. 

To avoid fire or excessive current, please check all rating values and signs on the 

product. Please consult the product manual for details of the rating values before 

connecting the product. 

 Do not operate with the cover open. 

Do not run the product with the cover or panel open. 

 Avoid circuit exposure. 

Do not touch exposed connectors and components after power is switched on. 

 Do not operate if the product is suspected to be faulty. 

If you suspect that the product has been damaged, please ask qualified 

maintenance personnel to check it. 

 Maintain proper ventilation. 

 Do not operate in a humid environment. 

 Do not operate in inflammable or explosive environment. 
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 Please keep the product surface clean and dry. 

Warning: 

Equipment that meets Class A requirements may not provide adequate protection 

for broadcast services in residential environments. 

1.2 Security Terms and Signs                            

Security terms in this manual: 

Warning: 

Indicates that the operation may not cause immediate damage to you. 

Note: 

Indicates that the operation may cause damage to the product or other property. 

Safety terms on products: 

Warning: 

Indicates a potential hazard may be caused to you if you do not perform this 

operation. 

Safety signs on the product: 

Hazardous Voltage Safety Warning 

  

1.3 Measurement Category                                

Measurement category 

This instrument can be used for measurement under class I. 

Warning: 

This instrument is only allowed to be used in the specified measurement class. 

Measurement class definition 

 Class I refers to measurements taken on a circuit not directly connected to 

the main power supply. For example, measurements made on circuits that are not 

exported from a main power supply, especially from a protected (internal) main 
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power supply. In the latter case, the instantaneous stress will change. Therefore, 

the user should understand the instantaneous capacity of the instrument. 

 Class II refers to measurements taken on a circuit directly connected to 

low-voltage instruments. For example, measurements made on household 

appliances, portable tools, and similar equipment. 

 Class III refers to measurements taken on construction equipment. For 

example, measurements made on switchboards, circuit breakers, circuits (including 

cables, busbars, junction boxes, switches, sockets) in fixed equipment, as well as 

equipment for industrial use and certain other equipment (for example, fixed motors 

permanently connected to fixed instruments). 

 Class IV refers to measurements taken at the source of low-voltage 

equipment. For example, measurements made on electricity meters, primary 

overcurrent protection equipment, and pulse control units. 

1.4 Ventilation Requirement                             

This oscilloscope uses a fan to force cooling. Please make sure that the air intake and  

exhaust areas are free from obstructions and have free air. When using the oscilloscope 

in a bench-top or rack setting, provide at least 10 cm clearance beside, above and 

behind the instrument for adequate ventilation. 

Note: 

Inadequate ventilation may cause an increase of temperature in the instrument, 

which would cause damage to the instrument. So please keep the instrument well 

ventilated and inspect the air outlet and the fan regularly. 

1.5 Working Environment                                

Temperature 

Operating: 0°C to 50°C 

Non-operating: -30°C to 70°C 

Humidity 

 Operating: 

Below +30°C: ≤95%RH (without condensation) 

+30°C to +40°C: ≤75%RH (without condensation) 

+40°C to +50°C: ≤45%RH (without condensation) 

 Non-operating: 

Below 65°C: ≤95% RH (without condensation) 
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Warning: 

To avoid short circuit or electric shock, do not operate the device in a damp 

environment. 

Altitude 

Operating: below 3 km 

Non-operating: below 15 km 

Installation (Overvoltage) Category 

This product is powered by mains conforming to installation (overvoltage) category II. 

Warning: 

Ensure that no overvoltage (e.g. from lightning) reaches the product. Otherwise, 

the operator may be in danger of receiving electric shock. 

Installation (Overvoltage) Category Definitions 

Installation (overvoltage) category I refers to signal level which is applicable to  

equipment measurement terminals connected to the source circuit. Among these  

terminals, precautions are done to limit the transient voltage to a low level. 

Installation (overvoltage) category II refers to the local power distribution level  

which is applicable to equipment connected to the AC line (AC power). 

Pollution Degree 

Pollution Degree 2 

Pollution Degree Definition 

 Pollution Degree 1: No pollution or only dry, nonconductive pollution occurs. The 

pollution has no effect. For example, a clean room or air-conditioned office 

environment. 

 Pollution Degree 2: Normally only nonconductive pollution occurs. Temporary 

conductivity caused by condensation is to be expected. For example, indoor 

environment. 

 Pollution Degree 3: Conductive pollution or dry nonconductive pollution that 

becomes conductive due to condensation occurs. To be found in industrial 

environment or construction sites (harsh environments). For example, sheltered 

outdoor environment. 

 Pollution Degree 4: The pollution generates persistent conductivity caused by 

conductive dust, rain, or snow. For example, outdoor areas. 

Security level 

Class 1 - Grounded products 
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1.6 Care and Cleaning                                     

Care: 

Do not expose the LCD to direct sunlight for a long time when storing or placing the 

oscilloscope. 

Cleaning: 

If the oscilloscope and probe are inspected frequently as required by operating 

conditions, clean the outer surface of the instrument by following the following steps: 

1) Use a lint-free cloth to remove the dust outside the oscilloscope and probe. Please be 

careful to avoid scratching the smooth display filter material. 

2) Clean the oscilloscope with a soft cloth soaked in water. For a more thorough cleaning, 

use a aqueous solution of 75% isopropyl alcohol. 

Note: 

In order to avoid damaging the surface of oscilloscope or probe, do not use any 

corrosive reagent or chemical cleaning reagent. 

Warning: 

Before powering on the device again, ensure that the device is dry enough to 

avoid electrical short circuit or personal injury caused by moisture. 

1.7 Environmental Considerations                        

The following symbols indicate that the product complies with the requirements of WEEE 

Directive 2002/96/EC. 

 

Equipment recovery: 

Producing the device requires the extraction and use of natural resources. Some 

substances contained in the equipment may be harmful to the environment or human 

health if the product is not disposed of properly. In order to avoid the release of harmful 

substances into the environment and reduce the use of natural resources, it is 

recommended that appropriate methods be used to recycle this product to ensure that 

most of the materials can be correctly reused. 
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2 Product Features                       

Product features 

 Integrated with 8 independent instruments, including oscilloscope/16 channel logic 

analyzer/spectrum analyzer/arbitrary wave generator/digital voltmeter/frequency 

meter and accumulator/protocol analyzer/protocol generator; 

 Real time sampling rate up to 2.5GSa/s, Max 2G storage depth; 

 10.1-inch multi touch capacitive screen, 256 level waveform grayscale and color 

temperature display; 

 Rich serial protocol triggering and decoding functions; 

 The waveform capture rate is higher than 1.1 million waveforms per second; 

 Up to 51 waveform parameters can be automatically measured, and full memory 

measurement function is also provided; 

 Multiple data analysis and processing functions: independent search, navigation 

buttons and event lists, histograms, Bode plots, power analysis, counters. 

 

The series digital oscilloscope adopts a 10.1-inch multi touch capacitive screen, 256 

level waveform grayscale and color temperature display, max 500MHz bandwidth, 

2.5GSa/s sampling rate, 2G storage depth. Equipped with signal generator that 

supports arbitrary wave output, 52 automatic measurements, providing full memory 

measurement function, Rich serial protocol triggering and decoding functions, Multiple 

data analysis and processing functions. By integrating 8 instrument functions, the 

measurement system is significantly simplified and the measurement speed is 

accelerated, Provide rich configuration interfaces for more convenient use. It is a 

trustworthy oscilloscope that can provide you with professional level measurements. 

 



  Document Overview 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

7 

3 Document Overview                    

This document describes how to quickly understand the front and back panels, user 

interfaces, and basic operation methods of the series digital oscilloscopes. 

Tip: 

The latest version of this manual can be downloaded at (http://www.hantek.com). 

Document number: 

 202506 

Software version: 

Software upgrade may change or increase product functionalities, please pay attention 

to Hantek website for the latest version. 

Document format conventions: 

1 Virtual keys and main interface icons 

Use [name] to represent virtual keys and main interface icons. For example, [Utility] is 

for . 

2 Menu 

Use "menu text (bold) + color" to represent a label or a menu option. For example, I/O 

means to click the "I/O" option on the current operation interface to enter the function 

configuration menu of "I/O". 

3 Operation steps 

Use "->" to represent the next step. For example, [Utility] -> Language means click 

Utility label before clicking Language menu. 

Document content conventions: 

The series tablet oscilloscope consists of the following models. Unless otherwise 

specified, this manual uses HTDO2504E as an example to describe the series and basic 

operations. 

Model Bandwidth Channel Signal Source Digital Channels 

HRDO2104E 100 MHz 4 1 16 

HRDO2204E 200 MHz 4 1 16 

HRDO2354E 350 MHz 4 1 16 

http://www.hantek.com/
http://www.hantek.com/
http://www.hantek.com/
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Table 3.1 Model List

HRDO2504E 500 MHz 4 -- -- 

HRDO2104C 100 MHz 4 -- -- 

HRDO2204C 200 MHz 4 -- -- 

HRDO2354C 350 MHz 4 -- -- 

HRDO2504C 500 MHz 4 -- -- 
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4 Quick Start                             

4.1 General Examination                                  

Check the shipping package 

After receiving the oscilloscope, please follow the following steps to check the instrument: 

Check whether there is any damage caused by transportation: If the packaging cartons 

or protective foam pads are seriously damaged, please keep them until the whole 

machine and accessories pass the electrical and mechanical testing. 

Check the accessories  

The details of the accessories are provided in Appendix A: Accessories at the end of the 

user manual. If you find any accessory missing or damaged, please contact the dealer 

responsible for this business. 

Check the machine 

If you find the instrument is damaged, not working properly, or unable to pass the 

performance test, please contact the dealer responsible for this business. 

4.2 Appearance and Dimension                          

 

Figure 4.1 Front View 
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Figure 4.2 Side View 

4.3 Preparation before Use                                

1. To Adjust the Supporting Legs 

There is a bracket design at the bottom of the machine, and the bracket should be 

adjusted appropriately to tilt the oscilloscope slightly upwards, which can better stabilize 

the placement of the oscilloscope and facilitate observation and operation. When not 

using the machine, simply close the bracket. 

2. To Connect to AC Power 

The specifications of the AC power supply that this oscilloscope can input are: 

47-440Hz, 90-264VAC/127-320VDC, 55Watts MAX. Please connect the oscilloscope to 

the power supply using the power cord provided in the attachment, as shown in the 

figure.  
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Figure 4.3 To Connect to AC Power 

Warning: 

To avoid electric shock, ensure that the instrument is correctly grounded. 

3. Turn-on Checkout 

When the machine is properly plugged in and the oscilloscope is powered on, press the 

power button in the lower left corner of the front panel to start the oscilloscope. During 

the startup process, all the button lights on the front panel will light up for a few seconds, 

and the oscilloscope will perform a series of self checks. After the self check is 

completed, the startup screen will appear. 

4. Function Inspection 

 Click on [Default Setup] in the button area to restore the oscilloscope to its 

factory settings. 

 Connect the grounding crocodile clamp wire of the probe to the grounding 

terminal in the figure below. 

 Connect the probe to the input terminal of channel 1 and the compensation 

signal output terminal marked in the figure below. 

 

Figure 4.4 To Use the Compensation Signal 
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 Set the probe attenuation ratio to X10 and click on the button area [Auto 

Scale]. 

 Observe the pictures on the waveform to see if the square wave signal is 

displayed normally. As shown in the following figure. 

 

Figure 4.5 Square Waveform Signal 

 Check CH2~CH4 channels using the same method. If the square wave 

waveform displayed in the time base does not match the figure above, you 

can follow the instructions in the section on Probe Compensation. 

Warning: 

To avoid electric shock when using the probe, please make sure that the  

insulated wire of the probe is in good condition. Do not touch the metallic part of 

the probe when the probe is connected to high voltage source. 

Tip: 

The probe compensation signal can only be used for probe compensation  

adjustment and cannot be used for calibration. 

5. Probe Compensation 

When connecting the probe to any input channel for the first time, this adjustment is 

required to match the probe with the input channel. Uncompensated or offset probes 

can lead to measurement errors or errors. 

 Perform the first four steps of the previous section on "Function Check". 

 Compare the waveform with the figure below. 
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Figure 4.6 Probe Compensation 

 If necessary, use a non-metallic screwdriver to adjust the variable 

capacitance on the probe until the waveform displayed on the screen is 

"Perfectly compensated" as shown in the figure above. If necessary, repeat 

this step. The adjustment method is shown in the following figure. 

 

Figure 4.7 Adjusting Capacitance 
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4.4 Front Panel Overview                                 

 

Figure 4.8 Front Panel 

Table 4.1 Front Panel Description 

No. Description 

1 Touch Screen 

2 Function Menu Operation Keys 

3 Multifunction Knob 

4 Default Setting Key 

5 Touch Lock Key 

6 Common Operation Keys 

7 Horizontal Control System 

8 Vertical Control System 

9 Run/Stop Key 

10 Single Trigger Control Key 
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11 Auto Waveform Display Key 

12 Arbitrary Waveform Generator Setting Key 

13 Trigger Control System 

14 

1. Probe Compensation Signal Output Terminal/Ground Terminal. 

2.Protocol Signal Generator Output Terminal (When the Protocol 

Generator Function is Enabled). 

15 Analog Channel Input Terminals 

16 Digital Channel Input Interface 

17 USB HOST Interface 

18 Power Key 

4.5 Front Panel Function Overview                        

1. Horizontal: 

           

 Search: 

Press this key to enter the search settings menu, and the search function 

allows users to search for related events in the collected data by setting 

search criteria. 

 Zoom: 

Pressing this key can turn on or off the delayed scanning function. 

  : Indicates the horizontal time base knob. You can rotate the knob to 

modify the horizontal time base. Turn it clockwise to decrease the time base, 

Horizontal time  

base knob      
Horizontal position knob 
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and turn it counterclockwise to increase the time base. During the 

modification, waveforms of all the channels will be displayed in expanded or 

compressed form, and the time base message at the upper section of the 

screen would change accordingly. Press down this knob to quickly switch the 

horizontal time base adjustment mode between "Coarse" and "Fine". 

 : Indicates the horizontal position knob. You can rotate the knob to modify 

the horizontal position (i.g. trigger position). The trigger point would move left 

or right relative to the center of the screen when you rotate the knob. During 

the modification, waveforms of all the channels would move left or right, and 

the horizontal position message at the upper-right corner of the screen would 

change accordingly. Press down this knob to quickly reset the horizontal 

position (or the delayed sweep position). 

 Horizontal time base knob: 

This knob is used to modify the horizontal time base. Rotate clockwise to 

decrease the time base, and counterclockwise to increase it. During the 

modification process, the waveforms of all channels are expanded or 

compressed for display, while the time base information above the screen 

changes in real-time. Press this knob to quickly switch the horizontal time 

base adjustment mode to "coarse adjustment" or "fine adjustment". 

 Horizontal displacement knob: 

This knob is used to modify the horizontal displacement. Rotate the knob to 

move the trigger point left and right relative to the center of the screen. During 

the modification process, the waveforms of all channels move left and right, 

while the horizontal displacement information in the upper right corner of the 

screen changes in real-time. Press this knob to quickly reset the horizontal 

displacement. 

2. Vertical: 

 

 CH1, CH2, CH3, and CH4 analog input channel switches: 

The four channels are identified with different colors, and the color of the 

Channel vertical offset knob 

Channel vertical scale knob 
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waveform also corresponds to the color of the channel. 

 Channel vertical offset knob: 

Rotate this knob to modify the vertical offset of the current channel waveform. 

Rotate clockwise to increase the offset, and counterclockwise to decrease the 

offset. During the modification process, the waveform will move up and down, 

and the offset information in the corresponding status labels will change in 

real-time. Press this knob to quickly reset the vertical offset to zero. 

 Channel vertical gear knob: 

Modify the vertical gear of the current channel. Rotate clockwise to decrease 

the gear, and counterclockwise to increase the gear. During the modification 

process, the waveform display amplitude will increase or decrease, and the 

corresponding gear information in the status label will change in real time. 

Press this knob to quickly switch the vertical gear adjustment mode to "coarse 

adjustment" or "fine adjustment". 

3. Waveform control system: 

 

4. Wave Gen: 

  

 

 REF：Reference waveform key. 

Press this key to open the reference waveform setting menu. 

 Math：Mathematical operation keys. 

Press this button to open the mathematical operation function 

menu, where you can perform A+B, A-B, A×B, A/B, FFT, and etc. 

 LA：Logic analyzer key. 

Press this key to open the control menu of Logic analyzer. 

 Decode：Decode key 

Press this key to open the decoding settings menu. 

 
 Signal source knob: 

Modify the frequency and amplitude of the signal source. Rotate 

clockwise to increase the value, and counterclockwise to 

decrease the value. Press this knob to select the adjustable 

frequency or amplitude. 

 
 G1: 

Press the G1 button to open the signal generator channel. 

 

 Burst：Burst button. 
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5. Trigger: 

  

6. AUTO: 

  

7. Run/Stop: 

  

8. Single: 

  

9. Multifunction Knob: 

  

10. Default: 

  

11. Touch Lock Key: 

  

12. Function Menu: 

 Trigger level knob: Modify the trigger level or threshold level. 

Rotate clockwise to increase the level, and counterclockwise to 

decrease the level. Press this knob to quickly set the trigger level 

value to 50% of the waveform peak value. 

 Trig Menu:  

Press the button to open the trigger operation menu. 

 Force Trig:  

Pressing this key will force the oscilloscope to generate a trigger 

signal. 

 Mode: 

Press this key to switch the trigger mode to Auto, Normal, or 
Single. 

Press this key to set the operating status of the oscilloscope to "Running" 

or "Stopping". In the RUN state, the green backlight of this key lights up. 

In the STOP state, the red backlight of this key lights up. 

Press this key to set the triggering method of the oscilloscope to Single. 

Press this button to enable the automatic waveform setting function. The 

oscilloscope will automatically adjust the vertical gear, horizontal time 

base, and triggering method based on the input signal to achieve the 

optimal waveform display. 

Modify the setting parameters by rotating the knob. 

Press this key to restore the oscilloscope to its factory default settings. 

Press this key to restore the oscilloscope to its factory default settings. 
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 Quick Action: 

The quick operations that can be performed by pressing this key include 

screenshots, waveform saving, setting saving, all measurements, and 

statistical resetting. 

 Analyze: 

Press this key to enter the analysis menu. 

 Cursors: 

Press this key to enter the cursor measurement menu. The oscilloscope 

provides two cursor modes: manual and tracking. 

 Save/Recall: 

This key can perform the save recall function. 

 Utility: 

Press this key to enter the system function settings menu. Set system related 

functions or parameters, such as interfaces, sound, and language. In addition, 

it also supports some advanced functions, such as testing, waveform 

recording, and self calibration. 

 Help: 

Help provides instructions for the various function buttons and corresponding 

menu keys on the front panel. 

 Meas: 

Press this key to enter the measurement settings menu. 

 Acquire: 

Press this key to enter the sampling settings menu. The time base mode, 

acquisition method, and storage depth of the oscilloscope can be set. 
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 Display: 

Press this key to enter the display settings menu. The display type, afterglow 

time, and waveform brightness can be set for the waveform. 

4.6 Rear Panel Overview                                  

 

Figure 4.9 Rear Panel 

Table 4.2 Rear Panel Description 

No. Description 

1 Handle 

2 LAN Interface 

3 USB DEVICE Interface 

4 Reference clock 

5 EXT input terminal 

6 G1 signal source output terminal 

7 

1.Trigger output;  2. Pass/fail event output; 

3.Protocol Signal Generator Output(When the Protocol Generator Function 

is enabled.) 
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8 HDMI 

9 RS232/485 

10 AC Power Cord Connector 

4.7 Rear Panel Overview                                   

1. Handle: 

Users can vertically pull up the handle for easy access to the oscilloscope; When 

not in use, press down on the handle. 

2. LAN interface: 

This interface is used to connect the oscilloscope to the network. 

3. USB VIEW interface: 

This interface is used to connect the oscilloscope to the computer, and users can 

send SCPI commands or customize programming to control the oscilloscope 

through the upper computer software. 

4. Reference clock: 

The use of a reference clock can provide a more accurate sampling clock signal for 

the oscilloscope, and can also be used to synchronize the clocks of two or more 

oscilloscopes. 

5. EXT input: 

This interface is used to input external trigger signals to the oscilloscope. 

6. G1 signal source output terminal: 

This interface outputs the waveform set by the signal generator. 

7. Trigger output and pass/fail: 

Trigger output: 

When the oscilloscope generates a trigger, a signal reflecting the current capture 

rate of the oscilloscope can be output through this interface. The signal can be 

connected to the waveform display device to measure the frequency of the signal, 

and the measurement result is the same as the current capture rate. 

Pass/fail: 

In pass/fail testing, when a pass or fail event is detected, a pulse will be output from 

the [TRIG OUT] connector on the rear panel. 

Protocol Signal Generator Output: 
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When the Protocol Generator Function is enabled, a signal will be output from the 

[TRIG OUT] connector on the rear panel. 

8. HDMI interface (option): 

This interface is used to connect the oscilloscope to an external display with an 

HDMI interface (such as a monitor or projector), allowing for clearer waveform 

display. At this point, the display screen of the oscilloscope is still valid. 

Note: 

When using an external display screen with an oscilloscope HDMI interface, 

the power supply of the external display screen needs to be grounded, 

otherwise it will burn out the oscilloscope's HDMI module. 

Suggestion: Connect the monitor to the HMDI interface before powering on 

the device. 

9. RS-232/485 interface (option): 

This interface is the serial communication interface of the oscilloscope( Cross 

serial cable). 

10. Power socket: 

Power input terminal. Please connect the oscilloscope to the power supply using 

the power cord provided in the attachment. 

4.8 User Interface                                         

 

Figure 4.10 User Interface 



  Quick Start 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

23 

1. Hantek logo, function navigation: 

Click on the icon using the touch screen function to open the function navigation. 

2. Running status: 

The operating status of the oscilloscope includes: RUN, STOP, TD, WAIT, and 

AUTO. 

3. Horizontal time base: 

Represents the length of time represented by each grid on the horizontal axis of 

the screen. The horizontal knob can be used to modify this parameter. 

4. Horizontal displacement: 

Adjust the parameters through the horizontal knob to display the specific horizontal 

position value. 

5. Sampling rate/storage depth: 

Display the current sampling rate and storage depth of the analog channel. The 

sampling rate and storage depth will change with changes in the horizontal time 

base. 

6. Trigger position marker: 

Display the trigger positions of waveforms in the waveform memory and screen. 

7. Waveform memory: 

Provide a schematic diagram of the position of the waveform in the current screen 

in the memory. 

8. Trigger information: 

Display system trigger information, including trigger type, trigger level, trigger 

mode, etc. 

9. Trigger source: 

Display the current trigger source. 

10. Trigger type: 

Display the currently selected trigger type and trigger condition settings. 

11. Trigger level/threshold level: 

The trigger source selection is CH1-CH4, and an appropriate trigger level needs to 

be set.  

When select LA digital channel or EXT as the trigger source, user can not set 

trigger level.  

The trigger level label  is displayed at the left section of the screen, and the 

trigger level/threshold level value is displayed at the upper-right corner of the 

screen. 

Note: In Slope Trigger, Runt Trigger, Window trigger and Overamp Trigger, you 

need to set the upper and lower limits of the trigger level, and two trigger level 

labels (  and  ) are displayed. 
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12. Operation menu: 

Press the menu button in the button area to open the corresponding menu. 

13. Notification area: 

Display icons for time, sound, USB drive, and LAN interface connections. 

14. Arbitrary wave generator (option): 

Display the open status of any wave generator. 

15. Digital channel status area: 

Display the current status of the digital channel. 

16. Message box: 

Display prompt messages. 

17. CH4 status label: 

Display the status of CH4. Display the disposal gear and offset information of CH4. 

Display the current channel settings: channel coupling and bandwidth limitation. 

18. CH3 status label: 

Display the status of CH3. Display the disposal gear and offset information of CH3. 

Display the current channel settings: channel coupling and bandwidth limitation. 

19. CH2 status label: 

Display the status of CH2. Display the disposal gear and offset information of CH2. 

Display the current channel settings: channel coupling and bandwidth limitation. 

20. Analog channel labels/waveforms: 

Different channels are identified with different colors, and the channel labels and 

waveform colors are consistent. 

21. CH1 status label: 

Display the status of CH1. Display the disposal gear and offset information of CH1. 

Display the current channel settings: channel coupling and bandwidth limitation. 

22. Digital Channel Label/Waveform: 

The grouping setting function under the logic analyzer function menu can divide 

the digital channels into 4 channel groups. The channel label of the same channel 

group is displayed in the same color, different channel groups are marked with 

different colors. 

4.9 Touch Screen Controls                                

This series of oscilloscopes provides a 10.1 inch super capacitive touch screen, which 

supports multi-touch and gesture operation with high sensitivity. The functions 

supported by the touch screen include touch, drag, pinch, and rectangle drawing. 

Tip: 
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The menus displayed on the oscilloscope screen and the enabled label buttons 

on the screen can both use the touch screen function. 

1. Tap: 

Tap a menu or function on the screen with one finger, and the functions that can be 

achieved by touching include: 

 Touch the menu displayed on the screen to operate the menu. 

 Touch the pop-up numeric keyboard to set parameters. 

 Touch the virtual keyboard to set the tag name and file name. 

 Touch the close button in the upper right corner of the pop-up menu to close the 

pop-up box. 

 Touch other windows displayed on the screen to operate them. 

 

Figure 4.11 Tap Gesture 

2. Drag: 

After holding down the target, drag to the desired position. The functions that can be 

achieved by dragging include: 

 Drag the waveform to change its displacement or offset. 

 Drag the window to change its position. 

 Drag the cursor to change its position. 

 

Figure 4.12 Drag Gesture 

3. Pinch & Stretch: 

Bring two fingers together or apart. Pinching gestures can amplify or reduce the 

waveform. Enlarge the waveform and slide the close fingers apart; Reduce the 

waveform and slide the separated fingers closer. As shown in the following figure. The 

functions that can be achieved by kneading include: 

 Vertical direction kneading can adjust the vertical gear of the waveform. 

 Horizontal direction pinch can adjust the horizontal gear of the waveform. 
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Figure 4.13 Pinch & Stretch Gesture 

4. Rectangle Drawing: 

Click on [Hantek], then click on the AreaSel to switch to rectangular drawing mode. 

Drag your finger on the screen to draw a rectangle,. Move your finger away from the 

screen, and a menu will appear on the screen. At this time, you can touch to select the 

functions of "Histogram", "Enlarge Level", "Enlarge Vertical", or "Enlarge Waveform". 

 Select "Histogram": 

 Draw the range of the histogram; 

 Open the 'Histogram' menu. 

 Select "Enlarge Level ": horizontally expand the waveform; Select 'Horizontal 

Zoom Out': compress the waveform horizontally. 

 Select "Enlarge Vertical ": vertically expand the waveform; Select 'Vertical Zoom 

Out': Compress the waveform vertically. 

 Select "Enlarge Waveform": expand the waveform in both horizontal and vertical 

directions simultaneously; Select 'Waveform Reduction': compress the waveform 

in both the horizontal and vertical directions simultaneously. 

 

Figure 4.14 Rectangle Drawing Gesture 

4.10 Parameter Setting Method                             

The parameter setting method of this series of oscilloscopes supports two methods: 

numeric keyboard input and multi-functional knob setting of values. 

1. For parameters on the menu, rotate the multi-functional knob V0 in the button area 

to select parameter items or modify parameter values. 

2. After clicking on the parameters on the menu, a numeric keyboard will pop up on 

the screen, as shown in the following figure. 
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Figure 4.15 Numeric Keypad 

In the numeric keypad, you can use the touch screen function to enter values or units by 

clicking on them. After entering all numerical values and selecting the desired units, the 

numeric keypad will automatically close to complete the parameter settings. In addition, 

after completing the numerical input, you can also directly click the  in the 

numeric keyboard to close it, and the units of the parameters are the default units. In the 

numeric keypad, you can also perform the following operations: 

 Delete the entered parameter values. 

 Set the parameters to maximum or minimum values. 

 Set the parameters to default values. 

 Clear the parameter input box. 

3. For parameters on the menu, click the menu label button directly to switch settings. 

4.11 To Use the Built-in Help System                        

To Use the Built-in Help System 

The help system of this oscilloscope provides instructions for various function buttons 

on the front panel and corresponding menu keys. The operation steps are: 

 Click the  button in the button area to enter the help module; 

 Press other keys to obtain help information; 

 Press the  button again to exit the help module. 

For example: 

After clicking the [Help] button, click the [QuickAction] button again, and the 

explanation menu for [QuickAction] will pop up on the screen. 
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5 To Set the Vertical System              

This series of oscilloscopes provides four input channels CH1-CH4, each with an 

independent vertical control system. The control systems for the four channels are the 

same, and this chapter mainly introduces various setting methods for CH1. Please read 

this chapter carefully to understand the setup functions and operation of the vertical 

system of the tablet oscilloscope. 

Contents in this chapter: 

 To Enable or Disable the Analog Channel 

 To Adjust the Vertical Scale 

 To Adjust the Vertical Offset 

 Channel Coupling 

 Bandwidth Limit 

 Probe Ratio 

 Input Impedance 

 Waveform Invert 

 Amplitude Unit 

 Fine tuning 

 Channel Delay 

 Offset Calibration 

 Vertical Expansion 

 Channel Label 
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5.1 To Enable or Disable the Analog Channel              

1. Enable analog channel 

For example, after connecting a signal to the CH1 channel, the channel can be opened 

as follows. 

 Click on the channel status label at the bottom of the screen, open the channel, 

and the label will light up. At the same time, the corresponding button in the button 

area [CH1] will also light up, and the color will be consistent. 

 Press the [CH1] button directly to open the channel, and the light on the 

corresponding channel knob will also light up. 

If CH1 is turned on and currently selected, the label is shown in the following figure. 

 

If CH1 is turned on but not currently selected, the label is shown in the following figure. 

 

The information displayed in the channel status label is related to the current channel 

settings (independent of the channel's on/off status). 

2. Disable analog channel 

The simulation channel can be closed through the following methods: 

 If the CH1 channel is already open and currently selected, press [CH1] once to 

close the CH1 channel. 

 If the CH1 channel is open but not in the selected state, press [CH1] once to make 

CH1 in the selected state, and then press the CH1 button again to close the CH1 

channel. 

 Use the touch screen function to close the channel by clicking on the number on 

the channel menu at the bottom of the screen. 

If CH1 is disabled, the label is shown in the following figure. 
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5.2 To Adjust the Vertical Scale                            

Vertical gear refers to the voltage value represented by each grid in the vertical direction 

of the display screen, usually expressed as V/div. When adjusting the vertical gear, the 

waveform display amplitude will increase or decrease, and the gear information in the 

channel status label will also change in real time. 

 

The probe ratio and input impedance of the vertical gear and channel settings are 

related. By default, the probe ratio is 1X and the input impedance is 1M Ω. The vertical 

gear range is: 500uV/div~10V/div. 

When the CH1 channel is open, the vertical gear can be adjusted through the following 

methods: 

 Rotate the knob corresponding to CH1 to adjust the vertical gear within an 

adjustable range. Rotate clockwise to decrease the gear, and counterclockwise to 

increase the gear. 

 Using the touch screen function, click on the CH1 channel menu at the bottom of 

the screen, and in the pop-up menu, set the vertical gear. 

 

5.3 To Adjust the Vertical Offset                           

Vertical offset refers to the offset of the zero point position of the channel signal of the 

waveform in the vertical direction relative to the center of the screen. The unit is 

consistent with the currently selected amplitude unit. When adjusting the vertical offset, 

the waveform of the corresponding channel moves up and down, and the offset 

information in the channel status label also changes in real-time. 

 

Adjust vertical offset: 

 Using the touch screen function, adjust the vertical offset by dragging gestures. 

Please refer to the Drag section for specific operations. 

 Rotate the offset knob in the button area to adjust the vertical offset. 
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 Using the touch screen function, click on the CH1 channel menu at the bottom of 

the screen, and in the pop-up menu, set the offset. 

 

5.4 Channel Coupling                                     

Setting the coupling method can filter out unwanted signals. Open the vertical menu of 

the channel and click on the Coupling menu to select the coupling method. As shown in 

the following figure. 

 When the coupling method is "DC": both the DC and AC components contained in 

the measured signal can pass through. 

 When the coupling method is "AC": the DC component contained in the measured 

signal is blocked. 

 When the coupling method is "GND": both the DC and AC components contained 

in the measured signal are blocked. 

After setting the coupling method, the current coupling method will be displayed at the 

channel label. 

 

Tip: 

When the input impedance is selected as 50 ohms, the coupling mode of the channel 

can only be set to DC and cannot be changed. 

5.5 Bandwidth Limit                                       

This oscilloscope supports bandwidth limiting function. Setting bandwidth limits can 

reduce noise in the displayed waveform. 

 When the bandwidth limit is turned off, the high-frequency components contained 

in the measured signal can pass through. 

 If the bandwidth limit is turned on and limited to 20MHz, the high-frequency 
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components greater than 20MHz contained in the measured signal will be 

attenuated. 

Click to open [CH1], and then click on the BW Limit menu to select the restricted 

bandwidth. You can choose to close, 20M, 100M, 200M, 350M, and the default is 20M. 

After opening the bandwidth limit, the color B at the channel label matches the channel 

color. 

 

Tip: 

Bandwidth limitation not only reduces noise, but also attenuates or eliminates 

high-frequency components in the signal. 

5.6 Probe Ratio                                           

Open [CH1], then click on the Attenuation to set the probe. 

The oscilloscope allows users to manually set the probe attenuation ratio, and users 

must set the probe ratio correctly to obtain accurate measurement results. The default 

probe ratio is 1X, and the probe range is 0.01X-50000X. 

To match the actual attenuation ratio of the probe, it is necessary to adjust the channel 

attenuation ratio accordingly under the channel menu. Whenever the attenuation ratio of 

the probe changes, it is necessary to set the corresponding attenuation ratio in the 

channel menu to ensure the correctness of the waveform amplitude and measurement 

results displayed on the oscilloscope. 

Table 5.1 Probe Ratio 

Menu 
Attenuation Ratio(display amplitude of the 

signal: actual amplitude of the signal) 

0.01X 0.01:1 

0.02X 0.02:1 

0.05X 0.05:1 

0.1X 0.1:1 

0.2X 0.2:1 

0.5X 0.5:1 

1X 1:1 

2X 2:1 
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5X 5:1 

10X 10:1 

20X 20:1 

50X 50:1 

100X 100:1 

200X 200:1 

500X 500:1 

1000X 1000:1 

2000X 2000:1 

5000X 5000:1 

10000X 10000:1 

20000X 20000:1 

50000X 50000:1 

5.7 Input Impedance                                      

This oscilloscope provides two input impedance modes: 1M Ω and 50 Ω to reduce the 

circuit load caused by the interaction between the oscilloscope and the circuit under 

test. 

Open [CH1], click on the Impedance menu tab, and select an input impedance of 1M Ω 

or 50 Ω. 

 1M Ω: At this point, the input impedance of the oscilloscope is very high, and the 

current flowing into the oscilloscope from the tested circuit can be ignored. 

 50 Ω: Match the oscilloscope with a device with an output impedance of 50 Ω. 

5.8 Waveform Invert                                       

Open [CH1], click on the inverting menu, select the inverting switch flag to turn it on or 

off, and the flag will light up to turn on the waveform inverting function. The default is to 

turn off inverting. 
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When the waveform inversion is turned off, the waveform is displayed normally; When 

the waveform inversion is turned on, the waveform voltage value is inverted. Opening 

waveform inversion will also change the results of mathematical operations, waveform 

measurement, and other operations. 

 

Figure 5.1 "Invert" Off 

 

Figure 5.2 "Invert" On 

5.9 Amplitude Unit                                        

Open [CH1], click on the Unit menu, and set the unit. The optional units are [W], [A], [V], 

[U], and the default unit is [V]. 

After modifying the amplitude unit, the units of functions related to the channel will also 

change. 
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5.10 Fine Adjustment                                            

Open [CH1], click on the Fine adjustment menu, and the label will light up to indicate 

fine adjustment. The default setting is coarse adjustment. 

 

 Fine adjustment: The vertical gear will be adjusted within a small range, changing 

the vertical resolution to facilitate the observation of waveform details. 

 Coarse adjustment: Set the vertical gear in steps of 1 to 2 to 5. 

5.11 Channel Delay                                         

When using an oscilloscope for actual measurements, the transmission delay of the 

probe cable may cause significant errors (zero offset). This series of oscilloscopes 

supports users to set a delay time to correct the zero offset of the corresponding 

channel. Zero offset is defined as the offset of the intersection point between the 

waveform and the trigger level line relative to the trigger position. 

Click on [CH1], click on the Channel Delay menu, and a numeric keyboard will pop up 

to set the delay. The delay time can be set from -100ns to 100ns. 

 

Figure 5.3 Zero Offset 
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5.12 Offset Calibration                                             

When using an oscilloscope for actual measurement, the temperature drift 

characteristics of the device or external environmental interference cause a small 

deviation in the zero voltage of the channel, which affects the measurement results of 

vertical parameters. This series of oscilloscopes supports users to set a zero elimination 

voltage to correct the zero point of the corresponding channel, thereby improving the 

accuracy of measurement results. 

Click on [CH1], click on the Offset Cal menu, and a numeric keyboard will pop up to set 

the numerical range. 

5.13 Vertical Expansion                                    

This series of oscilloscopes supports two vertical expansion methods: center or GND, 

with the default being center: 

 Screen: When changing the vertical gear, the mathematical operation waveform 

will expand or compress around the center of the screen. 

 GND: When changing the vertical gear, the mathematical operation waveform will 

expand or compress around the zero position (grounding) of the waveform. 

5.14 Channel Label                                         

This series of oscilloscopes can have additional channel labels set. 

Click on [CH1], click on the Label menu, and enter the settings menu. 

 Display: 

Click on the Display the menu label, choose to open or close the channel label, open 

the label, and the set label will be displayed on the left side of the waveform. The label 

defaults to 1. 

 Library: 

Click on the Library menu tab to select tags such as ADO, ADDR, BIT, CAS, CLK, etc. 

 Label: 

Click on the Label menu label, and the label editing keyboard will automatically pop up. 

Through the touch function, enter the label name on the keyboard. 
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In the virtual keyboard, click the Select Case switch and rotate the multi-functional knob 

V0 to select letters. After entering, press the  key to end editing. You can also 

use the touch screen function to operate through touch gestures. If the Display is 

turned on, the set label will be displayed on the left side of the CH1 waveform. 

If the inputted characters are deleted or modified, they can be achieved through the 

multi-functional knob V0 or by using the touch screen function: 

 Using a multifunctional knob: You can only delete the character until it needs to be 

deleted or modified by pressing the delete button. If you modify characters, you 

need to re-enter the required characters. 

 Using the touch screen function: simply position the cursor to the right of the 

character that needs to be deleted or modified through a touch gesture, and press 

the delete button to delete the character. If you modify characters, you need to 

re-enter the required characters. 

In addition, the "Input Selection Area" is only available when selecting the Chinese input 

method. 
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6 To Set the Horizontal System           

This chapter contains detailed information about the oscilloscope horizontal system. We 

suggest that you read carefully to understand the setting functions and operation of the 

oscilloscope horizontal system. 

Horizontal adjustment can be achieved through the following methods: 

 Click on the horizontal time base label at the top of the screen to adjust the 

horizontal setting. 

 

 Adjust the time base knob and displacement knob in the button area to adjust the 

horizontal setting. 

 

 Use the touch function to adjust the horizontal setting. 

This chapter includes: 

 To Adjust the Horizontal Position 

 To Adjust the Horizontal Time Base 

 Pan/Zoom Single or Stopped Acquisition 

 Delayed Sweep 
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6.1 To Adjust the Horizontal Position                     

Horizontal displacement refers to the displacement of the waveform trigger points of all 

channels in the horizontal direction relative to the center of the screen. When the 

waveform trigger point is located on the left (right) side of the screen center, the 

horizontal displacement is positive (negative). 

When changing the horizontal displacement, the waveform trigger points and displayed 

waveforms of all channels move left and right; The horizontal displacement information 

above the screen changes in real-time. 

 

The horizontal displacement can be adjusted by the following methods: 

 Click on the horizontal label at the top of the screen, and in the pop-up menu, enter 

the displacement value directly or click the increase/decrease knob on the right to 

set the displacement, as shown in the following figure. 

 

 Adjust the horizontal displacement by rotating the horizontal position knob. 

 

 Adjust the horizontal displacement by dragging the gesture, and the horizontal 

trigger position icon on the screen will move left and right with the sliding of the 

hand. Please refer to the Drag section for specific operations. 

6.2 To Adjust the Horizontal Time Base                    

The horizontal time base is the time value represented by each grid in the horizontal 

direction of the display screen, generally expressed as s/div. The adjustable range of 

the horizontal time base is 500ps/div~1000s/div. The default value is 1us/div. 

Change the horizontal time base, and the horizontal time base information will be 

displayed in real-time on the screen. 

 

The horizontal time base can be adjusted by the following methods: 
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 Click on the horizontal label at the top of the screen, and in the pop-up menu, enter 

the time base value directly or click the increase/decrease knob on the right to set 

the time base, as shown in the following figure. 

 

 Adjust the horizontal time base by rotating the horizontal time base knob. 

 Adjust the horizontal time base through the pinching gesture of the touch function. 

Please refer to the Pinch section for specific operations. 

6.3 Pan/Zoom Single or Stopped Acquisition              

After the oscilloscope stops, the stopped display may contain several collected data 

with useful information, but only the last collected data can be panned and scaled. Pan 

and zoom the data collected in a single or stopped collection. 

6.4 Delayed Sweep                                        

Delay scanning is used to horizontally amplify a section of waveform in order to view 

waveform details. 

Click the [Zoom] button in the button area, and the screen is divided into two display 

areas. 

 

Figure 6.1 Delayed Sweep Mode 



  To Set the Horizontal System 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

41 

Waveform before amplification: 

The upper half of the screen not covered by semi-transparent green represents the 

waveform before amplification, and its horizontal time base (known as the main time 

base) is displayed in the upper left corner of the screen. You can move the area left and 

right by adjusting the horizontal displacement, or expand or decrease the area by 

adjusting the base gear when horizontal. 

Amplified waveform: 

The lower part of the screen is a horizontally extended delayed scanning waveform, with 

its horizontal time base (referred to as the delayed scanning time base) displayed on the 

screen. Delayed scanning time base improves resolution compared to the main time 

base. In this mode, the horizontal time base knob adjusts the delayed sweep time base, 

and the horizontal position knob controls the delayed sweep horizontal position. 

Tip: 

The delay scanning time base should be less than or equal to the main time base. 
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7 To Set the Sample System              

Click on the button area [Acquire] to enter the settings menu. 

This chapter includes: 

 Timebase Mode 

 Acquisition Mode 

 Memory Depth 

 Fine Adjustment 

 Horizontal Expansion 

 Segmented Acquisition 

 Sample Rate 
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7.1 Timebase Mode                                       

Open [Acquire], click on the Timebase Mode menu, and select time base modes: YT 

mode, XY mode, and ROLL mode. 

7.1.1 YT Mode                                              

In this mode, the Y-axis represents the usual voltage and the X-axis represents the time. 

In YT mode, when the horizontal time base is set to 50ms/div or slower, the oscilloscope 

enters scanning mode. For details, please refer to the detailed explanation of scanning 

mode in the "ROLL Mode" section below. 

7.1.2 XY Mode                                            

This series of oscilloscopes supports the waveform display window "XY Window" in XY 

mode, where both the X-axis and Y-axis represent the voltage level. 

In this mode, the four channels are divided into two groups CH1 and CH2, CH3 and 

CH4. 

Phase difference measurement: 

The Lissajous method can conveniently measure the phase difference between two 

signals of the same frequency. The following figure shows the measurement principle 

diagram of phase difference. 

 

Figure 7.1 Measurement Schematic Diagram of Phase Deviation 

According to or, where θ the definition of A, B, C, and D is the phase difference angle 

between channels, as shown in the figure above. Therefore, the difference angle can be 
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obtained, which is: 

If the main axis of the ellipse is within the I and III quadrants, the obtained phase 

difference angle should be within the I and IV quadrants, that is, within (0 to π/2) or (3 

π/2 to 2 π). If the main axis of the ellipse is within the II and IV quadrants, the obtained 

phase difference angle should be within the II and III quadrants, that is, within (π/2 to π) 

or (π to 3 π/2). The X-Y function can be used to test the phase change generated by a 

signal passing through a circuit network. Connect the oscilloscope to the circuit and 

monitor the input and output signals of the circuit. 

Note: 

In general, longer sampling waveforms can achieve better display results, but due to 

storage depth limitations, longer waveform lengths mean a need to reduce the sampling 

rate. Therefore, in this measurement process, appropriately reducing the sampling rate 

can obtain a better display effect of the Lissajous pattern. 

In XY mode, "Scan Mode", "Protocol Decoding", "Acquisition Mode", "Pass/Fail Test", 

"Digital Channel" do not work. 

Using the Li Sha Yu method: 

1. Connect a sine signal to CH1, and then connect a sine signal with the same 

frequency, amplitude, and phase difference of 90 ° to CH2. 

2. Click on [AUTO Scale], select the XY mode, and rotate the knob to adjust the 

sampling rate appropriately to obtain a better Lissajous pattern for better 

observation and measurement. 

3. Adjust the vertical knobs corresponding to CH1 and CH2 channels to make the 

signal easy to observe. At this point, the circle shown in the following figure should 

be obtained. 

 

Figure 7.2 XY mode waveform 
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4. Observing the measurement results in the above figure and based on the phase 

difference measurement principle diagram (Figure 7.1), it can be concluded that 

A/B (C/D)=1, that is, the difference angle between the input signals of the two 

channels is θ=± arcsin1=90 ° 

7.1.3 ROLL Mode                                             

In Roll mode, the waveforms are updated rolling from right to left on the screen. You do 

not need to wait until all the complete waveforms are acquired. You can see the 

acquired data points at any time during its acquisition. In the acquisition menu, press 

[Acquire], click on the More -> More -> Auto ROLL menu to select "ON" or "OFF" for 

setting auto Roll function.  

 ON: enables the auto Roll mode. When the horizontal time base is set to 50 ms/div 

or lower than the value, the instrument automatically enters the Roll mode. In this 

case, there will be no scanning mode. 

 OFF: disables the auto Roll mode. In this mode, when the horizontal time base is 

set to 50 ms/div or lower than this value, the instrument enters “scanning mode”. In 

scanning mode, the instrument first acquires the data at the left of the trigger point 

and then waits for a trigger event. After the trigger occurs, the instrument continues 

to generate the waveform at the right of the trigger point. In this case, although the 

instrument cannot automatically enter Roll mode, you can press [Acquire] and 

select ROLL menu to enable Roll mode manually. 

If the current Delay Sweep function is turned on, the Delay Sweep will automatically turn 

off when the "ROLL" time base mode is enabled. 

The following functions cannot be set in ROLL mode: "Adjust horizontal displacement" 

(available when the oscilloscope is running in "STOP" state), "Delay scan", "Trigger 

oscilloscope", "Protocol decoding", "Pass/fail test", "Waveform recording and playback", 

"Set afterglow time", "Histogram". 

Tips： 

When observing low-frequency signals in scanning mode, it is recommended to set the 

"channel coupling" mode to "DC". 

When the memory depth is set to a higher value, the device remains in YT mode even if 

the horizontal time base is set to 50 ms/div or slower, and will not enter "scanning 

mode". 

7.2 Acquisition Mode                                    

Open [Acquire], click on the Acquisition method menu, select Normal, Average, Peak, 
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High Res, and the default acquisition method is Normal. 

7.2.1 Normal                                                 

In this mode, the oscilloscope samples the signal at equal time intervals to reconstruct 

the waveform. For most waveforms, using this mode can produce the best display 

effect. 

7.2.2 Average                                                

In this mode, the oscilloscope averages the waveforms sampled multiple times to 

reduce random noise on the input signal and improve vertical resolution. The higher the 

average frequency, the smaller the noise and the higher the vertical resolution, but the 

displayed waveform also responds slower to waveform changes. 

After selecting the "average" mode, the sampling system menu will display the average 

number of times. Press the Averages key and rotate the multi-functional knob to set it to 

2, 4, 8, 16, 32, 64, 128, 256, 512, or 1024. The default is 8. 

 

Figure 7.3 Waveforms before Averaging 
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Figure 7.4 Waveforms after Averaging 

7.2.3 Peak                                                    

In this mode, the oscilloscope collects the maximum and minimum values of the signal 

within the sampling interval to obtain the envelope of the signal or narrow pulses that 

may be lost. Using this mode can avoid signal aliasing, but the displayed noise is 

relatively high. 

In this mode, the oscilloscope can display all pulses at least as wide as the sampling 

period. 

7.2.4 High Resolution                                         

This mode adopts a super sampling technique that averages adjacent points of the 

sampled waveform, reducing random noise on the input signal and producing a 

smoother waveform on the screen. Usually used when the sampling rate of a digital 

converter is higher than the storage rate of the acquisition memory. 

Note: 

The averaging method used in "average" and "high resolution" modes is different, with 

the former being "multiple sample averaging" and the latter being "single sample 

averaging". 

7.3 Memory Depth                                        

Storage depth refers to the number of waveform points that an oscilloscope can store in 
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a single trigger acquisition. It reflects the storage capacity of the acquisition memory. 

 

Figure 7.5 Memory Depth 

The following equation shows the relations among memory depth, sample rate, and  

horizontal time base scale: 

MDepth =  SRate * TScale *  

MDepth ——indicates the memory depth. The unit is pts. 

SRate——indicates the sample rate. The unit is Sa/s. 

TScale ——indicates the horizontal time base scale. The unit is s/div. 

HDivs ——indicates the number of grids in the horizontal direction. The unit is div. 

Therefore, under the same horizontal time base scale, a higher memory depth can  

ensure a higher sample rate. 

Open [Acquire], click on the Mem Depth menu, and select the storage depth. 

 Single channel mode: Storage depth options: Auto, 25K, 250K, 2.5M, 25M, 50M, 

100M, 250M, 500M, 2G. 

 Dual channel mode: Storage depth options: Auto, 12.5K, 125K, 1.25M, 12.5M, 

25M, 50M, 125M, 250M, 1G. 

 Full channel mode: Storage depth options: Auto, 6.25K, 62.5K, 625K, 6.25M,12.5M, 

25M, 62.5M, 125M, 500M. 

7.4 Fine Adjustment                                                

Open [Acquire], click on the Fine menu, and the label will light up to indicate fine tuning. 

The default setting is coarse tuning. 

 

 Fine adjustment: The time base will be adjusted within a small range, changing the 

time base to facilitate observation of waveform details. 

 Coarse adjustment: Set the horizontal time base in steps of 1-2- 5. 
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7.5 Horizontal Expansion                                

Horizontal expansion refers to the reference position on which the screen waveform is 

horizontally expanded or compressed when adjusting the horizontal time base. Open 

[Acquire], click on the Expand menu, and select the open expansion method. The 

extensions supported by this oscilloscope include center, left, right, trigger point, and 

customization. The default is' Center '. 

 Center: When changing the horizontal time base, the waveform expands or 

compresses horizontally around the center of the screen. Press the multi-functional 

knob to quickly restore the reference position to 0. 

 Left: When changing the horizontal time base, the waveform expands or 

compresses horizontally around the leftmost side of the screen. 

 Right: When changing the horizontal time base, the waveform expands or 

compresses horizontally around the far right side of the screen. 

 Trigger: When changing the horizontal time base, the waveform expands or 

compresses horizontally around the trigger point. 

 User: When changing the horizontal time base, the waveform expands or 

compresses horizontally around the user-defined reference position. 

After selecting " User ", the menu will display "Expand User ". Click on the " Expand 

User " menu label, rotate the multi-functional knob to set the extension benchmark, and 

the range can be set from the rightmost side of the screen to the leftmost side of the 

screen. The default is the center of the screen. 

7.6 Segmented Acquisition                               

Open [Acquire], click on the Segmented menu, and enter the settings menu. 

Alternatively, click on the navigation icon [Hantek] in the upper left corner of the screen 

and select segmented acquisition. Entering the settings menu and lighting up the label 

means opening segmented collection. The segmented collection results appear in the 

middle of the screen. 

Click on the Segmented Set menu tab and set the segmented settings by rotating the 

multi-functional knob V0 or the pop-up numeric keyboard. 

7.7 Sample Rate                                         

Sampling refers to the process in which an oscilloscope converts analog signals into 

digital signals at certain time intervals and stores them in sequence. The sampling rate 

is the reciprocal of the time interval. 

Open [Acquire] and the sampling rate menu will display the current sampling rate value. 
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The sampling rate is displayed in the status bar at the top of the screen, and can be 

indirectly changed by adjusting the horizontal time base or modifying the storage depth. 

 

The impact of low sampling rate on waveform: 

 Waveform distortion: Due to the low sampling rate, some waveform details are 

missing, resulting in significant differences between the waveform displayed by the 

oscilloscope sampling and the actual signal. 

 

 Waveform aliasing: since the sampling rate is lower than 2 times of the actual 

signal frequency (Nyquist frequency), the waveform frequency when 

reconstructing the sampled data is lower than the frequency of the actual signal. 

 

 Waveform leakage: Due to the low sampling rate, the waveform reconstructed from 

the sampled data did not reflect all the actual signals. 
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8 To Trigger the Oscilloscope             

The so-called triggering refers to setting certain triggering conditions according to 

requirements. When a certain waveform in the waveform flow meets this condition, the 

oscilloscope immediately captures the waveform and its adjacent parts, and displays 

them on the screen. The trigger determines when the oscilloscope starts acquiring data 

and displaying waveforms. Once the trigger is set correctly, the oscilloscope can convert 

unstable displays or blank screens into meaningful waveforms. Here are some basic 

concepts of triggers. 

You can enter the trigger menu by: 

 Click on the button area [Trig Menu] to enter the trigger menu. 

 Click on the trigger tab at the top of the screen (as shown in the figure below), and 

a simple trigger menu will pop up on the screen. 

 

This chapter includes: 

 Trigger Level 

 Trigger Sensitivity 

 Trigger Source 

 Trigger Mode 

 Trigger Holdoff 

 Trigger Type 
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8.1 Trigger Level                                       

The trigger level is the signal voltage corresponding to the set trigger point, which is 

related to the type of trigger signal source. 

 The trigger flag and trigger level line move up and down as the trigger level 

changes. The trigger flag and channel color remain consistent. When changing the 

trigger level, a trigger level line will temporarily appear on the screen to tell you the 

position of the level (the specific value of the trigger level is displayed in the trigger 

menu label at the top right of the screen). After about 2 seconds of stopping 

modifying the trigger level, the trigger level line disappears. 

Note: In Slope Trigger, Runt Trigger, Overamp Trigger and Window trigger, you need to 

set the trigger level A and trigger level B by rotating the Trigger level knob. The 

subtraction result of Level A minus Level B is displayed at the upper-right side of the 

screen. Two trigger level labels (  and  ) are displayed at the left side of the 

screen. Additionally, if the trigger settings dialog is opened, real-time trigger level 

information can be viewed as shown in the figure below. 

 

 

Also, you can through the Level Select menu in the [Trig Menu] menu, select the 

current adjustable levels as level A, level B, and level AB. 

 When the trigger source is set to EXT, there is no trigger level. 

 When the trigger source is selected LA digital channel（D1.0-D1.3, D2.0-D2.3, 

D3.0-D3.3, D4.0-D4.3）, there is no trigger level display. You can also press [LA] to 

enter the LA logic analysis setting menu. Then set the threshold level of the digital 

channel in the Threshold menu setting. For the setting method, refer to 

"Threshold". 

The trigger level can also be adjusted through the touch function. 

 Using the touch screen function, touch the trigger setting label in the upper right 

corner of the screen to pop up the trigger setting box as shown in the following 

figure. Touch the right side of the level value input box to increase or decrease the 

Delta (Δ) between Level A and Level B 



  To Trigger the Oscilloscope 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

53 

level value. You can also touch the value input box and directly input the specific 

value through the pop-up numeric keyboard. 

 

8.2 Trigger Sensitivity                                   

The trigger sensitivity indicator shows the sensitivity of the trigger signal recognition. By 

adjusting the trigger sensitivity, it can effectively filter out the noise that may be 

superimposed on the trigger signal and prevent false triggering. 

Click on the trigger label in the upper right corner of the screen to pop up the trigger 

setting box and set the sensitivity. 

Set trigger Sens: 

 Click on the sens box in the menu to pop up the numeric keypad and set the 

sensitivity value. 

 Click the up and down arrow keys on the right to set the sensitivity value. 

 

8.3 Trigger Source                                      

Click on the button area [Trig Menu] to enter the Source menu. The available data 

sources include: CH1~CH4, EXT, Digital channels (D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, 

D4.0-D4.3). 

Analog channel: The input signals of analog channels CH1-CH4 can all be used as 

trigger sources, and only by selecting the channel with already connected signals as the 

trigger source can stable triggering be obtained. 

Digital channels: D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3 can be used as trigger 

sources, and only digital channels that have been inserted and enabled can be 

selected. 

External trigger source: can be used to trigger on the 5th channel while all 4 channels 

are collecting data. The trigger signal (such as an external clock or signal from the 

circuit under test) will be connected to the EXT trigger source through the external 
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trigger input terminal [EXT In] connector. 

8.4 Trigger Mode                                        

The following is a schematic diagram of the acquisition memory. To facilitate the 

understanding of triggering events, the collection memory can be divided into pre 

triggered buffer and post triggered buffer. 

 

Figure 8.1 Schematic Diagram of the Acquisition Memory 

After starting operation, the oscilloscope will first fill the pre triggered buffer. After filling, 

the oscilloscope will start searching and triggering; During the search period, the 

sampled data will continue to be transmitted to the pre triggered buffer (new data will 

continuously overwrite existing data). After searching for a trigger, the pre trigger buffer 

will contain the events that occurred before the trigger. Then, the oscilloscope will fill the 

trigger buffer and display the data in the acquisition memory. If the collection is initiated 

through the [Run/Stop] button, the process will be repeated; If the acquisition is initiated 

through the [Single] key, it will stop after completing a single acquisition (the current 

displayed waveform can be panned and scaled). 

The oscilloscope trigger mode provides Normal, Auto, and Single trigger. The trigger 

mode defaults to automatic mode. 

 Normal mode: Only when the oscilloscope has a valid trigger will the displayed 

waveform be updated. Before replacing the original waveform with a new 

waveform, the oscilloscope will display the original waveform. Use the "normal" 

mode only when you want to view the waveform that is effectively triggered. When 

using this mode, the oscilloscope only displays the waveform after the first trigger. 

 Auto mode: can freely run collection without effective triggering. This mode allows 

for untriggered scanning waveforms to occur at a time base setting of 100 

milliseconds/grid or slower. When the oscilloscope detects a valid triggering 

condition, complete a triggered acquisition. When the oscilloscope detects that 

there are no valid triggering conditions, complete a non triggering acquisition. 

 Single mode: Only when the oscilloscope has a valid trigger can the collection end 

and enter the stop state. 

 Forced trigger: In both normal and single trigger modes, pressing the forced trigger 



  To Trigger the Oscilloscope 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

55 

button in the trigger menu can forcibly generate a trigger signal. 

The trigger mode can be selected through the following two methods: 

 Using the touch screen function, touch the trigger setting label  in the 

upper right corner of the screen to pop up the trigger setting box as shown in the 

following figure. You can switch the trigger method by touching "Auto", "Normal" 

and "Single" with the touch gesture. 

 

 On the front panel’s Trigger Control area, pressing the [Mode] key allows you to 

quickly switch between current trigger modes. The active trigger mode is displayed 

in the upper-right corner of the screen: A(Auto), N(Normal) and S(Single).  

Note: In normal and single-trigger modes, pressing the【Force Trig】key can forcibly 

generate a trigger signal. 

When you are not familiar with a signal feature, the oscilloscope should be set in the 

"Auto" mode to ensure that the waveform is displayed even if other trigger settings are 

incorrect. Although the waveform may not be stable, it can provide us with intuitive 

judgment for further adjusting the oscilloscope. 

When we set specific triggering conditions for a specific signal, especially when the time 

interval between meeting the triggering conditions is relatively long, we need to set the 

triggering mode to "Normal" to prevent the oscilloscope from automatically forcing 

triggering. 

8.5 Trigger Holdoff                                      

The trigger release function can be used to generate stable and complex waveforms 

(such as amplitude modulation columns) for display. 'Release suppression' refers to the 

time difference between the oscilloscope detecting one trigger and preparing to detect 

another trigger. During the suppression period, the oscilloscope will not trigger. For a 

pulse train, the suppression time can be adjusted so that the oscilloscope only triggers 

on the first pulse of the train. 
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Figure 8.2 Schematic Diagram of Trigger Holdoff 

Set the Holdoff: 

 Open the [Trig Menu], click on the Holdoff menu label, and rotate the 

multi-functional knob V0 to adjust the trigger release value. 

 Click to Holdoff, and a numeric keyboard will appear. Set the value directly on the 

keyboard. 

The adjustable range of release time is 8ns to 10s. 

8.6 Trigger Type                                        

This series of machines has multiple triggering functions. Open the [Trig Menu], click 

on the Type menu, and select the trigger type. 

8.6.1 Edge Trigger                                             

The edge trigger type identifies the trigger by searching for the specified edge (Rising, 

Falling, Either) and voltage level on the waveform. 

 

Figure 8.3 Rising/Falling 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label, select "Edge ", and set the trigger settings. 
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After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger signal source, and trigger level) will be displayed at the top of the screen, 

which changes with the trigger setting. 

2. Source: 

Click on the Source menu tab to select CH1-CH4, EXT and Digital channels (D1.0-D1.3, 

D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Note: Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Slope Type: 

Click on the Slope Type menu label, and the edge types that can be selected include: 

rising edge, falling edge, or any edge. 

 Rising: Set the signal's rising edge to trigger. 

 Falling: Set the signal falling edge trigger. 

 Either: Set the signal to trigger the rising or falling edge. 

4. Holdoff: 

Click on the Holdoff menu tab, and set the trigger suppression by selecting the 

multi-functional knob V0 or directly setting the trigger suppression with the pop-up 

numeric keyboard. 

5. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

6. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

Note: 

The automatic setting button will set the trigger type to Edge trigger and the trigger 

slope to rising edge. 

8.6.2 Pulse Trigger                                           

Pulse width trigger sets the oscilloscope to trigger on a specified width of positive or 

negative pulses. You can set the trigger source, polarity (positive pulse width, negative 

pulse width), limiting conditions, and pulse width in this menu. 
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Figure 8.4 Positive Pulse Width/Negative Pulse Width 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "Pulse" to set the trigger. After selecting the 

trigger type, the current trigger setting information (including trigger type, trigger source, 

and trigger level) will be displayed at the top of the screen, which changes with the 

trigger setting. 

2. Source: 

Click on the Source menu tab to select CH1-CH4, EXT and Digital channels (D1.0-D1.3, 

D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Note: Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Polarity: 

Click on the Polarity menu tab to select either positive or negative polarity. 

 Positive(+): triggered when the positive polarity pulse width of the signal is set. 

 Negative(-): triggered when the signal negative polarity pulse width is set. 

4. When: 

Click on the When menu tab and select Trigger Condition. 

 =(Equal to time value): Only when the positive or negative pulse width of the input 

signal is equal to the set pulse width can it be triggered. 

For example, for a positive pulse, if t (actual pulse width) is set to 200ns, the 

waveform is triggered. 

 

 != (Not equal to time value): Only when the positive or negative pulse width of the 

input signal is not equal to the set pulse width can it be triggered. 
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 > (greater than the time value): Only when the positive or negative pulse width of 

the input signal is greater than the set pulse width can it be triggered. 

For example, for a positive pulse, if t (actual pulse width) is set to>100ns, the 

waveform is triggered. 

 

 <(less than the time value): Only when the positive or negative pulse width of the 

input signal is less than the set pulse width can it be triggered. 

For example, for a positive pulse, if t (actual pulse width) is set to<100ns, the 

waveform is triggered. 

 

5. Width: 

Click on the Width menu tab and select the multi-functional knob V0 to set the trigger 

release or the pop-up numeric keyboard to directly set the trigger release. The pulse 

width range available is from 8ns to 10s. 

6. Holdoff: 

Click on the Holdoff menu tab, and set the trigger suppression by selecting the 

multi-functional knob V0 or directly setting the trigger suppression with the pop-up 

numeric keyboard. 

7. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

8. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.3 Video Trigger                                           

Video triggering can be used to capture complex waveforms of most standard analog 

video signals and high-definition video signals. The trigger circuit can detect the vertical 

and horizontal intervals of the waveform and generate a trigger based on the selected 

video trigger setting. This series of oscilloscopes supports NTSC (National Television 

Standards Committee) and PAL. 

Click on [Trig Menu] in the button area to open the trigger menu. 
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1. Type: 

Click on the Type menu tab, select "Video", and set the trigger settings. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger signal source, and trigger level) will be displayed at the top of the screen, 

which changes with the trigger setting. 

2. Source: 

Click on the Source menu tab to select sources such as CH1, CH2, CH3, CH4. Only by 

selecting the channel that has been connected to the signal as the trigger source can 

stable triggering be obtained. 

3. Polarity: 

Click on the Polarity menu tab to select either positive or negative polarity. 

 Positive(+): triggered when the positive polarity pulse width of the signal is set. 

 Negative(-): triggered when the signal negative polarity pulse width is set. 

4. Standard: 

Click on the Standard menu tab and select the desired video standard. The video 

standards supported by this series of oscilloscopes include NTSC, PAL/SCEAM. 

Table 8.1 Video Standard 

Video Standard Frame Frequency  Scan Type TV Scan Line 

NTSC 30 Interlaced Scan 525 

PAL/SECAM 25 Interlaced Scan 625 

5. Sync: 

Click on the Sync menu tab and select the desired field or line (ScanLine, Line, Odd, 

Even, AllFields) to trigger the signal. 

 ScanLine: displays a complete line, including a portion of the previous and next 

lines. The oscilloscope is triggered at any line. 

 Line: Display a complete line, including a portion of the previous and next lines. 

Select a specified number of rows for the oscilloscope to trigger based on user 

selection. 

 Odd: displays multiple fields and the oscilloscope only triggers on odd fields. 

 Even: display multiple fields and the oscilloscope only triggers on even numbered 

fields. 

 AllFields: Display multiple fields and trigger the oscilloscope on any field. 

6. Line: 

Click on the Line number menu tab and set the line number in the field to be triggered. 

When selecting the synchronization method as the number of lines, you can specify the 
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number of lines. The range of line count settings is related to the currently selected 

video standard, with settings ranging from 1 to 525 (NTSC) and 1 to 625 (PAL/SECAM). 

7. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

8. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.4 Slope Trigger                                             

Slope triggering sets the positive or negative slope triggering of the oscilloscope from 

one level to another within a specified time. 

As shown in the figure below, we define the time difference between the two points (A 

and B) where the high and low trigger levels intersect with the rising (falling) edge of the 

waveform as the positive (negative) slope time. 

 

Figure 8.5 Positive Slope Time/Negative Slope Time 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "Slope" to set the trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger source, and trigger level) will be displayed at the top of the screen, which 

changes with the trigger setting. 

2. Source: 

Click on the Source menu tab to select sources such as CH1, CH2, CH3, CH4. Only by 

selecting the channel that has been connected to the signal as the trigger source can 

stable triggering be obtained. 

3. Slope Type: 

Click on the Slope Type menu tab to select rising and falling edges. 
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 Rising: Set the signal slope condition to trigger with a positive slope. 

 Falling: Set the signal slope condition to trigger with a negative slope. 

4. When: 

Click on the When menu tab and select Trigger Condition. 

 <(less than time value): Only when the positive or negative slope time of the input 

signal is less than the set time value can it be triggered. 

 >(Greater than time value): It can only be triggered when the positive or negative 

slope time of the input signal is greater than the set time value. 

 != (Not equal to time value): When the positive or negative slope time of the input 

signal is not equal to the set time value. 

 =(Equal to time value): When the positive or negative slope time of the input signal 

is equal to the set time value. 

5. Time: 

Click on the Time menu tab and set the trigger release by selecting the multi-functional 

knob V0 or directly set it on the pop-up numeric keyboard. The slope time range 

available is from 8ns to 10s. 

6. Level Select: 

Click on the Level Select menu tab, and the level selections are: Level A, Level B, and 

Level AB. 

7. Holdoff: 

Click on the Holdoff menu tab, and set the trigger suppression by selecting the 

multi-functional knob V0 or directly setting the trigger suppression with the pop-up 

numeric keyboard. 

8. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

9. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

 

8.6.5 Overtime Trigger                                        

Triggered when the time interval (△T) from the rising edge (or falling edge) of the input 

signal to the end of the adjacent falling edge (or rising edge) through the triggering level 

is greater than the set timeout time. As shown in the following figure: 
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Figure 8.6 Overtime Trigger 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "Overtime" to set the trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger source, and trigger level) will be displayed at the top of the screen, which 

changes with the trigger setting. 

2. Source: 

Click on the Source menu tab to select CH1-CH4, EXT and Digital channels (D1.0-D1.3, 

D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Slope type: 

Click on the Slope Type menu tab to select rising and falling edges. 

 Rising: Start timing by triggering the level on the rising edge of the input signal. 

 Falling: Start timing by triggering the level at the falling edge of the input signal. 

4. Timeout: 

Click on the Timeout time menu tab, and set the trigger release by selecting the 

multi-functional knob V0 or the pop-up numeric keyboard to directly set it. The timeout  

range available is from 8ns to 10s. 

5. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

6. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_Mode
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8.6.6 Window Trigger                                         

Window triggering provides high and low trigger levels. When the input signal passes 

the high or low trigger level, the oscilloscope triggers. 

 

Figure 8.7 Window Trigger 

 If both the high and low levels are within the waveform range, the waveform is 

triggered on the rising or falling edge at the same time. 

 If the high level is within the waveform range and the low level is outside the 

waveform range, the waveform will only trigger on the rising edge. 

 If the high level is outside the waveform range and the low level is within the 

waveform range, the waveform will only trigger on the falling edge. 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "Window trigger" to set the trigger. After 

selecting the trigger type, the current trigger setting information (including trigger type, 

trigger signal source, and trigger level) will be displayed at the top of the screen, which 

changes with the trigger setting. 

2. Source: 

Click on the Source menu tab and select CH1-CH4. Only by selecting the channel that 

has been connected to the signal as the trigger source can stable triggering be 

obtained. 

3. Level Select: 

After setting the triggering conditions, it is necessary to adjust the triggering level to 

correctly trigger the signal and obtain a stable waveform. 

Select the Level Select type from the level selection menu tab. 

 Level A: Only adjust the upper limit of the trigger level, while keeping the lower limit 

of the trigger level unchanged. 

 Level B: Only adjust the lower limit of the trigger level, while keeping the upper limit 

of the trigger level unchanged. 

 Level AB: Adjust both the upper and lower trigger levels simultaneously, keeping 

the trigger level difference (i.e. the difference between the upper and lower trigger 

levels) unchanged. 

4. Holdoff: 

Please refer to the introduction in the section on Trigger Holdoff for specific settings 
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related to triggering release. 

5. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

6. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.7 Logic Trigger                                          

Pattern triggering requires setting the logical values of each channel and the logical 

relationships between channels (AND, OR, NOT, etc.). When the logical relationship is 

met and the set time conditions are met, triggering occurs when the edges of any 

channel change. 

The logical values of each channel can be set to: high (higher than the trigger level), low 

(lower than the trigger level), and none (unrelated). 

Click on [Trig Menu] in the button area to open the trigger menu. 

  

1. Type: 

Click on the Type menu label and select " Pattern Trigger" to set the Pattern trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger source, and trigger level) will be displayed at the top of the screen, which 

changes with the trigger setting. 

2. Source: 

Click on the Source menu tab and select CH1-CH4. Only by selecting the channel that 

has been connected to the signal as the trigger source can stable triggering be 

obtained. 

file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_Mode
file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_LEVEL
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3. Condution: 

Click on the Logic Condition menu tab and select: H, L, X, Rising, Falling, or Either. 

 H: Set the selected channel code value to "1", which means the voltage level is 

higher than the trigger level/threshold level of the channel. 

 L: Set the selected channel code value to "0", which means the voltage level is lower 

than the trigger level/threshold level of the channel. 

 X: Set the selected channel code value to "X", which means that the channel is not 

part of the code. When all channels in the code are set to "ignore", the oscilloscope 

will not trigger. 

 Rising edge: Set the code pattern to the rising edge on the selected channel. 

 Descending edge: Set the code pattern to the descending edge on the selected 

channel. 

 Arbitrary edge: Set the code pattern to any edge on the selected channel. 

4. Logic type: 

Click on the Logic type menu tab to select: OR, AND. 

5. Holdoff: 

Please refer to the introduction in the section on Trigger Holdoff for specific settings 

related to Holdoff. 

8.6.8 Runt Trigger                                              

Under amplitude trigger is used to trigger pulses that cross one trigger level but do not 

cross another trigger level, as shown in the following figure: 

 

Figure 8.8 Runt Trigger 

 Forward under amplitude: The pulse spans the low level but not the high level. 

 Negative under amplitude: The pulse crosses the high level without crossing the 

low level. 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "Runt trigger" to set the under amplitude pulse 

trigger. After selecting the trigger type, the current trigger setting information (including 

trigger type, trigger signal source, and trigger level) will be displayed at the top of the 

screen, which changes with the trigger setting. 
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2. Source: 

Click on the Source menu tab and select CH1-CH4. Only by selecting the channel that 

has been connected to the signal as the trigger source can stable triggering be 

obtained. 

3. Polarity: 

Select the Polarity of the pulse that can trigger the under amplitude pulse in the polarity 

menu tab. 

 Positive(+): triggered on a forward under amplitude pulse. 

 Negative(-): triggered on a negative under amplitude pulse. 

4. When: 

Select the trigger limit condition for under amplitude pulse triggering in the When menu 

tab. 

 >[Greater than the set width value]: Only when the negative or positive pulse width 

is greater than the set width can it be triggered (with a pulse width error of 5%). 

 <[Less than the set width value]: Only when the negative or positive pulse width is 

less than the set width can it be triggered (with a pulse width error of 5%). 

 =[Equal to the set width value]: Only when the negative or positive pulse width is 

equal to the set width can it be triggered (with a pulse width error of 5%). 

 !=  [Not equal to the set width value]: Only when the negative or positive pulse 

width is not equal to the set width can it be triggered (with a pulse width error of 

5%). 

5. Width: 

Click on the Width menu tab and set the width value directly by rotating the 

multi-functional knob V0 or the pop-up numeric keyboard. 

6. Level Select: 

After setting the triggering conditions, it is necessary to adjust the triggering level to 

correctly trigger the signal and obtain a stable waveform. 

Select the Level Select type from the level selection menu tab. 

 Level A: Only adjust the upper limit of the trigger level, while keeping the lower limit 

of the trigger level unchanged. 

 Level B: Only adjust the lower limit of the trigger level, while keeping the upper limit 

of the trigger level unchanged. 

 Level AB: Adjust both the upper and lower trigger levels simultaneously, keeping 

the trigger level difference (i.e. the difference between the upper and lower trigger 

levels) unchanged. 

7. Holdoff: 

Please refer to the introduction in the section on Trigger Holdoff for specific settings 
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related to triggering release. 

8. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

9. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.9 Overamp Trigger                                       

Overamp trigger provides a high trigger level and a low trigger level. The instrument 

triggers when the input signal passes through the high trigger level or the low trigger 

level. 

Click on [Trig Menu] in the button area to open the trigger menu. 

 

Figure 8.9 Runt Trigger 

1. Type: 

Click on the Type menu label and select "Overamp trigger" to set the over amplitude 

pulse trigger. After selecting the trigger type, the current trigger setting information 

(including trigger type, trigger signal source, and trigger level) will be displayed at the 

top of the screen, which changes with the trigger setting. 

2. Source: 

Click on the Source menu tab and select CH1-CH4. Only by selecting the channel that 

has been connected to the signal as the trigger source can stable triggering be 

obtained. 

3. Polarity: 

Select the Polarity of the pulse that can trigger the under amplitude pulse in the polarity 

menu tab. 

 Positive(+): triggered on a forward under amplitude pulse. 

 Negative(-): triggered on a negative under amplitude pulse. 

4. When: 
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Select the trigger limit condition for under amplitude pulse triggering in the When menu 

tab. 

 >[Greater than the set width value]: Only when the negative or positive pulse width 

is greater than the set width can it be triggered (with a pulse width error of 5%). 

 <[Less than the set width value]: Only when the negative or positive pulse width is 

less than the set width can it be triggered (with a pulse width error of 5%). 

 =[Equal to the set width value]: Only when the negative or positive pulse width is 

equal to the set width can it be triggered (with a pulse width error of 5%). 

 != [Not equal to the set width value]: Only when the negative or positive pulse width 

is not equal to the set width can it be triggered (with a pulse width error of 5%). 

5. Width: 

Click on the Width menu tab and set the width value directly by rotating the 

multi-functional knob V0 or the pop-up numeric keyboard. 

6. Level Select: 

After setting the triggering conditions, it is necessary to adjust the triggering level to 

correctly trigger the signal and obtain a stable waveform. 

Select the Level Select type from the level selection menu tab. 

 Level A: Only adjust the upper limit of the trigger level, while keeping the lower limit 

of the trigger level unchanged. 

 Level B: Only adjust the lower limit of the trigger level, while keeping the upper limit 

of the trigger level unchanged. 

 Level AB: Adjust both the upper and lower trigger levels simultaneously, keeping 

the trigger level difference (i.e. the difference between the upper and lower trigger 

levels) unchanged. 

7. Holdoff: 

Please refer to the introduction in the section on Trigger Holdoff for specific settings 

related to triggering release. 

8. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

9. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 
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8.6.10 Delay Trigger                                             

Delay triggering requires setting source A and source B separately. When the time 

difference (△T) between the edge set by source A (edge A) and the edge set by source 

B (edge B) meets the preset time limit, the oscilloscope triggers, where edge A and 

edge B must be adjacent edges. 

 

Figure 8.10 Delay Trigger 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "Delay Trigger" to set the delay trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger source, and trigger level) will be displayed at the top of the screen, which 

changes with the trigger setting. 

2. Source A and Source B: 

 Source A: 

Click on the menu tab of Source A and select CH1-CH4, EXT and Digital channels 

(D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

 Source B: 

Click on the menu tab of Source B and select CH1-CH4, EXT and Digital channels 

(D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Edge A and Edge B: 

 Edge A: 

Click on the Edge A menu label to select the trigger edge type of source A during 

delayed triggering, and you can choose either the rising or falling edge. 
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 Edge B: 

Click on the Edge B menu label to select the trigger edge type of source B during 

delayed triggering, and you can choose either the rising or falling edge. 

4. When: 

Select the time limit condition for delayed triggering in the When menu tab. 

 = [Equal to the set width value]: Only when the time difference between the set 

edges is equal to the set width can it be triggered (with a pulse width error of 5%). 

 != [Not equal to the set width value]: Only when the time difference between the set 

edges is not equal to the set width can it be triggered (pulse width error is 5%). 

 >[Greater than the set width value]: Only when the time difference between the set 

edges is greater than the set width can it be triggered (with a pulse width error of 

5%). 

 < [Less than the set width value]: Only when the time difference between the set 

edges is less than the set width can it be triggered (with a pulse width error of 5%). 

5. Width: 

Click on the menu label for Width, and set the width value directly by rotating the 

multi-functional knob V0 or the pop-up numeric keyboard. 

6. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

7. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.11 Setup/Hold Trigger                                        

Establishing a hold trigger requires setting the clock channel and data channel 

separately. The establishment time starts from the time when the data channel crosses 

the power generation level and ends when the designated clock channel edge arrives; 

The holding time starts when the designated clock channel edge arrives and ends when 

the data channel crosses the touch power generation level again (as shown in the 

following figure). When the establishment time or holding time is less than the preset 

time, the oscilloscope will trigger. 
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Figure 8.11 Setup/Hold Trigger 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select " Setup/Hold " to set the trigger for establishing 

hold. After selecting the trigger type, the current trigger setting information (including 

trigger type, trigger source, and trigger level) will be displayed at the top of the screen, 

and it will change with the change of the trigger setting. 

2. Clock source: 

Click on the SCL menu tab to select CH1-CH4, EXT and Digital channels (D1.0-D1.3, 

D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Slope Type: 

Click on the Slope menu tab to select the desired clock edge type, which can be 

selected as either the rising or falling edge. 

4. Data source: 

Click on the SDA menu tab and select CH1-CH4, EXT and Digital channels (D1.0-D1.3, 

D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

5. Data Type: 

Click on the Data Type menu tab to set the effective code type of the data signal. It can 

be set to H (high level) or L (low level). 

6. When: 

In the When menu tab, select Create Hold Trigger Condition. 

 Setup: When the establishment time is less than the set value, the oscilloscope 
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triggers. 

 Hold: When the hold time is less than the set value, the oscilloscope triggers. 

7. Width: 

Click on the menu label for Width, and set the width value directly by rotating the 

multi-functional knob V0 or the pop-up numeric keyboard. 

8. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

9. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.12 Pattern Trigger                                     

Identify triggering conditions by searching for specified code patterns. The code pattern 

is a combination of channel logic 'and', and each channel can be set as H (high), L (low), 

X (ignored). You can also specify one channel in the pattern as the rising edge or falling 

edge (only one edge can be specified). After specifying the edge, if the code patterns of 

other channels are judged as "true" (i.e. the actual code pattern is consistent with the 

preset code pattern), the oscilloscope will trigger on the specified edge. If no edge is 

specified, the oscilloscope will trigger on the last edge that makes the code pattern 

"true". If all channel codes are set to 'ignore', the oscilloscope will not trigger. 

 

Figure 8.12 Schematic Diagram of Pattern Trigger 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu tab, select "Pattern trigger", and set the Pattern trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger source, and trigger level) will be displayed at the top of the screen, and will 

change with the change of trigger settings. 

2. Source: 

Click on the Source menu tab and select CH1-CH4, digital channels (D1.0-D1.3, 
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D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Code: 

Click on the Code menu tab and select the code type of the currently selected channel. 

You can choose from the following options: H,L,X. 

 H: Set the selected channel code value to "1", which means the voltage level is 

higher than the trigger level/threshold level of the channel. 

 L: Set the selected channel code value to "0", which means the voltage level is 

lower than the trigger level/threshold level of the channel. 

 X: Set the selected channel code value to "X", which means that the channel is not 

part of the code. When all channels in the code are set to "ignore", the oscilloscope 

will not trigger. 

4. Holdoff: 

Please refer to the introduction in the section on Trigger Holdoff for specific settings 

related to Holdoff. 

5. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

6. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.13 Nth Edge                                           

Triggered on the Nth edge after the specified idle time. For example, in the waveform 

shown in the following figure, if it is necessary to trigger on the second rising edge after 

a specified idle time (the time between adjacent rising edges), the idle time should be 

set to P<idle time<M. Where M is the time between the first rising edge and the previous 

rising edge, and P is the maximum time between the rising edges involved in counting. 
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Figure 8.13 Schematic Diagram of Nth Edge Trigger 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu tab, select "Nth Edge", and set the trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger source, and trigger level) will be displayed at the top of the screen, and will 

change with the change of trigger settings. 

2. Source: 

Click on the Source menu tab and select CH1-CH4, EXT and Digital channels 

(D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Slope Type: 

Click on the Slope Type menu tab and select either rising edge or falling edge. 

Rising edge: Triggered at the rising edge of the input signal and when the voltage level 

meets the set triggering level. 

Falling edge: Triggered at the falling edge of the input signal and when the voltage level 

meets the set triggering level. 

4. Idle Time: 

Click on the Idle Time menu tab to set the idle time before starting edge counting in the 

Nth edge trigger, and set the idle time by rotating the multifunction knob V0 or the 

pop-up numeric keypad. 

5. Edges: 

Click on the Edges menu tab to set the specific value of "N" in the Nth edge trigger. Set 

the idle time by rotating the multifunction knob V0 or the pop-up numeric keypad, with a 

range of 1 to 65535. 

6. Triggering inhibition: 

Please refer to the introduction in the section on Trigger Holdoff for specific settings 

related to Holdoff. 
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7. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

8. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.14 UART Trigger                                       

UART bus is a serial communication method used for data transmission between 

computers or between computers and terminals. 

The UART serial protocol transmits a character as a frame of data, with a frame 

structure consisting of 1 bit start bit, 5-8 bits data bit, 1 bit check bit, and 1-2 bits stop bit. 

The format is shown in the following figure. This series of oscilloscopes can trigger 

when detecting frame start, frame end, data, verification errors, and errors of UART 

signals. 

 

Figure 8.14 Schematic Diagram of UART Protocol 

The meanings of each of them are as follows: 

Start bit: First, a logical "0" signal is sent out, indicating the beginning of the character 

transmission. 

Data bits: It can be a 5 to 8-bit logical "0" or "1". 

Check bit: After adding this bit to the data bit, the number of digits of "1" should be an 

even number (even check) or an odd number (odd check). 

Stop bit: It is the end flag of a character data. It can be a high level of 1 bit, 1.5 bits or 2 

bits. 

Idle bit: In the logical "1" state, it indicates that there is no data transmission on the 

current line. 

 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 
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Click on the Type menu label and select "UART trigger" to set UART trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger signal source, and trigger level) will be displayed at the top of the screen, 

which changes with the trigger setting. 

2. Source: 

Click on the Source menu tab and select CH1-CH4, EXT and Digital channels 

(D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. When: 

Select the desired trigger condition in the When menu tab. 

 Start: Triggered at the start position of the frame. 

 Stop: Triggered at the end of the frame position. 

 Data: Triggered when the data reception is completed and the received data 

matches the data set by the user. 

 Check Error: Triggered when the data reception is completed and the verification 

result does not match the data set by the user. 

 Error: Triggered when an error frame is detected. 

4. Idle Level: 

Click the Idle Level menu and select the idle level as high or low. 

5. Baud Rate: 

Click on the Baud Rate menu tab and select the preset baud rate from the pop-up sub 

options. Alternatively, click again to pop up the numeric keypad and directly enter the set 

baud rate. 

6. Data Bits: 

Click on the Data Bits menu tab and select the desired data width. The data width 

refers to the number of bits of data per frame. The data width can be selected as 5 bit, 6 

bit, 7 bit, or 8 bit. 

7. Data: 

Click on the Data menu tab and set the data directly by rotating the multi-functional knob 

V0 or the pop-up numeric keyboard. 

8. Parity: 

Click on the Parity menu tab, select polarity, and you can choose None, Odd, or Even. 

9. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 



To Trigger the Oscilloscope 

  EN 

HRDO2000 User manual                                              Copyright © Qingdao Hantek Electronic Co., LTD 

78 

refer to descriptions in Trigger Mode. 

10. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.15 LIN Trigger                                          

This oscilloscope can be triggered on the synchronous field of LIN signals, as well as on 

designated identifiers, data, or frames. 

The format of the LIN bus data frame is shown in the following figure. 

 

Figure 8.15 Data Frame Format of the LIN Bus 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "LIN trigger" to set the LIN trigger. 

After selecting the trigger type, the current trigger setting information, including trigger 

type, trigger source, and trigger level, will be displayed at the top of the screen, and will 

change with the change of the trigger setting. 

2. Source: 

Click on the Source menu tab and select CH1-CH4, EXT and Digital channels 

(D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. When: 

Click on the When menu tab to select the desired trigger condition. 

 Interval Field: Triggered by the edge after the end of LIN interval. 

 Sync Field: Triggered upon completion of LIN sync field data reception. 

 ID Field: triggered after receiving data from LINID field. 

 Sync Code Error: Triggered when the LIN synchronization field data reception is 

completed but the synchronization field data is not equal to 0x55. 

 Identifier: Triggered when the LINID field data is received and the ID data is equal 

to the user set ID. 

 ID And Data: LIN data is received normally, and both ID and data are triggered by 

the user's set data. 

file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_Mode
file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_LEVEL


  To Trigger the Oscilloscope 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

79 

4. Baud Rate: 

Click on the Baud Rate menu tab and select the preset rate from the pop-up sub 

options. 

5. ID: 

Click on the ID menu tab and set the ID value by rotating the multi-functional knob V0 or 

the pop-up numeric keyboard. 

6. Data: 

Click on the Data menu tab and set Data 1, Data 2, Data 3, and Data 4 by rotating the 

multifunctional knob V0 or the pop-up numeric keypad. 

7. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

8. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.16 CAN Trigger                                          

This oscilloscope can be triggered at the beginning of the CAN signal frame, at a 

specified type of frame (such as remote frame, data frame, etc.), or at a specified type of 

error frame. The format of the CAN bus data frame is shown in the following figure. 

 

Figure 8.16 Data Frame Format of the CAN Bus 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "CAN trigger" to set the CAN trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger signal source, and trigger level) will be displayed at the top of the screen, 

which changes with the trigger setting. 

2. Source: 

Click on the Source menu tab and select CH1-CH4, EXT and Digital channels 

(D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 
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Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. When: 

Click the When menu button to select the desired trigger condition. 

 Start Bit: Triggered at the beginning of a data frame. 

 Remote ID: Triggered on the remote frame with the specified ID. 

 Data Frame ID: Triggered on the data frame with the specified ID. 

 Frame ID: Triggered on the frame with the specified ID. 

 ID and Data: Triggered on the data frame of the specified ID and the data frame of 

the specified data. After selecting the frame ID and data, click on the definition 

menu tab and select either data or ID. 

 Error Frame: Triggered on the error frame. 

 All Error: Triggered on all errors. 

 Ack Error: Triggered on confirmation error. 

 Overload Frame: Triggered on an overload frame. 

4. Baud Rate: 

Click on the Baud Rate menu tab and select the preset rate from the pop-up menu. 

5. ID: 

Click on the ID menu tab and set the ID value by rotating the multi-functional knob V0 or 

the pop-up numeric keyboard. 

6. Data: 

Click on the Data menu tab and set Data 1, Data 2, Data 3, and Data 4 by rotating the 

multifunctional knob V0 or the pop-up numeric keypad. 

7. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

8. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.17 SPI Trigger                                          

Under the SPI trigger type, when the timeout conditions are met, the oscilloscope 

triggers when it searches for the specified data. SPI trigger is a high-speed, full duplex, 

synchronous communication bus. When using SPI trigger, it is necessary to specify the 
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serial clock line (CLK) and serial data line (MISO). 

 

Figure 8.17 Sequential Chart of SPI Bus 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "SPI trigger" to set the SPI trigger. After 

selecting the trigger type, the current trigger setting information (including trigger type, 

trigger source, and trigger level) will be displayed at the top of the screen, which 

changes with the trigger setting. 

2. Source: 

Click on the CLK and MISO menu tabs respectively to select CH1-CH4, EXT and  

digital channels (D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3) specify the source for 

the serial clock line (CLK) and serial data line (MISO), respectively. 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

3. Slope type: 

Click on the Slope type menu tab to select the desired clock edge type. 

 Rising: Sampling MISO data at the rising edge of the clock. 

 Falling: Sampling MISO data at the falling edge of the clock. 

4. Timeout: 

Click on the Timeout menu tab and enter the set value directly by rotating the 

multi-functional knob V0 or the pop-up numeric keyboard. 

5. Bit X: 

Click on the Bit X menu tab to set the data bits that need to be operated on. 

6. Data bits: 

Click on the Data bits key and use the pop-up numeric keypad to set the number of 

digits in the serial data string. The number of digits in a string can be set to any integer 

between 4 and 32. 

7. Trigger Mode: 

In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

8. Trigger Level: 
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Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

8.6.18 I2C Trigger                                          

I2C (Inter Integrated Circuit Bus) integrated circuit bus, designed by NXP (formerly 

PHILIPS) company, is mainly used for master-slave communication between master 

controllers and slave devices. It is used in small data volume situations, has short 

transmission distance, and can only have one host at any time. I2C address addressing 

mode is divided into 7-bit addressing mode and 10 bit addressing mode. 

7-bit addressing: In the 7-bit addressing process, the slave address starts transmission 

from the first byte after the start signal. The first 7 bits of this byte are the slave address, 

and the 8th bit is the read write bit, where 0 represents write and 1 represents read. 

10 bit addressing: The 10bit and 7bit addressing of the I2C bus are compatible, allowing 

devices that use both 7bit and 10bit address modes on the same bus. When 

transmitting a 10bit address, the first byte is a special reserved address to indicate that 

the current transmission is a 10bit address. 

 

Figure 8.18 Schematic Diagram of I2C Protocol 

Click on [Trig Menu] in the button area to open the trigger menu. 

1. Type: 

Click on the Type menu label and select "I2C trigger" to set the I2C trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

type, trigger source, and trigger level) will be displayed at the top of the screen, which 

changes with the trigger setting. 

2. Clock source: 

Click on the SLK menu tab and select CH1-CH4, EXT and digital channels (D1.0-D1.3, 

D2.0-D2.3, D3.0-D3.3, D4.0-D4.3) specify the source for the serial clock line (CLK) and 

serial data line (MISO), respectively. 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_LEVEL
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3. Data source: 

Click on the SDA menu tab and select CH1-CH4, EXT and digital channels (D1.0-D1.3, 

D2.0-D2.3, D3.0-D3.3, D4.0-D4.3) specify the source for the serial clock line (CLK) and 

serial data line (MISO), respectively. 

Digital channel: Only digital channels that have been inserted and enabled can be 

selected. 

Only by selecting the channel that has been connected to the signal as the trigger 

source can stable triggering be obtained. 

4. When: 

Click on the When menu tab to select the desired trigger condition. 

 Start: IIC start condition trigger detected. (Triggered when SCL is high and SDA 

data jumps from high level to low level.) 

 Stop: IIC stop condition triggered detected. (Triggered when SCL is high and SDA 

data jumps from low to high.) 

 Restart: Triggered when a new start condition appears before the stop condition. 

 MissedAck: Triggered if SDA data is high during any SCL clock bit. 

 Address: Triggered to search for the set address value, triggered on the read/write 

bit. After selecting the address as the trigger condition: 

 Click the read/write direction key and select write, read, or read/write. When 

"8 Bits" is selected for the address bit width, this setting is not available. 

 Click on the address bit width to select the desired address bit width. The 

address bit width can be selected from 7 bits, 8 bits, or 10 bits. 

 Click on the address key and set the address value triggered by I2C through 

the pop-up numeric keypad. 

 Address and Data: Triggered when the IIC address is received and the data (4 

bytes of data) is equal to the user set value. (The oscilloscope simultaneously 

searches for the set address value and data value, and triggers when both address 

and data meet the conditions.) 

5. Address Bits: 

Click on the Addr Bits width menu tab to select the desired address bit width, which can 

be selected as either 7Bits or 10Bits. 

6. Address: 

Click on the Address menu label and set the address directly by rotating the 

multi-functional knob V0 or the pop-up numeric keyboard. 

9. Data: 

Click on the Data menu tab and set Data 1, Data 2, Data 3, and Data 4 by rotating the 

multifunctional knob V0 or the pop-up numeric keypad. 

10. Trigger Mode: 
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In Trigger [Mode] menu, select Auto, Normal, or Single as the trigger mode. For details, 

refer to descriptions in Trigger Mode. 

11. Trigger Level: 

Please rotate the Trigger Level knob to adjust the trigger level. For details, refer to 

descriptions in Trigger Level. The current trigger level is displayed in the trigger 

information label at the right top of the screen. 

 

file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_Mode
file:///C:/Users/Administrator/Desktop/HRDO2000%20UserManual2-1.docx%23_Trigger_LEVEL
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9 Math Operation                         

This series of oscilloscopes support algebraic, FFT, logical, and functional operations 

between various analog channel waveforms and digital filtering. 

You can enter the Math menu through the following methods: 

 Click [Math] in the button area to enter the mathematical operation menu. 

 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

FFT, and enter the FFT menu. 

This chapter includes: 

 Arithmetic Operations 

 FFT 

 Logic Operation 

 Function Operation 

 Digital Filtering 

 Expression 
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9.1 Arithmetic Operations                                 

The algebraic operations supported by this series of oscilloscopes include: A+B, A-B, 

A*B, A/B. 

 Addition: Add the signals from source A and source B point by point and display the 

calculation results. 

 Subtraction: Subtract the signals from source A and source B point by point and 

display the calculation results. 

 Multiplication: Multiply the signals of source A and source B point by point and 

display the calculation results. 

 Division: Divide the signals of source A and source B point by point and display the 

calculation results. 

1. Operator: 

Click on the Operator menu tab and select algebraic operations such as A+B addition, 

A-B subtraction, A * B multiplication, and A/B division. 

2. Operation: 

Click on the Operation menu tab and select on or off. 

3. Source A, Source B: 

After clicking on Source A or Source B, a menu will appear where you can select the 

source as CH1, CH2, CH3, CH4, or REF reference waveform, respectively. Channels in 

closed state cannot be selected. 

4. Offset: 

Click on the Offset menu label and set the offset by selecting the multi-functional knob 

V0 or directly setting the vertical offset for the calculation result display window using 

the pop-up numeric keyboard. 

5. Auto Setting: 

Click the AutoSetting button, and the instrument will automatically adjust the vertical 

gear and offset of the calculation results to the optimal value based on the current 

configuration, for the convenience of users' observation. 

6. Scale: 

Click on the Scale menu label, set the gear by selecting the multi-functional knob V0 or 

directly set the vertical gear for the calculation result display window using the pop-up 

numeric keyboard. 

7. Vertical expansion: 

Click on the Expand menu tab and select either GND or center. 

 GND: When changing the vertical gear, the mathematical operation waveform will 

expand or compress around the waveform zero point position. 
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 center: When changing the vertical gear, the mathematical operation waveform will 

expand or compress around the center of the screen. 

8. Invert: 

Click on the Invert menu tab to select whether to turn on or off the invert function, which 

is used to display waveform invert in the calculation result display window. 

9. Label: 

Click on the Label menu label and set it to display waveform labels in the calculation 

result display window. Please refer to the Label Setting section. 

 

Figure 9.1 Addition 

9.2 FFT                                                 

1. Operator: 

Click on the Operator menu tab and select FFT operation. 

2. Source: 

Click on the dropdown box of the information Source item to select the information 

source as CH1, CH2, CH3, or CH4. Channels in closed state cannot be selected. 

3. Offset: 

Click on the Offset menu label and set the offset by selecting the multi-functional knob 

V0 or directly setting the vertical offset for the calculation result display window using 

the pop-up numeric keyboard. 

4. Scale: 

Click on the Scale menu label, set the gear by selecting the multi-functional knob V0 or 
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directly set the vertical gear for the calculation result display window using the pop-up 

numeric keyboard. 

5. Auto settings: 

Click the AutoSetting button, and the instrument will automatically adjust the vertical 

gear and offset of the calculation results to the optimal value based on the current 

configuration, for the convenience of users' observation. 

6. Unit: 

Click on the Unit menu tab to select dBm/dBV or Vrms. 

7. X frequency range: 

In X, select the mode to determine the frequency range and set the frequency range. 

 Span Center: The frequency range refers to the screen width. Divide the frequency 

range by 10 to obtain the frequency of each grid. Click on the input box of the 

center frequency item to set the frequency of the frequency domain waveform 

corresponding to the horizontal center of the screen. The minimum value range is 

5Hz~5GHz, and the default value is 5MHz. Click on the input box of the frequency 

range item to set the frequency range of the frequency domain waveform, with a 

value range of 10Hz~5GHz and a default value of 10MHz. 

 Start End: The starting frequency refers to the frequency on the left side of the 

screen. Click on the input box of the starting frequency item to set the starting 

frequency of the frequency domain waveform. The value range is from 0Hz to the 

value of the ending frequency -10Hz, with a default value of 0Hz. The termination 

frequency refers to the frequency on the right side of the screen. Click on the input 

box of the termination frequency item to set the termination frequency of the 

frequency domain waveform. The value range is the starting frequency 

value+10Hz~5GHz, and the default value is 10MHz. 

8. Peak Search: 

Click on the Peak Search menu tab to enter the peak search settings menu. 

 Peak search: turned on or off 

 Peak number: Click on the input box for the Peak Number item and set the peak 

number using the pop-up numeric keypad. The value range is 1 to 15, with a 

default of 5. 

 Threshold: Click on the input box of the Threshold item and set the peak threshold 

through the pop-up numeric keyboard. The range of threshold values is related to 

the current FFT gear and offset. 

 Excursion: Click on the input box of the Excursion item to set the peak offset 

threshold. The minimum value of the offset threshold is 0, in dB. 

 Table Order: Click to select the Table Order to be sorted by peak size or frequency 

size. Sort by peak size by default. 

 Export: the interface jumps to the Save Settings menu, selects the file type, sets 

the file name, sets the window function, and saves. 
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9. Window: 

The window function can effectively reduce the spectral leakage effect. This series of 

oscilloscopes provide the following table, which shows five kinds of FFT window 

function. Each kind of window function has different characteristics and waveforms 

suitable for measurement. The selection needs to be based on the measured waveform 

and its characteristics. Click the menu of Window function item to select. 

Table 9.1 Window Function 

Window Function Characteristics 
Waveforms Applicable to the 

Window Function 

Rectangular 

Best frequency resolution. 

Poorest amplitude resolution. 

Similar to the situation when 

no window is applied. 

Transient or short pulse, the 

signal levels before and after 

the multiplication are basically 

the same. 

Sine waveforms with the same 

amplitudes and rather similar 

frequencies. 

Wide band random noise with 

relatively slow change of 

waveform spectrum. 

Hanning 

Better frequency resolution 

and poorer amplitude 

resolution compared with 

Rectangular. 

Sine, periodic, and narrow 

band random noise. 

Hamming 
A little bit better frequency 

resolution than Hanning. 

Transient or short pulse, the 

signal levels before and after 

the multiplication are rather 

different. 

Blackman-Harris 
Best amplitude resolution. 

Poorest frequency resolution. 

Single frequency signal, 

searching for higher order 

harmonics. 

Triangle Better frequency resolution. 

Measure the narrow band 

signal and that has strong 

noise interference. 

Flattop 
Measure the signals 

accurately. 

Measure the signal that has no 

accurate reference and 

requires an accurate 

measurement. 

10. Label: 

Click on the Label menu label and set it to display waveform labels in the calculation 

result display window. Please refer to the label section. 
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9.3 Logic Operation                                     

Click on the [MATH] menu, and the logical operations include: A&&B (AND), A | | B (OR), 

A ^ B (XOR), ! A (NOT). 

 A&&B: Perform logical AND operations on the waveform of the specified source 

point by point and display the results. When the voltage value of the source 

channel is greater than the threshold set by the corresponding channel during 

operation, it is determined as a logical "1", otherwise it is determined as a logical 

"0". The logical AND operation of two binary bits. 

 A | | B: Perform logical OR operations on the waveform of the specified source 

point by point and display the results. When the voltage value of the source 

channel is greater than the threshold set by the corresponding channel during 

operation, it is determined as a logical "1", otherwise it is determined as a logical 

"0". The logical OR operation of two binary bits. 

 A ^ B: Perform a logical XOR operation on the waveform of the specified source 

point by point and display the results. When the voltage value of the source 

channel is greater than the threshold set by the corresponding channel during 

operation, it is determined as a logical "1", otherwise it is determined as a logical 

"0". The logical XOR operation of two binary bits. 

 ! A: Perform logical 'not' operations on the waveform of the specified source point 

by point and display the results. When the voltage value of the source channel is 

greater than the threshold set by the corresponding channel during operation, it is 

determined as a logical "1", otherwise it is determined as a logical "0". The logical 

'not' operation of a binary bit. 

Table 9.2 Logic Operation 

A B A&&B A||B A^B !A 

0 0 0 0 0 1 

0 1 0 1 1 1 

1 0 0 1 1 0 

1 1 1 1 0 0 

1. Operator: 

Click on the Operator menu tab and select logical operation. 

2. Source A, Source B: 

After clicking on Source A or Source B, a menu will appear where you can select the 

source as CH1, CH2, CH3, CH4, or Ref reference waveform, respectively. Channels in 

closed state cannot be selected. 
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3. Offset: 

Click on the Offset menu label and set the offset by selecting the multi-functional knob 

V0 or directly setting the vertical offset for the calculation result display window using 

the pop-up numeric keyboard. 

4. Size: 

Click on the Size menu label and select the "Small", "Medium", or "Large" display mode. 

5. CH1 threshold, CH2 threshold, CH3 threshold, CH4 threshold: 

Set the threshold corresponding to the source channel, click on the 

Thre.CH1(Thre.CH2\ Thre.CH3\Thre.CH4) input box, and the setting method can be 

achieved by adjusting the multi-functional knob or directly setting the value on the 

numeric keyboard. 

6. Label: 

Used to display waveform labels in the calculation result display window. Display labels, 

label libraries, and labels. Please refer to the Label Setting section for the setting 

method. 

 

Figure 9.2 AND Operation 

9.4 Function Operation                                   

In the Math Operation menu, select from the drop-down menu of the operator item. The 

functions supported by this series of oscilloscopes include: Intg (integral), Diff 

(differential), Sqrt (square root), Lg (logarithm based on 10), Ln (natural logarithm), Exp 

(exponent), Abs (absolute value), AX+B (linear function). 

Intg: Calculate the integral of a specified source. For example, integration can be used 

to calculate the energy of a pulse or measure the area under a waveform. 
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 Diff: Calculate the discrete time derivative of a specified source. For example, 

differentiation can be used to calculate the instantaneous slope of a waveform. 

 Sqrt: Calculate the square root of the specified source waveform point by point and 

display the results. 

 Lg: Calculate the base 10 logarithm of the specified source waveform point by 

point and display the results. 

 Ln: calculate the natural logarithm of the specified source waveform point by point 

and display the results. 

 Exp: Calculate the index of the specified signal source waveform point by point and 

display the results. 

 Abs: Take the absolute value of the waveform of the specified signal source and 

display the result. 

 AX+B: calculate the linear function of the specified source waveform point by point 

and display the results. 

1. Operator: 

Click on the Operator menu tab and select logical operation. 

2. Source A: 

Click on the menu of Source A, and you can select channels with source CH1, CH2, 

CH3, CH4, or Ref reference waveform closed status that cannot be selected. 

3. Offset: 

Click on the Offset menu label and set the offset by selecting the multi-functional knob 

V0 or directly setting the vertical offset for the calculation result display window using 

the pop-up numeric keyboard. 

4. Scale: 

Click on the Scale label, set the gear by selecting the multi-functional knob V0 or 

directly set the vertical gear for the calculation result display window using the pop-up 

numeric keyboard. 

5. Auto Setting: 

Click the AutoSetting button, and the instrument will automatically adjust the vertical 

gear and offset of the calculation results to the optimal value based on the current 

configuration, for the convenience of users' observation. 

6. Integral Offset: 

Click on the Integral Offset menu tab and set the gear by selecting the multi-functional 

knob V0 or directly set the integral offset using the pop-up numeric keypad. 

7. Invert: 

Click on the Invert menu tab to select whether to turn on or off the invert function, which 

is used to display waveform invert in the calculation result display window. 

8. Label: 
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Click on the Label menu label and set it to display waveform labels in the calculation 

result display window. Please refer to the Label Setting section. 

 

Figure 9.3 Lg Operation 

9.5 Digital Filtering                                      

In the Math Operations menu, click on the Operator to select from the drop-down menu. 

The digital filtering supported by this series of oscilloscopes includes: LowPass, 

HighPass, BandPass, and BandStop. 

 LowPass: Only signals with frequencies lower than the current frequency limit are 

allowed to pass through. 

 HighPass: Only signals with frequencies higher than the current frequency lower 

limit are allowed to pass through. 

 BandPass: Only signals with frequencies higher than the current frequency lower 

limit and lower than the current frequency upper limit are allowed to pass through. 

 BandStop: Only signals with frequencies lower than the current frequency lower 

limit or signals higher than the current frequency upper limit are allowed to pass 

through. 
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1. Operator: 

Click on the Operator menu tab and select logical operation. 

2. Source A: 

Click on the menu of Source A to select a reference waveform with source CH1, CH2, 

CH3, CH4, or Ref. Channels in closed state cannot be selected. 

3. Offset: 

Click on the Offset menu label and set the offset by selecting the multi-functional knob 

V0 or directly setting the vertical offset for the calculation result display window using 

the pop-up numeric keyboard. 

4. Scale: 

Click on the Scale menu label, set the gear by selecting the multi-functional knob V0 or 

directly set the vertical gear for the calculation result display window using the pop-up 

numeric keyboard. 

5. Auto Setting: 

Click the AutoSetting button, and the instrument will automatically adjust the vertical 

gear and offset of the calculation results to the optimal value based on the current 

configuration, for the convenience of users' observation. 

6. Wc: 

Click on the wc menu tab and set it directly by selecting the multi-functional knob V0 or 

the pop-up numeric keyboard. 

7. Invert: 

Click on the Invert menu tab to select whether to turn on or off the invert function, which 

is used to display waveform invert in the calculation result display window. 
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Figure 9.4 LowPass Operation 
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9.6 Expression                                         

By selecting expressions from operators and editing working hours through the 

keyboard, multiple operators and sources can be freely combined to achieve more 

complex mathematical operations. 

   

1. Operator: 

Click on the Operator menu tab and select logical operation. 

2. Offset: 

Click on the Offset menu label and set the offset by selecting the multi-functional knob 

V0 or directly setting the vertical offset for the calculation result display window using 

the pop-up numeric keyboard. 

3. Scale: 

Click on the Scale menu label, set the gear by selecting the multi-functional knob V0 or 

directly set the vertical gear for the calculation result display window using the pop-up 

numeric keyboard. 

4. Edit: 

Click on the Edit menu tab, and the expression editing keyboard will pop up. Use the 

operation buttons to select the desired expression for calculation. 
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5. Step: 

Click on the Step menu label, and the setting method can be set by adjusting the 

multifunctional knob or directly setting the single step value on the numeric keyboard. 

6. CH1 threshold, CH2 threshold, CH3 threshold, CH4 threshold: 

Set the threshold corresponding to the source channel, click on the 

Thre.CH1(Thre.CH2\ Thre.CH3\Thre.CH4) input box, and the setting method can be 

achieved by adjusting the multi-functional knob or directly setting the value on the 

numeric keyboard. 

7. Label: 

Used to display waveform labels in the calculation result display window. Display labels, 

label libraries, and labels. Please refer to the Label Setting section for the setting 

method. 
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10 Measure                               

The voltage time coordinate graph displayed by the oscilloscope can be used to 

measure the displayed waveform. There are various methods for measuring, including 

screen grid scale, cursor, or automatic measurement. 

The menu can be accessed through the following methods: 

 Click on the button area [Meas] to enter the measurement menu. 

 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

Measure, and enter the measurement menu. 

This chapter includes: 

 Square Scale Measurement 

 Measurement Parameter 

 Measurement Settings 

 Quick Measurement after AUTO 

 Cursor Measurement 
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10.1 Square Scale Measurement                          

Grid scale: This method can be used to quickly and intuitively estimate the frequency 

and voltage amplitude of the waveform, and simple measurements can be made 

through the division of the grid chart and the scale coefficient. 

For example, simple measurements can be made by calculating the relevant primary 

and secondary scale divisions and multiplying them by the proportional coefficient. If it is 

calculated that there are 6 main vertical scale divisions between the maximum and 

minimum values of the waveform, and the scaling coefficient is known to be 

50mV/division, the peak to peak voltage can be calculated as follows: 

6 divisions × 50mV/division=300mV 

10.2 Measurement Parameter                             

10.2.1 Time Parameters                                          

 

1. Period: defined as the time between the middle threshold points of two consecutive, 

like-polarity edges. 

2. Frequency: defined as the reciprocal of period. 

3. Rise Time: indicates the time for the signal amplitude to rise from the threshold 

lower limit to the threshold upper limit. 

4. Fall Time: indicates the time for the signal amplitude to rise from the threshold 

upper limit to the threshold lower limit. 

5. +Width: indicates the time between the threshold middle value of a rising edge to 

the threshold middle value of the next falling edge. 

6. -Width: indicates the time between the threshold middle value of a falling edge to 

the threshold middle value of the next rising edge. 

7. +Duty: indicates the ratio of the positive pulse width to the period. 
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8. -Duty: indicates the ratio of the negative pulse width to the period. 

 

9. Bandwidth: The time from the first edge of the data source to the last edge of the 

data source. 

10. MaxTime: indicates the time that corresponds to the maximum value of the 

waveform (Vmax). 

11. MinTime: indicates the time that corresponds to the minimum value of the 

waveform (Vmin). 

10.2.2 Count Value Parameters                                  

1. Positive Pulse Count [+ Pulse Count]: The number of positive pulses rising from 

be-low the lower threshold to above the upper threshold. 

Threshold upper limit

Threshold lower limit

1 2 3 nn-1

 

2. Negative pulse number [- Pulse Count]: the number of negative pulses from above 

the upper threshold to below the lower threshold. 

 

Threshold upper limit

1 2 n-1 n

Threshold lower limit

 

3. Rise Pulse Count: The number of rising edges rising from below the lower 

threshold to above the upper threshold. 
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Threshold upper limit

Threshold upper limit

1 2 3 nn-1

 

4. Fall Pulse Count: The number of falling edges from the upper threshold to the 

lower threshold. 

 

Threshold upper limit

Threshold lower limit

1 2 n-1 n

 

5. Trigger Count: The number of rising (or falling) edges from the threshold. 

 

Threshold value

1 2 3 4 n-1 n

 

Note: The above measurement items are only applicable to analog channels. The 

de-fault values for the upper and lower thresholds are 90% and 10%, respectively. 
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10.2.3 Delay and Phase                                          

 

Data source A and data source B, namely data source A and data source B in the 

measurement settings menu, can be any channel in CH1-CH4. 

1. FRR [First Delay Rise Rise Rise]: ↑ A ->↑ B, the time difference between the 

first rising edge of data source A and data source B. 

2. FFF [First Delay Fall Fall]: ↓ A ->↓ B, the time difference between the first falling 

edge of data source A and data source B. 

3. FRF [First Delay Rise Fall]: ↑ A ->↓ B, the time difference between the first 

rising edge of data source A and the first falling edge of data source B. 

4. FFR [First Delay Fall Rise]: ↓ A ->↑ B, the time difference between the first 

falling edge of data source A and the first rising falling edge of data source B. 

5. LRR [Last Delay Rise Rise Rise]: ↑ A ->↑ B, the time between the first rising 

edge of data source A and the last rising edge of data source B. 

6. LRF [Last Delay Rise Fall]: ↑ A ->↓ B, the time between the first rising edge of 

data source A and the last falling edge of data source B. 

7. LFR [Last Delay Fall Rise]: ↓ A ->↑ B, the time between the first falling edge of 

data source A and the last rising edge of data source B. 

8. LFF [Last Delay Fall Fall]: ↓ A ->↓ B, the time between the first falling edge of 

data source A and the last falling edge of data source B. 

9. Positive phase difference [R-PhaseAB]: The phase difference on the rising edge 

between channels. 

10. Negative phase difference [F-PhaseAB]: The phase difference at the falling edge 

between channels. 
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10.2.4 Voltage Parameters                                       

 

1. Vmax: The voltage value from the highest point of the waveform to GND (ground). 

2. Minimum value [Vmin]: The voltage value from the lowest point of the waveform to 

GND (ground). 

3. Pk Pk: The voltage value from the highest point to the lowest point of the 

waveform. 

Double peak = Vmax - Vmin 

4. Vtop: The voltage value from the flat top of the waveform to GND (ground). 

5. Vbase: The voltage value from the flat bottom of the waveform to GND (ground). 

6. Vamp: The voltage value from the top to the bottom of the waveform. 

Amplitude = Vtop - Vbase 

7. Vmid: The actual voltage value corresponding to the intermediate value of the 

measurement threshold. 

8. Average: the arithmetic mean value of the whole waveform or gate area. 

9. Cycle Average: arithmetic mean value of the first cycle of the waveform. 

 

Among them, xi is the measurement result of the i-th point, and n is the number of 

measured points. 

10. Vrms: The root mean square value on the entire waveform or gating region. 

11. Per Vrms: The root mean square value within a period. 

Among them, xi is the measurement result of the i-th point, and n is the number of 

measured points. 

12. Fall Pre shot: The ratio of the difference between the minimum and bottom values 
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of the falling edge of a waveform and its amplitude. 

13. Fall Overshoot: The ratio of the difference between the maximum value of the 

falling edge of the waveform and the top value to its amplitude. 

14. Vrpr: The ratio of the difference between the minimum value of the falling edge of 

the waveform and the bottom value to the amplitude. 

15. Vfov: The ratio of the difference between the maximum value of the falling edge 

and the top value of the waveform to the amplitude. 

16. L@T: Voltage value at the trigger point. 

10.2.5 Other Parameters                                        

1. Positive slope: On the rising edge, divide the difference between the high and low 

values by the corresponding time. 

2. Negative slope: On the falling edge, divide the difference between the low and high 

values by the corresponding time. 

3. DC positive area: The sum of the areas of the waveform within the screen where 

the value is greater than zero. 

4. DC negative area: The sum of the areas of the waveform within the screen where 

the value is less than zero. 

5. DC effective area: the effective area of the waveform inside the screen. 

6. Absolute DC area: The absolute area of the waveform inside the screen. 

7. Communication positive area: The sum of the areas of the waveform on the screen 

where the value is greater than the average. 

8. Communication negative area: The sum of the areas of the waveform within the 

screen where the value is less than the average. 

9. Effective communication area: The effective area of the communication component 

within the screen. 

10. Absolute communication area: The absolute area of the communication 

component within the screen. 

10.3 Measurement Settings                                

10.3.1 Add                                                     

Click the [Meas] button to enter the measurement settings menu. 

1. Measurement Category: 

Click on [Meas] -> Add -> Category to select three measurement categories: 

Horizontal, Vertical, and Other. At the same time, the specific measurement parameters 

in the measurement categories are displayed on the screen, as shown in the following 

figure. You can also turn the multi-functional knob V0 in the measurement category area 
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to select horizontal, vertical, or other measurement categories, and then press to switch 

to that measurement category. 

Horizontal: Freq, Period, RiseT, FallT, PosPW, NegPW, PDuty, NDuty, BWidth, 

MaxTime, MinTime, +Edges, -Edges, +Pulses, -Pulses, TrigCnt, +slope, -slope. 

Vertical: VMean, VMax, VMin, PkPk, VTop, VMid, VBase, VAmp, VRms, Vovr, Vper, 

PVRms, PVMeas, Vfov, Vrpr, L@T. 

Other: FRR, FFF, FRF, FFR, LRR, LRF, LFR, LFF, +Phase, -Phase, +AreaDC, -AreaDC, 

perAreaDC, absAreaDC, +AreaAC, -AreaAC, perAreaAC,absAreaAC. 

  

 

2. Source A, B: 

 Horizontal and vertical parameter measurement 

Press [Meas] -> Add -> Source A, rotate the multi-functional knob to select the channel 

to be measured, and press the knob to select it. You can also continuously press the 

source A button to switch to the current measurement source, or use the touch screen 

function to select using touch gestures. Optional channels include CH1-CH4, 

Math1-Math4, D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3, Ref. 

 Measurement of other parameters 

Press [Meas] -> Add -> Source A and Source B to set the two source channels for the 

current measurement type. Optional channels include CH1-CH4, Math1-Math4, 

D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3, Ref. 

3. Remove: 

Press [Meas] -> Add -> Remove to enter the delete detailed menu settings. 
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10.3.2 Remove                                                

Press [Meas] -> Remove to enter the delete settings menu. 

1. Remove 

Click on the Remove menu tab to delete the last measurement item added. Note that 

pressing this soft key once will only delete one measurement item. When deleting a 

measurement item, the measurement result at the bottom of the screen will shift to the 

left and display one item. 

2. Remove All 

Click to Remove All menu labels and delete all displayed measurement items with one 

click. 

3. Statistic 

Click on the Statistic menu tab to open the statistics function. For a detailed 

introduction, please refer to the Statistics section. 

10.3.3 Statistic                                                

Calculate and display the current value (Cur), average value (Avg), maximum value 

(Max), minimum value (Min), standard deviation (Dev), count (Cnt), and histogram of 

the measurement results, as shown in the following figure. 

After turning on the statistical histogram, the bar histogram at the bottom of the 

statistical area displays the number of measurement results counted in the form of 

columns, allowing users to visually view the distribution of the measured values of this 

parameter. The color of the histogram matches the color of the specified source. 

 

1. Statistic 

Click on the Statistic menu tab to open the statistics function. 

2. Reset Stat. 

Click on the Reset Stat. menu tab to clear historical data and perform statistics again. 

3. Count 

Click on the Count menu tab, rotate the multi-functional knob, or set the number of 

counts through the pop-up numeric keypad. The value range is 2 to 100000, with a 
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default of 10. 

10.3.4 All Measure                                             

All measurements can display all the parameters of the current measurement source on 

the screen. Press [Meas] -> All Measure, select to turn off all measurement functions 

(OFF) or select the channels CH1-CH4 that need to be measured. If CH1 channel is 

selected, all measurement parameter data of CH1 channel will be displayed on the 

screen. 

Note: 

The deletion operation will not clear the measurement results of all measurement 

functions. 

 

Figure 10.1 All Measure 

10.3.5 Region                                              

Click on [Meas] -> Region to enter the measurement area settings menu. 

If this function is enabled, one or two cursors will appear on the screen. Before enabling 

the cursor indication function, you need to enable at least one automatic measurement 

parameter. The value of cursors will change with the measurement parameters. 

1. Region: 

Click on the area menu tab to open the area settings function. 

2. AX: 

Click on the AX menu tab and set AX by rotating the multifunction knob V0 or the 

pop-up numeric keypad. 

3. BX: 
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Click on the BX menu tab and set BX by rotating the multifunction knob V0 or the 

pop-up numeric keypad. 

4. AXBX: 

Click on the AXBX menu tab and set the AXBX by rotating the multifunction knob V0 or 

the pop-up numeric keypad. 

10.3.6 Setting                                              

Click on [Meas] -> Settings to enter the measurement threshold setting menu. 

1. Source: 

Click on the Source menu tab, select the desired measurement channel, and choose 

CH1-CH4, Math1-Math4。 

2. Upper limit: 

Click on the Upper limit menu tab and set the upper limit value by rotating the 

multifunction knob V0 or the pop-up numeric keypad. When the upper limit value is set 

to less than or equal to the current middle value, the interface prompts "Input value has 

reached the lower limit", and the default percentage is 90%. 

3. Median value: 

Click on the Mid menu tab and set the median by rotating the multifunction knob V0 or 

the pop-up numeric keypad. The median value is limited by the upper and lower limits, 

with a default percentage of 50%. 

4. Lower limit: 

Click on the Lower limit menu tab and set the lower limit value by rotating the 

multifunction knob V0 or the pop-up numeric keypad. When the lower limit value is set to 

be greater than or equal to the current middle value, the interface prompts "Input value 

has reached the upper limit", and the default percentage is 10%. 

5. Default value: 

Click the Default button to restore the upper limit, median, and lower limit values to their 

default values. 

10.4 Quick Measurement after AUTO                       

After connecting the oscilloscope correctly, input a valid signal, press the [Auto Scale] 

button to automatically set the waveform and open the following function menu: 

 Single cycle  : Set the screen to automatically display signals for a single 

cycle. Simultaneously measure the "time parameter" and "voltage parameter" of 

the current data source in a single cycle, and the measurement results are 

displayed at the bottom of the screen. 

 Multi cycle  : Set the screen to automatically display signals for multiple 



  Measure 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

109 

cycles. Simultaneously perform multi cycle "time parameter" and "voltage 

parameter" measurements on the current data source, and the measurement 

results are displayed at the bottom of the screen. 

 Rising edge  : Click or tap the icon, and then one rising edge of the signal 

is displayed automatically on the screen. Meanwhile, the system will make 

measurements for the "rise time" of the currently displayed rising edge. The 

measurement results are displayed at the bottom of the screen under the "Result" 

list. 

 Falling edge  : Click or tap the icon, and then one falling edge of the signal 

is displayed automatically on the screen. Meanwhile, the system will make 

measurements for the "fall time" of the currently displayed falling edge. The 

measurement results are displayed at the bottom of the screen under the "Result" 

list. 

 Back  : Click or tap the icon to cancel the auto setting and recovers to the 

parameter settings prior to clicking or tapping Auto. 

10.5 Cursor Measurement                                 

The cursor can be used to measure the X-axis value (such as time) and Y-axis value 

(such as voltage) of the selected waveform. Before using the cursor for measurement, 

we need a stable waveform display. The cursor measurement function provides the 

following two types of cursors. 

 

 X Cursor 

The X cursor is a vertical dashed line used for horizontal adjustment, which can be used 

to measure time (s) and frequency (Hz). 
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 Y Cursor 

The Y cursor is a horizontal dashed line used for vertical adjustment, which can be used 

to measure amplitude (consistent with the amplitude unit of the source channel). 

Click the [Cursors] in the button area to enter the cursor setting menu. The selected 

modes include: None, Manual, and Tracking. When selecting a manual cursor or 

tracking cursor, a cursor measurement window will appear on the screen, displaying the 

measurement results. 

10.5.1 Manual Mode                                           

In manual cursor mode, the value of the specified signal source waveform at the current 

cursor can be measured by manually adjusting the cursor. If the settings of parameters 

such as cursor type and measurement source are different, the results obtained by 

using the cursor will also be different. 

Click the [Cursors] in the button area to enter the cursor setting menu. The cursor 

defaults to off mode. 

Click on the Mode menu tab and select the cursor mode as manual. In the window 

where the measurement results are displayed, the window can be moved. By changing 

the cursor position, the measurement results also change in real-time. 

 

AX: The X value at cursor A. 

BX: The X value at cursor B. 

AY: The Y value at cursor A. 

BY: The Y value at cursor B. 

BX-AX: Horizontal spacing between cursors A and B. 

BY-AY: The vertical spacing between cursors A and B. 

|1/dX |: The reciprocal of the horizontal spacing between cursors A and B. 

1. Select: 

Click on the Select menu tab and select the cursor type X or Y. 

 X: The X cursor is a vertical solid line (cursor A) and a vertical dashed line (cursor 

B), usually used to measure time parameters. The measurement results include 

AX, BX, △X, and 1/△X (only displayed when "s" or "Hz" is selected for "horizontal 

units"). 
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 Y: The Y cursor is a horizontal solid line (cursor A) and a horizontal dashed line 

(cursor B), usually used to measure voltage parameters, and the measurement 

results include AY, BY, and △Y. 

2. Source: 

Click on the Source menu tab, and the optional source channels are CH1-CH4, Math, 

or LA. 

 Only the currently open channels are selectable. 

 When the source selects "LA", the selection menu is grayed out and cannot be 

changed. By default, the "X" cursor type is selected. 

3. AX: 

Click on the AX menu label to select the horizontal position of cursor A. After selection, 

rotate the knob V0 to adjust the cursor position. 

4. BX: 

Click on the BX menu label to select the horizontal position of cursor B. After selection, 

rotate the knob V0 to adjust the cursor position. 

5. AXBX: 

Click on the AXBX menu tab to select both the horizontal positions of cursor A and 

cursor B. After selection, rotate knob V0 to simultaneously adjust the positions of cursor 

A and cursor B. The horizontal spacing between cursor A and cursor B remains 

unchanged. 

6. AY: 

Click on the AY menu label to select the vertical position of cursor A. After selection, 

rotate the knob V0 to adjust the cursor position. 

7. BY: 

Click on the BY menu label to select the vertical position of cursor B. After selection, 

rotate the knob V0 to adjust the cursor position. 

8. AYBY: 

Click on the AYBY menu label to select both the vertical positions of cursor A and cursor 

B. After selection, rotate knob V0 to simultaneously adjust the positions of cursor A and 

cursor B. The vertical spacing between cursor A and cursor B remains unchanged. 

9. Test example: 

Use the manual measurement function (cursor) and the automatic measurement 

function to measure the period of a sine wave, and the measurement results are both 1 

ms. 
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Figure 10.2 Manual Cursor Measurement Example 

10.5.2 Track Mode                                             

In tracking cursor mode, two cursors (cursor A and cursor B) can be adjusted to 

measure the X and Y values of two different sources, respectively. When moving the 

cursor horizontally/vertically, the marker will automatically position on the waveform. 

When expanding or compressing the waveform horizontally/vertically, the marker will 

track the point marked during the last adjustment of the cursor. 

Click the [Cursors] button in the button area to enter the cursor setting menu. The 

cursor defaults to off mode. 

Click on the Mode menu tab and select the cursor mode as tracking. In the window 

where the measurement results are displayed, the window can be moved. By changing 

the cursor position, the measurement results also change in real-time. 

 

AX: The X value at cursor A. 

BX: The X value at cursor B. 

AY: The Y value at cursor A. 

BY: The Y value at cursor B. 

BX-AX: Horizontal spacing between cursors A and B. 

BY-AY: The vertical spacing between cursors A and B. 
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|1/dX |: The reciprocal of the horizontal spacing between cursors A and B. 

1. Source: 

Click on the Source menu label, and the available information sources include 

CH1~CH4 and Math. 

2. AX: 

Click on the AX menu label to select the horizontal position of cursor A. After selection, 

rotate the knob V0 to adjust the cursor position. 

3. BX: 

Click on the BX menu label to select the horizontal position of cursor B. After selection, 

rotate the knob V0 to adjust the cursor position. 

4. AXBX: 

Click on the AXBX menu tab to select both the horizontal positions of cursor A and 

cursor B. After selection, rotate knob V0 to simultaneously adjust the positions of cursor 

A and cursor B. The horizontal spacing between cursor A and cursor B remains 

unchanged. 

5. Measurement example: 

Measure the waveform of CH1 using cursor A and cursor B, and then expand the 

waveform horizontally. It can be observed that the cursor will track the marked point, as 

shown in the following figure. 

 

Figure 10.3 Track Measurement (before Horizontal Expansion) 
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Figure 10.4 Track Measurement (after Horizontal Expansion) 
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11 Reference Waveform                    

Click the [REF] button in the button area to enable the reference waveform function. 

  

After enabling the REF function, you can set the source of the reference channel for the 

reference waveform, adjust the vertical gear and offset of the reference waveform, save 

the reference waveform to internal or external storage, and retrieve it for use when 

needed. 

This chapter includes: 

 Enable Ref Function 

 To Adjust the Ref Waveform 

 To Adjust the Ref Waveform Display 

 Detail 

 To Reset the Reference Waveform 

 Color Setting 

 Label Setting 

 Import 

 Export 
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11.1 Enable Ref Function                                             

Press the REF button on the front panel, and the indicator light will illuminate, enabling 

the reference function. 

Note: The reference waveform function is disabled when the time base mode is set to 

"XY". 

11.2 To Set Reference Waveform                                             

1. To Select the Ref Source 

Click or tap the drop-down button of Source to select the desired reference waveform 

source (CH1~ CH4 or D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). 

2. To Save the Reference Waveform to Internal Memory 

Click or tap SaveToRef to save the displayed waveform for the specified source to the 

internal memory as the reference waveform. 

CAUTION: 

This operation only saves the reference waveform to the volatile memory, and the 

waveform will be cleared at power-off or restoring to the default settings. 

3. To Clear the Reference Waveform 

Click or tap Clear to clear the reference waveform. 

11.3 To Adjust the Ref Waveform Display                  

Set the vertical gear and vertical offset of the reference waveform. 

1. Vertical Scale: 

Click on the VScale menu label and set the vertical gear of the reference waveform by 

rotating the multi-functional knob V0 or the pop-up numeric keyboard. 

2. Vertical offset: 

Click on the VOffset menu tab and set the vertical offset of the reference waveform by 

rotating the multi-functional knob V0 or the pop-up numeric keyboard. 

11.4 Detail                                               

Click on the Details menu tab to open the Reference Details window. 
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11.5 To Reset the Reference Waveform                    

Reference waveform reset refers to: if a gear or offset operation is performed on the 

reference waveform, the reset operation can restore the waveform to the original saved 

position. 

Click on the Reset menu tab to reset the reference waveform. 

11.6 Color Setting                                        

This series of oscilloscopes provides multiple colors to identify different reference 

waveforms, allowing users to better distinguish between reference waveforms. 

Click on the Color menu tab and there are five colors to choose from. 

11.7 Label Setting                                        

Click on the Label menu label to enter the label settings menu. 

1. Display Label: 

Click on the Display Label menu label and choose to turn on or off the reference 

waveform label. 

2. Label Library: 

Click on the Library menu label, rotate the multi-functional knob to select the preset 

label, and press the knob to select it. You can also continuously press the tag library key 

or use the touch screen function to make selections. You can choose preset labels such 

as Default, ACK, ADO, or ADDR. 

3. Label: 

Click on the Label menu label and manually enter the label name at the pop-up 

keyboard. 

11.8 Import                                              

Users can import reference waveform files stored in the instrument's internal memory or 

external USB drive into the instrument for display on the screen. 

Click on the Import menu tab to enter the reference waveform file loading interface. 

Please refer to the Store and Load for storage calls for specific operations. 

Example of reference waveform: 
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Figure 11.1 Example of reference waveform 

11.9 Export                                              

Users can save the current reference waveform to the instrument's internal memory or 

external USB drive. The reference waveform file format is *. ref, *. bin, or *. csv. 

Click on the Export menu tab to enter the reference waveform file save interface. 

Please refer to the Store and Load for storage calls for specific operations. 
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12 Display                                 

In the display settings menu, users can set the waveform display type, afterglow time, 

waveform brightness, grid type and brightness displayed on the screen, etc. 

Click on the button area [Display] to enter the display settings menu. 

  

This chapter includes: 

 To Select the Display Type 

 To Set the Persistence Time 

 To Set the Waveform Intensity 

 To Set the Screen Grid 

 To Set the Grid Brightness 

 Scale 

 Color Grade 

 To Set the Screen Brightness 

 Anti-aliasing 
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12.1 To Select the Display Type                             

Click on the Type menu label, which can be selected as vector or point. Choose 

whether the waveform is displayed as a vector or as a point. The vector setting will fill in 

the blank space between adjacent sampling points in the display; Point settings only 

display sampling points. 

The vector type sampling points are displayed through connecting lines. This mode 

provides the most realistic waveform in most cases, making it easy to view the steep 

edges of waveforms (such as square waves). 

12.2 To Set the Persistence Time                         

In the displayed menu, click on the Persis.Time menu label and select afterglow time 

(Min, 100ms, 200ms, 500ms, 1s, 2s, 5s, 10s, Infinite). 

 Minimum value: Observable waveform with high refresh rate changes. 

 Specific value: burrs with slower changes or lower probability of occurrence can be 

observed. The afterglow time can be set to 100ms, 200ms, 500ms, 1s, 2s, 5s, and 

10s. 

 Infinite: When the oscilloscope displays the newly collected waveform, it will not 

clear the previously collected waveform. The collected waveforms will be displayed 

in colors with lower brightness, while the newly collected waveforms will be 

displayed in normal brightness and color. The use of infinite afterglow can measure 

noise and jitter, capturing occasional events. 

12.3 To Set the Waveform Intensity                        

Click on the Intensity menu button, and set the brightness value directly through the 

multi-functional knob V0 or the numeric keyboard, with a range of 0%~100%. 

12.4 To Set the Screen Grid                               

Click on the Grid menu tab to select the types of screen grids: Dot, Line, and Close. 

 Dot: Set the background grid line as a point. 

 Line: Set the background grid to solid lines. 

 Close: Close the background grid. 



  Display 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

121 

12.5 To Set the Grid Brightness                            

Click on the Grid Brightness menu tab and set the grid brightness value directly 

through the multi-functional knob V0 or the numeric keypad, with a range of 0%~100%. 

12.6 Scale                                                

Click on the Scale menu tab and choose to turn the ruler function on or off. 

12.7 Color Grade                                         

Click on the Color Grade menu tab and choose to turn on or off the color temperature 

function. When the color temperature is displayed, different colors representing the 

number or probability of data collection will be displayed on the screen. 

12.8 To Set the Screen Brightness                        

Click on the Brightness menu button, and set the brightness value directly through the 

multi-functional knob V0 or the numeric keypad, with a range of 0%~100%. 

12.9 Anti-aliasing                                       

Click the Anti-aliasing menu tab to enable or disable the anti-aliasing function. 

Enabling anti-aliasing reduces the color levels from 256 to 64 and increases the number 

of display columns from 500 to 1000, resulting in smoother waveform rendering and 

improved gradient performance. 
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13 System Utility Function Setting         

Click on [Utility] in the button area. Enter system configuration. 

Users can set system related functional parameters or interfaces. 

This chapter includes: 

 Interface Configuration 

 Beeper 

 Language 

 Pass/Fail 

 Recording & Playing 

 System 

 Clock Source 

 Key Locker 

 Quick Setting 

 Screen Saver 

 Self Check 

 Time 
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13.1 Interface Configuration                               

Click on the I/O menu tab and select LAN interface or RS232 interface. 

13.1.1 LAN Configuration                                        

Click on [Utility] in the button area to enter the menu, click on the I/O menu tab, select 

LAN, and enter the LAN settings menu. 

 

Figure 13.1 LAN Connection Setting Interface 

1. Status: 

The oscilloscope will provide different prompts based on the current network connection 

status: 

 Click on the application to display: Please wait ... 

 Dynamic IP: Requests to the DHCP server will fail when the network status is poor. 

All statuses are as follows: 

Obtaining IP... 

The automatic IP configuration was successful! 

DHCP configuration failed! 

 Auto IP: Local IP calculation is basically successful. All statuses are as follows: 

Obtaining IP... 

The automatic IP configuration was successful! 

Automatic IP configuration failed! 

 Static IP: Local setting. It will definitely succeed. There is only one status: 

The network setup was successful! 
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When settings are successful, only dynamic IP indicates that the network request IP is 

successful. In other cases, it only represents the local status and has nothing to do with 

whether the network status is connected or not. 

2. IP Config Mode 

The IP Config Mode include DHCP, Auto IP, and Static IP. Under different methods, the 

configuration methods for network parameters such as IP addresses vary. 

 DHCP: 

Click on the IP Config Mode menu tab and select Set as Dynamic IP. When the 

dynamic IP is valid, the dynamic IP server in the current network will assign IP address, 

subnet mask, gateway address, domain name server address and other network 

parameters to the oscilloscope. 

 Auto IP: 

Click on the IP Config Mode menu tab and select Set as Dynamic IP. In the automatic 

IP mode, the oscilloscope automatically acquires the IP address and subnet mask 

255.255.0.0 from 169.254.0.1 to 169.254.255.254 according to the current network 

configuration. Automatic IP only takes effect when dynamic IP is not selected or 

connection fails. 

 Static IP: 

Click on the IP Config Mode menu tab and select Set as Static IP. When this mode is 

effective, manually turn off dynamic IP and automatic IP, and the menu of setting IP 

address, setting subnet mask, setting gateway address, and setting DNS address will 

be added. At this point, users can customize network parameters such as the IP 

address of the oscilloscope. 

 Set IP Address 

The format of the IP address is nnn. nnn. nnn. nnn. The first nnn can be set in 

the range of 0 to 255 (excluding 127), with a valid range of 0 to 223. The other 

three nnns all have a range of 0 to 255. It is recommended to consult your 

network administrator for an available IP address. 

Press the IP Address key to pop up the numeric keypad and enter the desired 

IP address. This setting will be saved in non-volatile memory. If "Power on 

Call" is set to "Last Value", the next time the device is turned on, both dynamic 

IP and automatic IP will be turned off, and the oscilloscope will automatically 

load the set IP address. 

 Set Subnet Mask 

The format of the subnet mask is nnn.nnn.nnn.nnn, where nnn ranges from 0 

to 255. It is recommended that you consult your network administrator for an 

available subnet mask. 

Press the Subnet Mask key, a numeric keypad will pop up, and enter the 

required subnet mask. This setting is saved in the non-volatile memory. If the 

"power on call" is set to the "last value", the dynamic IP and automatic IP will 

be turned off when the next power on, and the oscilloscope will automatically 
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load the set subnet mask. 

 Set up Gateway 

In Static IP mode, you can set up a gateway. 

The format of the gateway is nnn. nnn. nnn. nnn, with the first nnn ranging from 

0 to 223 (excluding 127) and the other three nnns ranging from 0 to 255. It is 

recommended to consult your network administrator for an available gateway 

address. 

Press the Gateway key, pop up the numeric keypad, and enter the desired 

gateway address. This setting is saved in non-volatile memory. If the "power on 

call" is set to "last value", the next time the power is turned on, both dynamic IP 

and automatic IP are turned off, and the oscilloscope will automatically load the 

set gateway address. 

 Set Domain Name Server Address 

In static IP mode, you can set the domain name server address. 

The address format of the domain name server is nnn.nnn.nnn.nnn, with the 

first nnn ranging from 0 to 223 (excluding 127) and the other three nnns 

ranging from 0 to 255. It is recommended to consult your network administrator 

for an available address. 

Press the DNS key, pop up the numeric keypad, and enter the desired address. 

Generally speaking, users do not need to set the domain name server address 

in the network, so this parameter setting can be ignored. 

3. MAC Address 

For an oscilloscope, the MAC address is always unique. When assigning IP addresses 

to instruments, they are always identified by MAC addresses. 

4. VISA Address 

Display the VISA address currently used by the oscilloscope. 

13.1.2 RS232 Configuration                                      

Click on [Utility] in the button area to enter the menu, click on the I/O menu label, select 

RS232, and enter the RS232 settings menu label. 

Click on the Baud Rate menu tab and select Baud Rate from the pop-up menu. 

13.2 Beeper                                              

[Utility] -> Beeper. The sound can be selected to be turned off or on. 

Click on the Beeper menu tab to choose whether to turn sound on or off. The sound 

sign is displayed in the bottom right corner of the screen. 
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13.3 Language                                           

Click on the Language menu tab to switch between Chinese or English. 

13.4 Pass/Fail                                            

By testing the function, it is possible to better monitor the changes in signals. You can 

enter the testing menu through the following methods: 

 In [Utility] -> Pass/Fail, enter the Pass/Fail function menu. 

 Click on the navigation label [Hantek] in the upper left corner of the screen, select 

Pass/Fail, and enter the Pass/Fail function menu. 

  

13.4.1 To Enable or Disable the Pass/Fail Test Function           

Click on the Pass/Fail menu tab to enter the Pass Test Settings menu. 

Click on the Enable menu tab to select whether to enable or disable the pass testing 

function. The icon illuminates to enable the pass test function. 

13.4.2 To Select the Source                                      

Click on the Source Selection menu tab in the Test menu to select channels CH1 to 

CH4. 
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13.4.3 To Start or Stop the Pass/Fail Test Operation               

Click on the Operation menu tab in the Test menu to start or stop the test operation. 

After starting the testing operation, the oscilloscope will test the waveform. Select the 

testing source and set testing rules as needed. 

Only when the pass test function is enabled can the pass test operation be started or 

stopped. 

The testing interface is shown in the following figure: 

 

Figure 13.2 Pass/Fail examples 

13.4.4 Mask                                                   

1. Create Rules 

Click on the Mask menu tab in the Test menu to enter the Mask Settings menu, select 

Create Rule, and enter the Settings menu. 

Click on the Range menu tab to select the Screen or Cursor. 

Click on the X Mask menu tab and set the horizontal tolerance range on the pop-up 

numeric keyboard or V0 knob. 

Click on the Y Mask menu tab and set the vertical tolerance range on the pop-up 

numeric keyboard or V0 knob. 

Click on the Create Rule menu tab to apply the currently created rule. 

2. Load Rules 

Click on the Mask menu tab in the Test menu to enter the Mask Settings menu, select 

Load Rules, and enter the Settings menu. 
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Click on the File Type menu tab, and the file types you can choose are: *. stp or *. ptr. 

Click the Load menu tab to call out the stored files from the machine's internal memory 

or external memory (successfully connected to the USB flash disk) and apply them to 

the current passing test function. 

3. Save Rule 

In the pass test menu, users can enter the mask menu to customize the pass/fail test 

rules. 

Enter the Test Settings menu, click on the Mask Menu tab to enter the Mask Settings 

menu, select Save Rules, and enter the File Save menu. 

Click on the File Type menu tab and select the file save type, which can be *. stp or *. 

ptr. 

Click on the File Name menu tab to modify the file name. 

Click on the Window menu tab to choose whether to open or close the window. 

Click on the Save menu tab to save the settings file in the machine's internal or external 

memory (external memory USB flash drive has been recognized on the machine). 

13.4.5 Option                                                  

Click on the Option menu tab in the Pass/Fail menu to enter the Options Settings menu. 

1. Aux Output: 

Click on the Aux Output menu tab to choose whether to turn on or off the Aux output 

function. If set to enable Aux output function, then [Utility] -> System -> AUXOut will 

automatically be set to pass the test. If the Aux output function is turned off, then [Utility] 

-> System -> AUXOut is automatically set to trigger output. 

2. Output Event: 

Click on the Output Event menu tab to select either pass or fail. 

3. Output polarity: 

Click on the Polarity menu tab to select positive or negative pulses. 

4. Output Pulse Width: 

Click on the Pulse menu label, and the range of output pulse width can be selected from 

100ns to 100ms. Set the pulse width through the pop-up numeric keypad. 

5. Error Action: 

Click on the Error Action menu tab to select Attonity, Buzzer. 

Buzzer: When a failure event is detected, the machine emits a sound (independent of 

the machine's sound on/off state). 

6. Stop Output: 

Click on the Stop Output menu tab to choose whether to turn it on or off. 
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13.4.6 Information                                             

By clicking on the Information menu tab in the Test menu, you can choose to turn on or 

off the information. Select to open the information, and the test results table will appear 

on the screen. The test results include total number, pass, and fail. 

When opening the measurement results tab, click on the Reset menu tab to reset the 

data in the measurement results table. 

 

13.4.7 Statistical Reset                                         

Click on the Reset menu tab in the Test menu to reset the data in the measurement 

results table. 

13.5 Recording & Playing                                 

The recording and playback functions of waveforms can play the recorded analog input 

channels (CH1-CH4) waveforms, making it convenient for users to analyze waveforms. 

The menu can be accessed through the following methods: 

 In the [Utility] -> Record, enter the waveform recording function menu. 

 Click on the navigation label [Hantek] in the upper left corner of the screen, select 

Record, and enter the waveform recording function menu. 

13.5.1 Record Options                                         

For waveform recording, it is necessary to set the recording time, recording frame 

number, etc. in advance. The oscilloscope can manually stop recording or the recorded 

frame number can reach the set recording frame number based on the currently open 

channel for recording. 

Click [Utility] in the button area to enter the menu, Click on Record, select to turn on or 

off the waveform recording function, and turn it on to turn it on. 
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1. Frames: 

Click on the Frames rate menu tab and set the recorded frame rate using the 

multi-functional knob V0 or numeric keyboard. The number of frames recorded 

represents the number of frames that can be recorded. After starting recording, if the 

number of recorded frames reaches the set recording frame number, the recording will 

automatically stop. 

2. Record Interval: 

Recording interval refers to the time interval between frames during the recording 

process. 

Click on the Record Interval menu tab and set the recording time using the 

multi-functional knob V0 or the numeric keypad. 

3. Current Frames: 

Press Current, then rotate the multifunction knob or use the pop-up numeric keypad to 

set the current frame. At this time, the waveform of the current frame is displayed on the 

screen.. 

4. Beeper: 

Click on the Beeper menu tab to select whether the buzzer will sound when the 

recording ends. 

13.5.2 Play Options                                              

Play function: 

Click on [Utility] in the button area to enter the menu, click on the Record -> More 

menu tab to enter the playback settings. 
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1. Play Mode: 

Click on the Mode menu tab to choose between looping or single playback. 

 Loop playback: Repeat playback from the start frame to the end frame until 

manually stopping the playback operation. 

 Single playback: Automatically stops from the start frame to the end frame. 

2. Play Order: 

 Sequential playback: Plays from the start frame to the end frame. 

 Reverse playback: Plays from the end frame to the start frame. 

3. Play Interval: 

Click on the Play Interval menu tab, and you can set the time interval between frames 

by rotating the knob V0 or directly setting the time interval between frames on the 

pop-up numeric keyboard. 

4. Start Frame 

Press Start Frame, then rotate the multifunction knob or use the pop-up numeric 

keypad to set the start frame of playback. By default, it is 1, and the maximum value is 

the number of recorded frames. 

5. End Frame 

Press End Frame, then rotate the multifunction knob or use the pop-up numeric keypad 

to set the end frame of playback. The default is the number of frames of the recorded 

waveforms. 
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13.6 System                                             

Click on the [Utility] button area to enter the menu, click on the System menu tab, and 

enter the system settings menu. 

13.6.1 Power On                                              

Click on the Power On menu tab and select the system configuration that will be called 

when the device is powered back on after a power down. You can choose to restore the 

Default or Last. 

 Default: Restore the system to factory settings. 

 Last: Reply to the settings from the last time the system was powered down. 

13.6.2 Aux Output                                             

[Utility] -> More -> System -> AUXOut, enter the Auxiliary Output menu tab, and there 

are two options: Trigout and Pass/Fail. 

 Trigout: When the oscilloscope generates a hardware trigger, it will output a signal 

from the auxiliary output connector that reflects the current capture rate of the 

oscilloscope. Input the signal into the port, display the waveform on the screen, 

and measure the frequency of the waveform. It is found that the frequency is the 

same as the current capture rate. 

 Pass/Fail: In the pass test, when the oscilloscope detects a pass or fail, a positive 

or negative pulse will be output from the auxiliary output connector. Set [Utility] -> 

Pass/Fail -> AUXOut to On, then the [Utility] -> More -> System -> AUXOut 

menu will automatically be set to "Pass/Fail". If the auxiliary output menu here is 

set to "trigout", then [Utility] -> Pass/Fail -> AUXOut function will automatically 

close. 

13.6.3 Education model                                        

Click on the Education Model menu tab and select whether to turn Education Mode on 

or off. After enabling the education mode, the Auto function and some functions of Meas 

are disabled. 

13.6.4 Self-calibration                                         

The self-calibration program can optimize the oscilloscope signal path with maximum 

measurement accuracy. You can run this program at any time, but if the ambient 

temperature changes by more than 5℃, you should run this program. 
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For more accurate calibration, please turn on the oscilloscope power and preheat for 30 

minutes before performing self calibration. Follow the prompts on the screen to operate. 

To compensate for the signal path, disconnect any probes or cables connected to the 

input connector. 

Click on the SelfCal menu tab and select Offset Start. 

13.6.5 Local upgrade                                          

[Utility] -> More -> System -> Local Upgrade, 

Click Local Upgrade and select whether to upgrade the firmware. If you click OK, 

select the firmware file to be upgraded; Click Cancel to exit the upgrade interface. 

13.6.6 About this oscilloscope                                 

[Utility] -> More -> System -> About. 

Click on the menu label of About, and the system information of the oscilloscope will 

pop up on the screen, including the model, serial number, software version, hardware 

version, etc. of the oscilloscope. 

The menu also includes the functions included in the oscilloscope: 16 digital channels, 

any signal generator, digital voltmeter, power analysis, Bode diagram, histogram, Bus 

trigger and Decode, storage depth option. 

13.7 Clock Source                                        

Click on the [Utility] -> More -> Clock Source menu tab, and select whether the clock 

source is Internal or External. 

13.8 Key Locker                                          

Click on [Utility] -> More -> Key Locker menu tab. Users can set whether to lock the 

keyboard. After the keyboard is locked, users will no longer be able to use the keyboard 

for configuration. At the same time, the [Touch Lock] button in the keyboard area lights 

up. 

13.9 Quick Setting                                        

You can access the shortcut menu through the following methods: 

 Click on [Utility] -> More -> Quick setting to enter the shortcut menu. 
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 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

shortcut operations, and enter the settings menu. 

Quick setting include: Save Image, Save Wave, Save Setup, All Measure, Stat Reset, 

Record, Save Group. 

13.9.1 Save Image                                             

Click on the Operation Type, select the Save Image menu tab, and make further 

settings. 

 In the Format item, you can click to select image types including "*. png", "*. bmp", 

"*. jpg", or "*. tif". 

 In the Invert option, click to open the Invert function. 

 In the Color item, click to select the color stored in the image. 

After setting up, click the [Quick Action] button in the button area to capture the current 

screen and save the image in the set type. Do not insert a USB drive, it is saved 

internally by default. Insert a USB drive and save it in the USB drive. 

13.9.2 Save Wave                                              

Click on the Operation Type, select the Save Wave menu tab, and make further 

settings. 

 In the Data Source item, you can click to select the stored waveform from the 

screen or memory. After selecting the memory as the data source, you can choose 

the corresponding source: CH1-CH4, digital channels (D1.0-D1.3, D2.0-D2.3, 

D3.0-D3.3, D4.0-D4.3). 

 In the Format item, optional format types include "*. bin" , "*. csv" or “*.wfm”. 

After setting, click the [Quick Action] button to save the waveform according to the 

settings. Do not insert a USB drive, it is saved internally by default. Insert a USB drive 

and save it in the USB drive. 

13.9.3 Save Setup                                             

Click on the Operation Type, select the Save Setup menu tab, and make further 

settings. 

After setting, click the [Quick Action] button to save the waveform settings according to 

the settings. Do not insert a USB drive, it is saved internally by default. Insert a USB 

drive and save it in the USB drive. 
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13.9.4 All Measure                                             

Click on the Operation Type, select All Measure menu labels, and make further 

settings. 

In All Measure items, options include OFF or measurement channels CH1 to CH4. 

After setting up, click the [Quick Action] button to measure the specified channel. 

13.9.5 Stat Reset                                              

Click on the Operation Type, select the Stat Reset menu tab, and make further 

settings. 

In the Stat Reset option, you can select the function "Measure" or "Pass/Fail". 

After setting, click the [Quick Action] button to reset the statistical results of the 

specified function and restart the measurement. 

13.9.6 Record                                                 

Click on the Operation Type, select the Record menu tab, and make further settings. 

After setting, click the [Quick Action] button to record the waveform. 

13.9.7 Load Mask                                            

Click on the Operation Type, select the Load Mask menu tab, and make further 

settings. 

After setting, click the [Quick Action] button to load the previously set mask and pop up 

the load template menu tab under the Pass/Fail function. 

13.9.8 Save Group                                            

Click on the Operation Type, select the Save Group menu tab, and make further 

settings. 

In the Save Group option, the available storage options are "Save Image", "Save 

Wave", or "Save Setup". 

After setting up, click the [Quick Action] button to store the selected content according 

to the configuration. Do not insert a USB drive, it is saved internally by default. Insert a 

USB drive and save it in the USB drive. 
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13.10 Screen Saver                                        

Click [Utility] -> More -> Screen Saver menu tab, options: off, Picture, Text. 

Select Picture: Click to Select Picture and load it locally on the machine or on a USB 

drive. The image format is *. png, *. bmp, *. jpg, *. tif; Click on the Time to Start menu 

tab and set the waiting time (5min, 10min, 30min, 1h, 2h, 4h); Click on the Preview 

menu tab to see the effect of the settings in advance; Click on the Default Menu tab to 

restore the settings to their default state. 

Select text: Click on the Text menu label and enter custom text on the keyboard; Click 

on the Time to Start menu tab and set the waiting time (5min, 10min, 30min, 1h, 2h, 4h); 

Click on the Preview menu tab to see the effect of the settings in advance; Click on the 

Default Menu tab to restore the settings to their default state. 

13.11 Self Check                                          

Enter the self-test menu through the following methods: 

 Click on the [Utility] -> More -> More -> Self Check menu tab to enter the Self 

Check menu. 

 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

Self Check, and enter the Self Check menu. 

The self-test options include Key Test, Screen Test, and Touch Test. 

Key Test: Click on the Key Test menu tab to enter the keyboard testing interface. The 

icon corresponding to the button appears on the screen. By pressing the button on the 

front panel of the instrument or rotating the knob, the corresponding icon can be 

illuminated to determine whether the button or knob function is normal. Press' Run/Stop 

'three consecutive times to exit the testing function. 

Screen Test: Click on the Screen Test menu tab to enter the screen testing interface. 

Red and XXX appear in sequence. Follow the prompts and press "Single" to enter the 

next screen. Press' Run/Stop 'three consecutive times to exit the testing function. 

Touch Test: Click on the Touch Test menu tab to enter the touch function testing 

interface. Use your finger to click on the screen. If there are corresponding lines 

displayed in the blank area and the boxes that pass through turn into green background 

boxes, it indicates that the touch screen function is normal in that area. 

13.12 Time                                                

Click on [Utility] -> More -> More -> Time to enter the time setting menu. 

Click on the Show Time menu tab and set whether the time is displayed in the bottom 

left corner of the screen. Click on the Set Time menu tab to enter the Set Time menu, 

where you can set the Year, Month, Day, Hour, and Minute. 
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14 Decode                               

Protocol decoding is the foundation of protocol analysis. Only correctly decoded 

protocol analysis can be accepted, and only correct decoding can provide more error 

information. This oscilloscope provides commonly used protocol decoding, including 

UART, I2C, SPI, LIN, and CAN. You can enter the decoding menu through the following 

methods: 

Click on the button area [Decode] to enter the decoding settings menu. 

This chapter includes: 

 UART Decoding 

 I2C Decoding 

 SPI Decoding 

 LIN Decoding 

 CAN Decoding 
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14.1 UART Decoding                                     

The UART serial bus consists of a transmit data line (TX) and a receive data line (RX). 

 

Figure 14.1 Schematic Diagram of UART Serial Bus 

The high levels represent logic "1" and low levels represent logic "0". 

 

Figure 14.2 Schematic Diagram of Logic 

The baud rate is used in UART to represent the transmission rate of data (i.e. bits per 

second). UART requires setting the start bit, data bit, check bit (optional), and stop bit 

for each frame of data. 

 

 Start Bit: indicates when the data starts to be output. 

 Data Bit: represents the actual number of data bits contained in each frame of 

data. 

 Check Bit: used to verify the correctness of data transmission. 

 Stop Bit: indicates when the data stops outputting. 

Click [Decode] in the button area to enter the decoding function menu. 

1. Bus Type: 

Click on the Bus Type menu tab and select UART from the pop-up menu to configure 

UART decoding. 

2. Bus Status: 

Click or tap On/Off button for the Bus Status menu item and choose to enable/disable 

the bus decoding. 
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3. Baud Rate: 

Click on the Baud Rate menu tab and select Baud Rate from the pop-up menu. 

4. Source: 

Click on the Source menu tab to enter the Source Settings menu. 

 Set the Tx source and Threshold 

Click on the Tx menu tab and select the source channel from the pop-up menu. 

Click on the Threshold menu label and set the threshold through the multi-functional 

knob V0 or the pop-up numeric keyboard. 

 Set the Rx source and threshold 

Click on the Rx menu tab and select the source channel from the pop-up menu. 

Click on the Threshold menu label and set the threshold through the multi-functional 

knob V0 or the pop-up numeric keyboard. 

 Idle Level: 

Click on the Idle Level menu tab and select idle level as High/Low to set the idle state of 

the data decoding channel as high or low level. 

5. Display: 

Click on the Display Menu tab to enter the Display Settings menu. 

 Format 

Click on the Format menu tab, and the available formats include hexadecimal, decimal, 

binary, and ASCII. 

 Position 

Click on the Position menu tab to set the location. 

 Label  

Click on the Label to display the menu label, and choose to turn it on or off. 

 Event Table 

Click on the Event Table menu tab to enter the event table settings menu. The event 

table displays detailed decoding information in chronological order in the form of a table, 

making it easy to observe longer decoded data. Decoded information includes the 

decoded data (TX and/or RX, corresponding line numbers, time, and error information). 

 Event Table 

The event table can be selected to open or close. 

 Format 

Click on the Format menu tab to set the format of the event table. The 

options include hexadecimal, decimal, binary, and ASC. 

 View 

Click on the View menu tab to select Package, Details, and Data. Select 

'Package', and the decoded data, time, and error information will be displayed 

in the event table accordingly; Select 'Detailed' to display detailed data for the 
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specified row in the event table. If '...' appears in the row data, it indicates that 

not all decoded data is displayed. At this time, you can view detailed 

information in the 'Package' view; Select 'Data' to display all data for the 

specified column in the event table. If '...' appears in the column data, it 

indicates that not all decoded data is displayed. At this time, you can view 

detailed information in the 'Package' view. 

 Export 

Click on the Export menu label, and when the view selects "package", 

information such as time and corresponding decoding data can be exported. 

 Jump 

Click on the Jump menu tab to display the specified data waveform in the 

center view of the screen. 

6. Setting: 

Click on the Setting menu tab to enter the Settings menu. 

 Data: 

Click on the Data menu tab, and the available data bits are: 5bit, 6bit, 7bit, 8bit, and 9bit. 

 Parity: 

Click on the Parity menu tab, and the available verification methods include: None, Odd, 

and Event. 

 None: There is no checksum during transmission. 

 Odd: The total number of "1" in the data bit and parity bit is odd. For example, 

if you send 0x55 (01010101), you need to check that the bit stuffing is filled 

with 1. 

 Event: The total number of "1" in the data bit and parity bit is even. For 

example, if 0x55 (01010101) is sent, 0 needs to be filled in the calibration 

position. 

 Stop Bit: 

Click on the Stop Bit menu tab, and the available stop bits are: 1 bit, 1.5 bit, and 2 bit. 

 Endian: 

Click on the Endian menu tab, and the available bit orders are: LSB, MSB. 

 LSB: Least Significant Bit, which means that the low bit of data is transmitted 

first. 

 MSB: Most Significant Bit (most significant bit), that is, the high data bits are 

transmitted first. 

 

 Package: 
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Click on the Package menu tab to select whether to open or close the package. When 

the package is ON state, several data blocks will be merged based on the package 

delimiter. 

 Separator: 

Click on the Separator menu label, and the available package separators are 0A (LF), 

0D (CR), 20 (SP), and 0 (NULL). 

7. Copy Trig: 

Click on the Copy Trig menu tab to select the Copy Trigger function. The copy trigger 

function can quickly apply trigger settings to corresponding types of decoding functions. 

For the source channel, copy the source channel in the trigger to the RX source channel 

in the decoding. If it is an analog channel, its threshold level setting will also be 

replicated. 

8. Decoding example: 

  

Figure 14.3 UART decoding example 

14.2 I2C Decoding                                          

The I2C serial bus consists of a clock line (SCL) and a data line (SDA). 

 

Figure 14.4 Schematic diagram of I2C serial bus 
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 SCL: Sampling SDA on the rising or falling edge of the clock. 

 SDA: Represents a data channel. 

Click [Decode] in the button area to enter the decoding function menu. 

1. Bus Type: 

Click on the Bus Type menu tab and select I2C from the pop-up menu to configure I2C 

decoding. 

2. Bus Status: 

Click or tap On/Off button for the Bus Status menu item and choose to enable/disable 

the bus decoding. 

3. Source: 

Click on the Source menu tab to enter the Source Settings menu. 

 Set clock channel source and threshold 

 Click on the SCL menu tab and select the source of the clock channel. 

 Click on the SCL Thre menu tab and adjust the threshold of the clock channel 

through XX settings. When changing the threshold of the clock channel, a 

dashed line appears on the screen displaying the current threshold level. 

When the change is stopped, the dashed line of the threshold level 

disappears after about 2 seconds. 

 Set data channel source and threshold 

 Click on the SDA menu tab and select the source of the data channel. 

 Click on the SDA Thre menu tab and adjust the threshold of the data channel 

through XX settings. 

 Exchange 

Click on the Exchange menu tab and select Clock/Data or Data/Clock. Can exchange 

the current clock channel and data channel sources. 

4. R/W: 

Click on the R/W menu tab to select whether the address information includes 

read/write bits or does not. When selecting include, the read/write bit will be included in 

the address information and will be in the lowest position; When not included, the 

address information does not include read/write bits. 

5. Display: 

Click on the Display Menu tab to enter the Display Settings menu. 

 Format 

Click on the Format menu tab to set the display format, which can be selected from: 

hexadecimal, decimal, binary, or ASCII. 

 Position 

Click on the Position menu tab to set the location. 

 Label  
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Click on the Label to display the menu label, and choose to turn on or off the decoded 

label display. (Label display position) 

 Event Table 

Click on the Event Table menu tab to enter the event table settings menu. 

 Event Table 

The event table can be selected to open or close. 

 Format 

Click on the Format menu tab to set the format of the event table. The options 

include hexadecimal, decimal, binary, and ASC. 

 View 

Click on the View menu tab to select Package, Details, and Data. 

 Export 

Click on the Export menu label, and when the view selects "package", 

information such as time and corresponding decoding data can be exported. 

 Jump 

Click on the Jump menu tab to display the specified data waveform in the 

center of the screen. 

6. Copy Trig: 

Click on the Copy Trig menu tab to select the Copy Trigger function. The copy trigger 

function can quickly apply trigger settings to corresponding types of decoding functions. 

7. Decoding example: 

 

Figure 14.5 I2C decoding example 
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14.3 SPI Decoding                                         

SPI bus communication is based on master-slave configuration and generally consists 

of chip selection lines (CS), clock lines (CLK), and data lines (SDA). The data lines 

include MISO (master input slave output) and MOSI (master output slave input). The 

oscilloscope samples channel data on the rising or falling edge of the clock signal (if it is 

an analog channel, it will also determine whether each data point is a logical "1" or a 

logical "0" based on the set threshold level). 

 

Figure 14.6 SPI Bus Schematic 

Click [Decode] in the button area to enter the decoding function menu. 

1. Bus Type: 

Click on the Bus Type menu tab and select SPI from the pop-up menu to configure SPI 

decoding. 

2. Bus Status: 

Click or tap On/Off button for the Bus Status menu item and choose to enable/disable 

the bus decoding. 

3. TimeOut: 

Click on the Time menu tab and set the timeout value through the multi-functional knob 

V0 or numeric keyboard. Frame synchronization is carried out based on the timeout 

period, which needs to be greater than half a clock cycle. 

4. Source: 

Click on the Source menu tab to enter the Source Settings menu. 

 Set clock signal: 

 Click on the CLK menu tab and select the clock source channel (CH1-CH4, 

D0-D3, OFF). 

 Click on the Threshold menu tab and set the threshold using the 

multi-functional knob V0 or the numeric keypad. 

 Click on the Slope menu label and select the edge type positive or negative 

polarity to set the instrument to sample MISO and MOSI on the CLK. 

 Set MISO and MOSI: 

 Click on the MISO menu tab and select the MISO source channel (CH1-CH4, 

D0-D3, OFF). 
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 Click on the Threshold menu tab and set the threshold using the 

multi-functional knob V0 or the numeric keypad. 

 Click on the MOSI menu tab and select the MOSI source channel (CH1-CH4, 

D0-D3, OFF). 

 (Reminder: The MISO and MOSI source channels cannot be set to OFF at the 

same time.) 

Tip: The MISO and MOSI source channels cannot be set to OFF simultaneously. 

 Idle Level: 

Click on the Idle Level menu tab and select idle level as High/Low to set the idle 

state of the data decoding channel as high or low level. 

5. Display: 

Click on the Display Menu tab to enter the Display Settings menu. 

 Format 

Click on the Format menu tab, and the available formats include hexadecimal, decimal, 

binary, and ASCII. 

 Position 

Click on the Position menu tab to set the location. 

 Label  

Click on the Label to display the menu label, and choose to turn it on or off. 

 Event Table 

Click on the Event Table menu tab to enter the event table settings menu. 

 Event Table 

The event table can be selected to open or close. 

 Format 

Click on the Format menu tab to set the format of the event table. The options 

include hexadecimal, decimal, binary, and ASC. 

 View 

Click on the View menu tab to select Package, Details, and Data. 

 Export 

Click on the Export menu label, and when the view selects "package", 

information such as time and corresponding decoding data can be exported. 

 Jump 

Click on the Jump menu tab to display the specified data waveform in the 

center view of the screen. 

6. Setting: 

Click on the Setting menu tab to enter the Settings menu. 

 Endian 

Click on the Endian menu tab to select either MSB or LSB. 

 LSB: Least Significant Bit, which means that the low bit of data is transmitted 
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first. 

 MSB: Most Significant Bit (most significant bit), that is, the high data bits are 

transmitted first. 

 Width 

Click on the Width menu tab and select the bus width for decoding data through the 

pop-up menu. 

7. Copy Trig: 

Click on the Copy Trig menu tab to select the Copy Trigger function. The copy trigger 

function can quickly apply trigger settings to corresponding types of decoding functions.  

8. Decoding example: 

 

Figure 14.7 SPI decoding example 

14.4 LIN Decoding                                        

The oscilloscope samples the LIN signal and determines whether each data point is a 

logic "1" or a logic "0" based on the set threshold level. LIN decoding requires specifying 

the LIN signal protocol version. 

Click [Decode] in the button area to enter the decoding function menu. 

1. Bus Type: 

Click on the Bus Type menu tab and select LIN from the pop-up menu to configure LIN 

decoding. 

2. Bus Status: 

Click or tap On/Off button for the Bus Status menu item and choose to enable/disable 

the bus decoding. 

3. Source: 
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Click on the Source menu tab and select the source channel. 

4. Threshold: 

Click on the Threshold menu tab and set the threshold using the multi-functional knob 

V0 or the numeric keypad. 

When changing the threshold of the clock channel, a dashed line appears on the screen 

displaying the current threshold level. When the change is stopped, the dashed line of 

the threshold level disappears after about 2 seconds. 

5. Setting: 

Click on the Setting menu tab to enter the Settings menu. 

 Baud Rate: 

Click on the Baud Rate menu tab and select Baud Rate from the pop-up menu. 

 Parity Bit: 

Click on the Parity Bit menu tab and select whether to include inspection positions or 

not. 

 Version: 

Click on the Version menu tab and select versions 1. x, 2. x, and Both. 

 Idle Level: 

Click on the Idle Level menu tab and select idle level as High/Low to set the idle state of 

the data decoding channel as high or low level. 

6. Display: 

Click on the Display Menu tab to enter the Display Settings menu. 

 Format 

Click on the Format menu tab, and the available formats include hexadecimal, decimal, 

binary, and ASCII. 

 Position 

Click on the Position menu tab to set the location. 

 Label  

Click on the Label to display the menu label, and choose to turn it on or off. 

 Event Table 

Click on the Event Table menu tab to enter the event table settings menu. 

 Event Table 

The event table can be selected to open or close. 

 Format 

Click on the Format menu tab to set the format of the event table. The 

options include hexadecimal, decimal, binary, and ASC. 

 View 

Click on the View menu tab to select Package, Details, and Data. 
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 Export 

Click on the Export menu label, and when the view selects "package", 

information such as time and corresponding decoding data can be exported. 

 Jump 

Click on the Jump menu tab to display the specified data waveform in the 

center view of the screen. 

7. Copy Trig: 

Click on the Copy Trig menu tab to select the Copy Trigger function. The copy trigger 

function can quickly apply trigger settings to corresponding types of decoding functions. 

If the source channel is an analog channel, the threshold level settings will also be 

copied. 

8. Decoding example: 

 

Figure 14.8 LIN decoding example 

14.5 CAN Decoding                                       

The oscilloscope samples CAN or CAN-FD signals at the designated sampling position, 

and will also determine whether each data point is a logic "1" or a logic "0" based on the 

set threshold level. CAN decoding requires specifying the CAN or CAN-FD signal type 

and sampling location. 

Click [Decode] in the button area to enter the decoding function menu. 

1. Bus Type: 

Click on the Bus Type menu label and select CAN from the pop-up menu to configure 

CAN decoding. 

2. Bus Status: 

Click or tap On/Off button for the Bus Status menu item and choose to enable/disable 
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the bus decoding. 

3. Source: 

Click on the Source menu tab and select the source channel. 

4. Threshold: 

Click on the Threshold menu tab and set the threshold using the multi-functional knob 

V0 or the numeric keypad. 

When changing the threshold of the clock channel, a dashed line appears on the screen 

displaying the current threshold level. When the change is stopped, the dashed line of 

the threshold level disappears after about 2 seconds. 

5. Setting: 

Click on the Setting menu tab to enter the Settings menu. 

 Signal: 

Click on the Signal menu label, and the signal types that can be selected are: CAN_ H, 

CAN_ L, Rx, Tx, Diff. 

 CAN_ H: Actual CAN_ H-bus signal. 

 CAN_ L: Actual CAN_ L-bus signal. 

 Rx: Received signal from CAN signal line. 

 Tx: Sending signal from CAN signal line. 

 Diff: Use a differential probe to connect to the CAN differential bus signal of 

the analog channel. Positive connection CAN of differential probe_ H-bus 

signal, negative connection CAN of differential probe_ L-bus signal. 

 Baud: 

Click on the Baud menu tab and select Baud Rate from the pop-up menu. 

 Sample Position: 

It can be set either by the V0 knob or through the pop-up numeric keypad. The 

adjustable range is from 10% to 90%. 

Sample position is a point within a bit's time. The oscilloscope samples the bit level at 

this point. The sample position is represented by the proportion of "the time from the 

start of the bit to the sample point" to the "bit time", as shown in the figure below. 

 
Sample Position 

6. Display: 

Click on the Display Menu tab to enter the Display Settings menu. 

 Format 
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Click on the Format menu tab, and the available formats include hexadecimal, decimal, 

binary, and ASCII. 

 Position 

Click on the Position menu tab to set the location. 

 Label  

Click on the Label to display the menu label, and choose to turn it on or off. 

 Event Table 

Click on the Event Table menu tab to enter the event table settings menu. 

 Event Table 

The event table can be selected to open or close. 

 Format 

Click on the Format menu tab to set the format of the event table. The 

options include hexadecimal, decimal, binary, and ASC. 

 View 

Click on the View menu tab to select Package, Details, and Data. 

 Export 

Click on the Export menu label, and when the view selects "package", 

information such as time and corresponding decoding data can be exported. 

 Jump 

Click on the Jump menu tab to display the specified data waveform in the 

center view of the screen. 

7. Copy Trig: 

Click on the Copy Trig menu tab to select the Copy Trigger function. The copy trigger 

function can quickly apply trigger settings to corresponding types of decoding functions. 

8. Decoding example: 

 

Figure 14.9 CAN decoding example 
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15 Protocol Generator                              

This series of machines support a variety of protocol generator functions, click the 

navigation icon [Hantek] in the upper left corner of the screen, select Protocol, enter 

the setting menu. 

The contents of this chapter include: 

 UART Protocol 

 LIN Protocol 

 CAN Protocol 

 SPI Protocol 

 IIC Protocol 
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15.1 UART Protocol                                       

Click the navigation icon [Hantek] to open the protocol generator menu. 

  

1. Type: 

Click the Type menu tab and select the "UART" type for specific Settings. 

After the protocol generation type is selected, the menu changes to the UART Setting 

menu. 

2. Method: 

Click the Method menu tab to select the following modes: SigFixedValue and 

SigRandomValue. 

3. SendData: 

Click on the SendData menu tab to set the data value by rotating the multifunction knob 

V0 or directly set the send data value by popping up the numeric keypad. 

4. DataBits: 

Click the DataBits menu tab and select data bits from the drop-down menu: 4bits, 5bits, 

6bits, 7bits, 8bits. 

5. Bandrate: 

Click the Baudrate menu tab and select the desired Baud rate from the drop-down 

menu or select Custom Baud rate. 

6. Idle Level: 

Click the Idle Level menu tab to select the idle level as High or Low. 

7. Parity Check: 

Click the Parity Check tab to select the check mode as Null, Odd check, or Even check. 

8. Trigger Mode: 



  Protocol Generator 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

153 

Click the Trigger Mode menu tab and select Auto or Manual. 

9. Send Interval: 

Click on the Send Interval menu tab to set the interval value by turning the multifunction 

knob V0 or directly set the interval value by popping up the numeric keypad.  

10. Burst: 

When the trigger mode is set to manual trigger, click the Burst menu tab to manually 

trigger once. 

15.2 LIN Protocol                                        

Click the navigation icon [Hantek] to open the protocol generator menu. 

  

1. Type: 

Click on the Type menu tab and select the "LIN" type for specific Settings. 

After selecting the protocol generation type, the menu changes to the LIN Settings 

menu. 

2. Method: 

Click the Method menu tab to select the following modes: SigFixedValue and 

SigRandomValue. 

3. Identifier: 

Click on the Identifier menu tab and set the identifier value by rotating the multifunction 

knob V0 or set the send identifier value directly on the popup numeric keypad. 

4. Data: 

Click on the Data menu tab to set the data values by turning the multifunction knob V0 

or by the pop-up numeric keypad directly. 
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5. Baudrate: 

Click the Baudrate menu tab and select the desired Baud rate from the drop-down 

menu or select Custom Baud rate. 

6. Idle Level: 

Click the Idle Level menu tab to select the idle level as High or Low. 

7. DataByte: 

Click on the DataByte menu tab and select from the drop-down menu: 1 Byte, 2 Byte, 3 

Byte, 4 Byte, 5 Byte, 6 Byte, 7 Byte, 8 Byte. 

8. Trigger Mode: 

Click the Trigger Mode menu tab and select Auto or Manual. 

9. Send Interval: 

Click on the Send Interval menu tab to set the interval value by turning the multifunction 

knob V0 or directly set the interval value by popping up the numeric keypad. 

10. Burst: 

When the trigger mode is set to manual trigger, click the Burst menu tab to manually 

trigger once. 

15.3 CAN Protocol                                        

Click the navigation icon [Hantek] to open the protocol generator menu. 

  

1. Type: 

Click the Type menu tab and select the "CAN" type for specific Settings. 

After the protocol generation type is selected, the menu changes to the CAN Settings 

menu. 

2. Method: 
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Click the Method menu tab to select the following modes: SigFixedValue and 

SigRandomValue. 

3. FrameID: 

Click the FrameID menu tab, you can select the label ID as: standard, extended 29 bits. 

4. Frame ID data: 

Click on the Frame ID data menu tab to set the data value by rotating the multifunction 

knob V0 or directly set the frame ID data value by popping up the numeric keypad. 

5. Bandrate: 

Click the Baudrate menu tab and select the desired Baud rate from the drop-down 

menu or select Custom Baud rate. 

6. Idle Level: 

Click the Idle Level menu tab to select the idle level as High or Low. 

7. FrameType: 

Click the Frame Type menu tab and select from the drop-down menu: Data frame 

length 1-8, Remote frame, Error frame, Overload frame. 

8. Data: 

Click on the Data menu tab to set the data values by turning the multifunction knob V0 

or by the pop-up numeric keypad directly. 

9. Trigger Mode: 

Click the Trigger Mode menu tab and select Auto or Manual. 

10. Send Interval: 

Click on the Send Interval menu tab to set the interval value by turning the multifunction 

knob V0 or directly set the interval value by popping up the numeric keypad. 

11. Burst: 

When the trigger mode is set to manual trigger, click the Burst menu tab to manually 

trigger once. 

15.4 SPI Protocol                                         

Click the navigation icon [Hantek] to open the protocol generator menu. 
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1. Type: 

Click the Type menu tab and select the "SPI" type for specific Settings. 

After the protocol generation type is selected, the menu changes to the SPI Settings 

menu. 

2. Method: 

Click the Method menu tab to select the following modes: SigFixedValue and 

SigRandomValue. 

3. BitWide: 

Click the BitWide menu tab, and the data bit width can be selected from the drop-down 

menu: 4, 8, 16, 24, 32. 

4. Databit: 

Click on the Databit menu tab to set the data values by turning the multifunction knob 

V0 or by the pop-up numeric keypad directly. 

5. Send rate: 

Click the Send rate menu tab and select the desired send rate from the drop-down 

menu or select Custom send rate. 

6. ClockEdge: 

Click the ClockEdge menu tab to select the clock edge as a rising or falling edge. 

7. Trigger Mode: 

Click the Trigger Mode menu tab and select Auto or Manual. 

8. OverTime: 

Click on the OverTime menu tab to set the interval value by turning the multifunction 

knob V0 or directly set the interval value by popping up the numeric keypad. 

9. Burst: 

When the trigger mode is set to manual trigger, click the Burst menu tab to manually 
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trigger once. 

15.5 I2C Protocol                                         

Click the navigation icon [Hantek] to open the protocol generator menu. 

  

1. Type: 

Click the Type menu tab and select the "IIC" type for specific Settings. 

After the protocol generation type is selected, the menu changes to the IIC Settings 

menu. 

2. Method: 

Click the Method menu tab to select the following modes: SigFixedValue and 

SigRandomValue. 

3. Address: 

Click on the Address menu tab and set the address by turning the multifunction knob 

V0 or the pop-up numeric keypad directly. 

4. Data: 

Click on the Data menu tab to set the data values by turning the multifunction knob V0 

or by the pop-up numeric keypad directly. 

5. Send rate: 

Click the Send rate menu tab and select the desired send rate from the drop-down 

menu or select Custom send rate. 

6. AddressWide: 

Click the AddressWide menu tab, and select the address bit width: 7bits, 10bits from 

the drop-down menu. 
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7. DataBits: 

Click the DataBits menu tab, and select the data bits as follows: 1 Byte, 2 Byte, 3 Byte, 

4 Byte, 5 Byte, 6 Byte, 7 Byte, 8 Byte from the drop-down menu. 

8. Trigger Mode: 

Click the Trigger Mode menu tab and select Auto or Manual. 

9. OverTime: 

Click on the OverTime menu tab to set the interval value by turning the multifunction 

knob V0 or directly set the interval value by popping up the numeric keypad. 

10. Burst: 

When the trigger mode is set to manual trigger, click the Burst menu tab to manually 

trigger once. 
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16 Storage and Load                         

Users can save the current oscilloscope settings, waveforms, screen images, and 

parameters in various formats to internal memory or an external USB storage device 

(such as a USB flash drive), and can reload saved settings or waveforms when needed. 

In addition, users can perform replication on specified types of files in internal storage or 

external USB drives through the disk management menu operations such as creating, 

deleting, and renaming. 

This chapter includes: 

 Storage Type 

 Load Type 

 External Storage and Load 

 Internal Storage and Load 

 Disk Management 

 



Storage and Load 

  EN 

HRDO2000 User manual                                              Copyright © Qingdao Hantek Electronic Co., LTD 

160 

16.1 Storage Type                                        

Click the [Save/Recall] button in the button area to open the save/recall menu. 

1. Image storage: 

Click on the Save Image menu tab to enter the Image Storage Settings menu. 

  

 Format: 

Click on the Format menu tab, and the types you can choose include: *. png, *. bmp, *. 

ipg, and *. tif. Image storage will be stored in the selected type to the internal or external 

memory of the machine. 

 File Name: 

Click on the File Name menu tab and set the file name on the pop-up keyboard. Please 

refer to the NewFolder for the file name input method. Press the More -> Auto Name 

key to automatically generate a file name when Auto Name On. When Auto Name Off, if 

a file name already exists and is saved with the same file name again, a prompt box will 

pop up to prompt the user that the file will be overwritten. Do you want to continue. 

 Invert: 

Click on the Invert menu tab to select the ON or OFF image anti color function. 

 Color: 

Click on the Color menu tab to choose whether to save the image in color or gray. 

 NewFolder: 

Click on the NewFolder menu tab and set the directory name on the pop-up keyboard. 

 Window: 
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Click on the Window menu tab and choose to open or close the window. 

 Save: 

Click on the Save menu tab to save the set image in internal or external memory. Press 

the More -> Header. If the header display is turned on, when saving the image file, the 

instrument model and image construction date will be displayed in the header of the 

image. 

Tips: After connecting the USB Flash drive (FAT32, Flash format), press the [Quick 

Action] key on the front panel to save. You can choose to save it in the internal storage 

or the external USB flash drive. 

2. Save Wave: 

Click on the Save Wave menu tab to enter the waveform storage settings menu. The 

waveform storage can save the oscilloscope's setting information (channel switch 

settings, vertical gear, horizontal time base, etc.) and open the waveform data of the 

channel. 

  

 Data Source: 

Click on the Data Source menu tab and select Screen or Memory. 

 Format: 

Click on the Format menu tab, and the types you can choose are: *.csv,*.wfm. 

 Source: 

Click on the Source menu tab to select types such as CH1, CH2, CH3, CH4, digital 

channels (D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3). The resource menu can only 

be set when selecting the data source as memory. 

 Window: 
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Click on the Window menu tab and choose to open or close the window. 

 File Name: 

Click on the File Name menu tab and set the file name on the pop-up keyboard. Please 

refer to the NewFolder for the file name input method. Press the More -> Auto Name 

key to automatically generate a file name when Auto Name On. When Auto Name Off, if 

a file name already exists and is saved with the same file name again, a prompt box will 

pop up to prompt the user that the file will be overwritten. Do you want to continue. 

 NewFolder: 

Click on the NewFolder menu tab and set the directory name on the pop-up keyboard. 

 Save: 

Click the Save menu tab to save the set waveform in internal or external memory. 

3. Save Setup: 

Click on the Save Setup Menu tab to enter the Set Storage Settings menu. Set Storage 

will save the oscilloscope settings to internal or external memory. 

 

 File Type: 

Click on the File Type menu tab to select types such as *. stp. 

 File Name: 

Click on the File Name menu tab and set the file name on the pop-up keyboard. Please 

refer to the NewFolder for the file name input method. Press the More -> Auto Name 

key to automatically generate a file name when Auto Name On. When Auto Name Off, if 

a file name already exists and is saved with the same file name again, a prompt box will 

pop up to prompt the user that the file will be overwritten. Do you want to continue. 

 NewFolder: 
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Click on the NewFolder menu tab and set the directory name on the pop-up keyboard. 

 Window: 

Click on the Window menu tab and choose to open or close the window. 

 Save: 

Click on the Save menu tab to save the settings in internal or external memory. 

16.2 Load Type                                            

Load files stored inside or outside the machine into the machine. Select waveform 

loading or set loading, and the file path will pop up on the screen. 

1. Load Wave: 

Click on the Load Wave menu tab to enter the waveform loading settings menu. 

 File Type: 

Click on the File Type menu label, with the type: *. wfm. 

 Load: 

Click on the Load menu tab to load the selected file. 

2. Load Setup: 

Click on the Load Setup Menu tab to enter the Settings Load Settings menu. 

 File Type: 

Click on the File Type menu tab to select types such as *. stp and *. ptr. 

 Load: 

Click on the Load menu tab to load the selected file. 

16.3 External Storage and Load                           

The first step for external storage of an oscilloscope is to ensure that the USB flash 

drive is correctly connected. The external storage function supports image, waveform, 

setting storage, and loading of waveforms and settings. 

1. For example, storing the waveform of a specified type of file in an external 

USB drive: 

 Oscilloscope obtains signal; 

 Open the waveform storage function and enter the storage settings menu; 
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 Open the menu interface for external storage through multi-functional knobs or 

touch screen functions, and select the path to store. In addition, a new storage 

path can be created in external storage through the function of creating a new 

directory; 

 In the storage menu, select the storage type as waveform storage. For specific 

information on waveform storage, please refer to the relevant chapters; 

 Click Save, and the waveform file will be stored in the selected directory in the set 

save format. 

2. For example, to load the waveform of a specified type of file from an external 

USB drive: 

 Open the waveform storage function and enter the waveform loading interface; 

 Open the menu interface of external storage through multi-functional knobs or 

touch screen functions, and select the loading path; 

 After selecting the file to load, click Load to load the selected file. 

16.4 Internal Storage and Load                            

The internal storage function supports the storage and loading of images, waveforms, 

settings, reference waveforms, pass/fail test rule files. 

1. For example, saving the specified type of file settings file in internal storage: 

 Oscilloscope obtains signal; 

 Open the storage function menu, select Set Storage, and the disk management 

interface will pop up. By default, "XX" is selected; 

 Open the internal storage interface through multifunctional knobs or touch screen 

functions; 

 Open the menu interface for external storage through multi-functional knobs or 

touch screen functions, and select the path to store. In addition, a new storage 

path can be created in external storage through the function of creating a new 

directory; 

 Click on the File Name to name the stored settings file. Click More -> Auto Name, 

and the file name will be automatically generated. If the file name is duplicate and 

already exists, a prompt box will pop up. 

2. For example, loading the settings file for internal storage: 

 Open the storage function menu, select Set Storage, and the disk management 

interface will pop up. By default, "XX" is selected 
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 Open the internal storage interface through multifunctional knobs or touch screen 

functions; 

 Open the menu interface for external storage through multi-functional knobs or 

touch screen functions, and select the path to store; 

 Select the file to load through the multi-functional knob or touch screen function, 

and click Load to load the selected file. 

16.5 Disk Management                                     

Click the [Save/Recall] button in the button area to open the save/recall menu. Click on 

Disk menu to open the disk management interface. Select the disk by rotating the 

multi-functional knob V0 or touching the function. 

 

Through the disk management menu, you can perform the following operations: 

 Choose a file type 

 Copy and paste files or directories 

 Rename files or directories 

 Delete files or directories 

 Create a new directory 

 Safely clear internal memory 

1. File Type 

Click on [Save/Recall] -> Disk -> File Type, and rotate the multi-functional knob V0 to 

select the desired file type. The default is' *. * '. Only files with a file name suffix that 

matches the selected file type will be displayed in the current path. 

2. Copy 

Press [Save/Recall] -> Disk, rotate the multi-functional knob V0 to select internal or 

external storage, and press this knob to open it. Rotate the multi-functional knob V0 to 

select the file or directory to be copied. Press the Copy key to copy the selected file or 
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directory. 

3. Paste 

Press [Save/Recall] -> Disk, rotate the multi-functional knob V0 to select internal or 

external storage, and press this knob to open it. Rotate the multi-functional knob V0 to 

select the file or directory to be pasted. Press the Paste button to paste the selected file 

or directory. 

4. Rename 

Press [Save/Recall] -> Disk, rotate the multi-functional knob V0 to select internal or 

external storage, and press this knob to open it. Rotate the multi-functional knob V0 to 

select the file or directory that needs to be renamed. Press the Rename button to open 

the file name input interface. Please refer to the NewFolder for the file name input 

method. 

5. Delete 

 Delete files or directories from internal storage 

 Press [Save/Recall] -> Disk, rotate the multifunction knob to select the 

internal storage Local Disk (C), and press the knob to open it. 

 Rotate the multi-functional knob V0 to select the file or directory to be deleted. 

 Press the Delete button and in the pop-up delete confirmation box, click OK 

to delete the file or directory. 

 Delete files or directories from external storage 

 Press [Save/Recall] -> Disk, rotate the multifunction knob to select external 

memory, and press the knob to open it. 

 Rotate the multi-functional knob V0 to select the file or directory to be deleted. 

 Press the Delete button and in the pop-up delete confirmation box, click OK 

to delete the file or directory. 

6. NewFolder 

Before using external storage, please ensure that the USB flash drive (FAT32 format, 

Flash type) is properly connected. In the disk management interface, select the storage 

path through the multi-functional knob V0 or use the touch screen function, and select 

Internal Storage Local Disk (C) by default. Then press the NewFolder button to open 

the interface shown in the following figure. 
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Figure 16.1 To Create a Folder 

This oscilloscope supports both Chinese and English input methods. Below are 

instructions on how to input the name of a directory using both Chinese and English 

input methods. 

 Create English Name: 

 

 Choose English input method 

If the current input method is En/中, please skip to the next step; If the current 

input method is 中/En, click this button to switch the input method to En/中, 

with "En" arranged first. 

 Clear the name input area 

If the current "Name Input Area" does not contain characters, please skip to 

the next step; If the current "Name Input Area" contains characters, click the 

delete button to delete all characters in the name input area in sequence. 

 Input the first character 'N' 

 Currently in uppercase, please skip to the next small step; If lowercase is 

currently displayed, select the case switch button to switch the 
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characters to uppercase. 

 If "F" is selected and the knob is pressed, the character will appear in the 

input area. 

 Input other characters 

Refer to the previous step and use the same method to input the remaining 

characters 'ame' in sequence, paying attention to capitalization during the 

input process. 

 Modify or delete inputted characters 

During the name input process, you can modify or delete the characters that 

have already been entered. To delete a character that has already been 

entered, select the delete key and press to delete the character. If you modify 

a character that has already been entered, delete the character and re-enter 

the desired character. If the modified character is in the middle, it needs to be 

deleted from the last character forward (left) to the character that needs to be 

modified, and then re-enter the character. 

 After completing the input, click the completion button, and the oscilloscope 

will create a specified type of file or directory under the current path with that 

file name. 

 Create a Chinese name File name: 

 

 Select Chinese input method 

If the current input method is Medium/En, please skip to the next step; If the 

current input method is En/Medium, click this button to switch between input 

methods, so that the input method is Medium/En and the middle is arranged 

first. 

 Clear the Pinyin input area and name input area 

If the current Pinyin input area and name input area do not contain characters, 
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please skip to the next step; If the current pinyin input area and name input 

area contain characters, click the delete button to delete all characters in the 

name input area in sequence. 

 Input the first Chinese character 'text' 

 Input pinyin wen in the pinyin input area 

Click on the first letter "w" in Pinyin wen to enter "w" in the Pinyin input 

area. Use the same method to input the remaining letters "en" in Pinyin 

wen in sequence. After the input is completed, optional Chinese 

characters will be displayed in the Chinese character selection area. 

 Select the desired Chinese character in the Chinese character selection 

area 

Click on "text" in the Chinese character selection area to input text in the 

name input area. If the desired Chinese character is not on the current 

page, please press the switch to next page key to switch to the next 

page selection. 

 Input other characters 

Refer to the previous step and use the same method to input the remaining 

Chinese characters' part names' in sequence. 

 Modify or delete inputted characters 

During the input process, you can modify or delete the inputted characters in 

the name input area and delete the inputted pinyin characters in the pinyin 

input area. To delete the entered characters, select the delete key on the 

virtual keyboard and press to delete the characters. If you modify a character 

that has already been entered, delete the character and re-enter the desired 

character. If the modified character is in the middle, it needs to be deleted 

from the last character forward (left) to the character that needs to be 

modified, and then re-enter the character. 

 After completing the input, click the completion button, and the oscilloscope 

will create a specified type of file or directory under the current path with that 

file name. 

7. SecurityClear 

Press [Save/Recall] -> Disk, rotate the multifunction knob to select Internal Memory 

Local Disk (C). 

Press the SecurityClear button to pop up a security clear confirmation dialog box. 

Press the OK key to clear all stored files on the internal memory. 
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17 Analyze                               

This chapter includes: 

 Frequency Counter 

 Digital Voltmeter (DVM) 

 Power Analysis (Option) 

 Histogram Analysis 

 Bode Plot 
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17.1 Frequency Counter                                  

The frequency meter analysis function can provide counting and measurement of 

frequency, period, or edge events on any analog channel. You can enter the frequency 

meter settings menu by using the following methods: 

 

 Click on the button area [Analyze] to select the frequency counter function. 

 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

the frequency counter, and enter the settings menu. 

After enabling the frequency meter function, enter the frequency meter settings menu 

and select the signal source and measurement item. 

1. Select measurement source: 

Select the desired measurement signal source and click on the corresponding 

frequency meter menu label: CH1 frequency meter, CH2 frequency meter, CH3 

frequency meter, and CH4 frequency meter. 

2. Select measurement item: 

The measurement items supported by a frequency meter include Frequency, Period, 

and Totalize. 

Totalize: Counting of signal edge events. 

3. Statistics: 

Click on the Statistic menu tab and select on or off. After selecting to open statistics, a 

window with statistical results will appear on the left side of the screen 

4. Clear Count: 

When the measurement item is selected to accumulate and measure the count of signal 

edge events, clicking the Clear Count button can reset the measurement result to zero. 
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17.2 Digital Voltmeter (DVM)                              

The digital voltmeter (DVM) of this series of digital oscilloscopes can measure the 

voltage of six significant digits on any analog channel. The collection system of DVM 

measurement and oscilloscope is asynchronous and always performs collection. 

The voltmeter setting menu can be accessed through the following methods: 

  

 Click the key area [Analyze] -> DVM to enter the DVM setting menu. 

 Click the navigation icon [Hantek] in the upper left corner of the screen, select 

“DVM” to enter the setting menu. 

1. DVM: 

The measurement modes include AC RMS, DC, and AC+DC RMS. 

 AC RMS: Display the root mean square value of the DC component in the 

collected mode. 

 DC: Display the average value of the collected data. 

 AC+DC RMS: displays the root mean square value of the collected data. 

After opening the DVM measurement, the display is as shown in the following figure. The 

DVM display result includes a calibration, the range of which is determined by the vertical 

position and vertical offset of the channel, and the calibration range is the screen range. 

The calibrated orange triangular indicator shows the most recent measurement results. 

 

Note: The DVM measurement shares the probe with this oscilloscope, so the unit 

displayed by the DVM measurement is consistent with the channel unit. 

2. Limits: 
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Click on the Limits menu tab to enter the limit setting menu. 

 Source: 

Click the Source menu tab to set the analog channel corresponding to the limit 

parameter. 

 Buzzer: 

Click on the Buzzer menu tab and choose to turn the buzzer on or off. 

 Limit conditions: 

Click on the menu label of When to select whether the In Limits or Out Limits. 

 In Limits: Enable or disable the buzzer when the voltage value is within the 

set limit range. 

 Out Limits: Enable or disable the buzzer when the voltage value is outside 

the set limit range. 

 Upper and Lower values: 

Set the upper or lower limit of the voltage limit value through the multi-functional knob 

V0 or the pop-up numeric keyboard. 

17.3 Power Analysis (Option)                               

The series oscilloscope is equipped with power analysis function, which can help users 

quickly and easily analyze the efficiency and reliability of switching power supplies. 

Using the power analysis function, you can analyze the power quality of the input power 

supply and output ripple noise. You can enter power analysis through the following 

methods: 

 Click on the button area [Analyze] -> Power Analyzer to enter the Power Analysis 

Settings menu. 

 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

Power Analyzer, and enter the settings menu. 

17.3.1 Power Quality                                            

Analyzing power quality can test the quality of AC input lines. The specific measurement 

parameters for power quality analysis include the measurement of electrical parameters 

such as voltage effective value, current effective value, active power, apparent power, 

reactive power, power factor, reference frequency, phase angle, impedance, voltage 

peak factor, and current peak factor at the input end of the power supply 

In the Power Analysis menu, click the Analysis Type menu tab and select the Power 

Quality option. 
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1. Source: 

Click on the Source menu tab to set the power quality source. You can choose voltage 

channel, current channel, and frequency reference. 

 Voltage channel: 

Click on the Voltage menu label and select the channels CH1~CH4 for collecting 

voltage. 

 Current channel: 

Click on the Current menu tab and select the channels CH1~CH4 for collecting current. 

 Frequency reference: 

Click on the Fre.Ref menu tab and set the frequency to be referenced by the voltage 

channel or current channel. 

2. Display: 

Click on the Display menu tab to choose whether to turn on or off the display results. 

When opened, the results are displayed on the screen, as shown in the following figure. 

 

3. Count: 

Click on the Count menu tab, and you can set the frequency meter by rotating the knob 

V0 or directly set the counting on the pop-up numeric keyboard. 
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4. Reset: 

Click on the Reset stat. menu tab to clear the current data and recalculate the 

measurement results. 

5. Wiring diagram: 

Click on the Tips menu label, and a wiring diagram for power quality analysis will pop up 

on the screen. 

 

Figure 17.1 Power Analysis Wiring Diagram 

17.3.2 Ripple                                                    

Power ripple is an important parameter for evaluating DC power supplies, representing 

the fluctuation of output DC voltage. Ripple analysis can measure the current value, 

average value, minimum value, maximum value, standard deviation, and count value of 

the ripple at the power output end. 

In the Power Analysis menu, click the Analysis Type menu tab and select the Ripple 

option. 
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1. Source: 

Click on the Source menu tab and select the ripple analysis sources CH1~CH4. 

2. Count: 

Click on the Count menu tab, and you can set the frequency meter by rotating the knob 

V0 or directly set the counting on the pop-up numeric keyboard. 

3. Reset: 

Click on the Reset stat. menu tab to clear the current data and recalculate the 

measurement results. 

4. Display: 

Click on the Display menu tab to choose whether to turn on or off the display results. 

When opened, the results are displayed on the screen, as shown in the following figure. 

 

5. Wiring diagram: 

Click on the Tips menu label, and a wiring diagram for power quality analysis will pop up 

on the screen. 
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Figure 17.2 Ripple Wiring Diagram 

17.4 Histogram Analysis                                  

The analysis histogram function of this series of oscilloscopes can provide statistical 

views for waveforms or measurement results. 

You can enter the histogram through the following methods: 

 Click on the button area [Analyze] -> Histogram to enter the Histogram Settings 

menu. 

 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

the histogram, and enter the settings menu. 
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17.4.1 Enable                                                    

Click on the Enable menu tab to turn on or off the histogram analysis function. 

17.4.2 Type                                                     

Click on the Type menu tab to select the histogram types: Horizontal and Vertical. 

 Horizontal histogram: A bar histogram at the bottom of the screen displays the 

number of times statistical data is displayed in columns. 

 Vertical histogram: displays the number of times statistical data is displayed in 

rows in a bar histogram on the left side of the screen. 

17.4.3 Source                                                  

Click on the Source menu tab, and you can select CH1~CH4 information sources. Only 

when the histogram type is horizontal or vertical histogram, it is necessary to select the 

source (CH1~CH4). 

17.4.4 Histogram height                                        

Click on the Histogram height menu tab and set the histogram height in the pop-up 

numeric keypad or rotate the knob V0 to set the histogram height, with a range of 1-4. 

The height of the histogram is the number of grids occupied by the histogram on the 

screen. 

17.4.5 Statistics                                                 

Click on the Statistics menu tab to select whether to turn on or off the statistics function. 

Turn on the statistics function, and the screen will pop up with the statistical results 

shown in the following figure. 

 

 Sum: The number of times all data is counted. 
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 Peaks: The number of times the data is counted the most. 

 Max: The maximum value of the histogram range. 

 Min: The minimum value within the histogram range. 

 Pk_Pk: The increment of the value corresponding to the highest number of data 

statistics and the value corresponding to the lowest number of data statistics. 

 Mean: The average value corresponding to the histogram. 

 Median: The median value corresponding to the histogram. 

 Mode: The crowdsourcing value corresponding to the histogram. 

 Bin width: The width corresponding to the histogram. 

 Sigma: The standard deviation corresponding to the histogram. 

17.4.6 Reset Statistics                                           

Click the Reset menu tab to reset the statistical data to zero and perform statistics 

again. 

17.4.7 Range Settings                                           

Click on the Range menu tab to enter the range setting menu. You can adjust the size 

and position of the histogram window by setting the left, right, upper, and lower 

boundaries. Set the boundary value by rotating the knob V0 or the pop-up numeric 

keyboard. 

Note: 

The adjustment of horizontal time base and vertical gear does not affect the time base 

size of the histogram range, but only shows synchronous changes with gear. 

17.5 Bode Plot(Option)                                             

Porter plot is a graphical method of describing the frequency response of a system. The 

baud chart is the curve that loop analysis can measure the gain and phase of a system 

as a function of frequency in a switching power supply and operational amplifier 

feedback network. The gain margin and phase margin of the system can be analyzed 

through the Bode diagram, and the stability of the system has been determined. 

The series digital oscilloscope generates a sweep signal within a specified frequency 

range through a built-in signal generation module, and outputs it to the injection point of 

the tested switching power supply circuit. The oscilloscope tests the phase difference 

change curve and gain change curve of the injection and output ends at different 

frequencies to draw a Bode plot. 
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You can access the Bode plot by: 

 Click on the button area [Analyze] -> Bode Plot to enter the Porter Chart Settings 

menu. 

 Click on the navigation icon [Hantek] in the upper left corner of the screen, select 

the Porter chart, and enter the settings menu. 

 

17.5.1 Enable                                                    

Click on the Function menu tab and choose to open or close the Porter chart. 

17.5.2 Parameter settings                                       

Click on the Parameter Set menu tab to enter the parameter setting menu. 

1. Input Source: 

Click on the Input Source menu tab to select CH1-CH4 as the input source. The input 

source is the channel of the input signal, which serves as the reference for the current 

frequency. Before selecting an input source, it is necessary to connect the measured 

signal to the analog channel input of the oscilloscope. 

2. Output Source: 

Click on the Output Source menu tab to select CH1-CH4 as the output source. The 

output source is the channel that connects the feedback output signal. Before selecting 

the output source, it is necessary to connect the measured signal to the analog channel 

output terminal of the oscilloscope. 

3. Minimum frequency: 

Click on the Min Freq menu tab, and the frequencies you can select are: 10Hz, 100Hz, 

1KHz, 10KHz, 100KHz, 1MHz, and 10MHz. 
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4. Maximum frequency: 

Click on the Max Freq menu tab, and the frequencies you can select are: 100Hz, 1KHz, 

10KHz, 100KHz, 1MHz, 10MHz, and 25MHz. 

17.5.3 Chart Settings                                           

Click on the Icon Set menu tab to enter the Chart Settings menu. 

1. Gain gear: 

Click on the Gain Scale menu tab and adjust the gain gear through the multi-functional 

knob V0. 

2. Gain offset: 

Click on the Gain Off menu tab and adjust the gain offset through the multi-functional 

knob V0. 

3. Phase Scale: 

Click on the Phase Scale menu tab and adjust the phase shift through the 

multi-functional knob V0. 

4. Phase offset: 

Click on the Phase Off menu tab and adjust the phase shift through the multi-functional 

knob V0. 

17.5.4 Show Type                                               

Click the Show Type menu tab to select Line Chart or Form. 

17.5.5 Wiring Diagram                                           

Click on the Bode Tips menu label, and a wiring diagram of the Bode diagram will pop 

up on the screen. 
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Figure 17.3 Bode diagram wiring diagram 
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18 Digital Channel                        

This series of machines are equipped with Logic analyzer function as standard, 

including 16 digital channels. The default channel label is D1.0-D1.3, D2.0-D2.3, 

D3.0-D3.3 and D4.0-D4.3. The oscilloscope compares the voltage obtained from each 

sampling with the preset logical threshold. If the voltage is greater than the threshold, it 

is stored as a logical "1", and vice versa, it is stored as a logical "0". The oscilloscope 

displays the logical level values (1 and 0) of waveform points in a graphical manner, 

making it easy for users to detect and analyze errors in circuit design. 

 Click the [LA] button in the front panel button area to enter the digital channel. 

 By touching the digital channel symbol on the screen, you can enter the LA logic 

analysis setting menu. 

This chapter includes: 

 Enable 

 Source 

 Type 

 Threshold 

 To Set the Waveform Display Size 

 To Select One of the Channels 

 



Digital Channel 

  EN 

HRDO2000 User manual                                              Copyright © Qingdao Hantek Electronic Co., LTD 

184 

18.1 Enable                                            

Click the Enable menu tag and select to turn the logic analyzer function on or off, and 

open a group of channels. 

Note: Only the channel group with the digital probe inserted can be opened. 

18.2 Source                                           

Click on the selection menu tab to open the channel menu, rotate the multifunction knob 

or touch screen function to select the channel group. 

 Select any channel group from D1.0-D1.3, D2.0-D2.3, D3.0-D3.3, D4.0-D4.3. 

Only open digital channels and grouped custom channel groups can be selected. 

18.3 Type                                              

Click on the Type menu tab and select the type of digital channel. 

18.4 Threshold                                         

Click on the Threshold menu tab to enter the threshold setting menu. The threshold to 

be set can be selected through the multi-functional knob or the numeric keyboard.  

If the voltage is greater than the threshold, it is stored as logical "1", and vice versa, it is 

stored as logical "0".  

Thresholds can be set independently for each group of channels as needed. 

18.5 To Set the Waveform Display Size                                            

Press the Height menu tab and rotate the multi-function knob to set the waveform 

display size, and then press the knob again to select. You can also select by 

continuously pressing the Height menu tab or using the touchscreen function. You can 

choose "Low", "Mid" and "Hig". 

18.6 To Select One of the Channels                                           

Click the Select menu tag and set to turn one of the channels on or off. 

Press the Select menu tab and rotate the multi-function knob to select one of the 

channels in this group, and then press the knob again to confirm.  
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19 Search and Navigation Function        

The search function allows users to quickly search for related events by setting search 

criteria. Navigation function includes recording, playing, and guiding Navigation, time 

navigation, and event navigation. 

This chapter includes: 

 Search Function 

 Navigation Function 
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19.1 Search Function                                     

The search function allows users to quickly search for related events by setting search 

criteria. 

The search function can search for channel edges, pulse width triggering, Runt pulse 

triggering, slope triggering, UART triggering, I2C triggering, or SPI triggering. 

Press the [Search] button on the front panel to open the search menu. 

  

1. Search: 

Click on the Search menu tab to turn on or off the search function. 

2. Type: 

Select the desired type, which can include Edge, Slope, Runt, Pulse, UART, I2C, or SPI. 

 Edge: 

Select the search type as Edge, and refer to the detailed introduction of Edge Trigger for 

edge settings. 

Threshold setting: Click on the Threshold setting menu label, rotate the multi-functional 

knob or the pop-up numeric keyboard to set the threshold. 

 Slope: 

Select the search type as Slope, and refer to the detailed introduction of Slope Trigger 

for slope settings. 

Threshold setting: Click on the Threshold setting menu label, rotate the multi-functional 

knob or the pop-up numeric keyboard to set the threshold A and threshold B. 

 Runt: 

Select the search type as Runt, and refer to the detailed introduction of Runt Trigger for 

under amplitude settings. 
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Threshold setting: Click on the Threshold setting menu label, rotate the multi-functional 

knob or the pop-up numeric keyboard to set the threshold. 

 Pulse: 

Select the search type as Pulse, and refer to the detailed introduction of Pulse Trigger 

for pulse width settings. 

Threshold setting: Click on the Threshold setting menu label, rotate the multi-functional 

knob or the pop-up numeric keyboard to set the threshold. 

 UART: 

Select the search type as UART, and refer to the detailed introduction of UART Trigger 

for UART settings. 

Threshold setting: Click on the Threshold setting menu label, rotate the multi-functional 

knob or the pop-up numeric keyboard to set the threshold. 

 I2C: 

Select the search type as I2C trigger, and refer to the detailed introduction of I2C Trigger 

for I2C settings. 

Threshold setting: Click on the Threshold setting menu label, rotate the multi-functional 

knob or the pop-up numeric keyboard to set the threshold. 

 SPI: 

Select the search type as edge trigger, and refer to the detailed introduction of SPI 

Trigger for edge settings. 

Threshold setting: Click on the Threshold setting menu label, rotate the multi-functional 

knob or the pop-up numeric keyboard to set the threshold 

3. Mark Table: 

Click on the Mark Table menu tab, open or close the tag table, select Open Tag Table, 

and the tag table will appear on the screen. 

4. To Trigger: 

Click on the To Trigger Menu tab to copy the settings for the selected search type to the 

corresponding trigger type. For example, if the current search type is Edge, press Copy 

to Trigger to copy the edge search Settings to the Edge Trigger Settings. 

5. From Trigger: 

Click on the From Trigger Menu tab to copy the settings for the selected search type 

into the search settings. To operate the copy self triggering function, you need to first set 

the search type. For example, if the current trigger type is Edge Trigger, press the Copy 

Self-trigger key to copy the edge trigger Settings to the Edge search Settings. 

Note: If you select the "Copy Trigger" function, you need to set the search type before 

you can copy the corresponding trigger type Settings from the trigger menu. 

6. Save events: 
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Users can Save events marker data in internal or external storage. For specific 

operations, please refer to the relevant introduction in the Store and Load. 

19.2 Navigation Function                                   

Navigation functions include Recoding & Playing Navigation, Time navigation, and 

Event navigation. 

 

1. Recoding & Playing Navigation: 

After opening the waveform recording function and completing waveform recording, you 

can press the navigation combination key to play and navigate the recorded waveform. 

Pressing the  key plays the recorded waveform in reverse order, pressing the 

key plays the recorded waveform in sequence, and pressing the  key stops 

playback. 

2. Time Navigation: 

After data collection stops, you can use the navigation key combination to quickly and 

continuously play the captured data waveform. Press the  key to play the waveform 

to the left, press the  key to play the waveform to the right, and press the  key 

to stop playing. Pressing the  key or the  key multiple times can accelerate 

the playback speed of the waveform and quickly locate the desired waveform. 

Note:  

The waveform of the time navigation function is in YT time base mode and the operating 

state is in STOP state. 

3. Event Navigation: 

After opening the search function and completing the event search, you can use the 

navigation combination keys to quickly navigate to specific events in the event marker 

table. Press the  key to navigate to the previous event (decreasing the number in 

the tag table), and press the  key to navigate to the next event (increasing the 

number in the tag table). Pressing the key does not have any effect. 
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20 Quik Key                              

Automatic setting: Automatically set the oscilloscope controls to generate useful 

displays of input signals. Please refer to the table below for details. 

Click the [Auto Scale] button to automatically set the oscilloscope. 

Default Settings: Automatically call up the default settings. 

Click the [Default Setup] button, and the machine will enter the default setting 

operation. 

This chapter includes: 

 Auto Scale 

 Default Setup 
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20.1 Auto Scale                                          

Automatic setting is one of the advantages of digital oscilloscopes. When you click on 

automatic settings, the oscilloscope will recognize the waveform type and adjust the 

control method to accurately display the waveform of the input signal. 

Table 20.1 Auto Scale 

Parameter Settings 

Acquire Normal 

Cursor Close 

Timebase Mode YT 

Display Vector 

Horizontal Adjusted 

SEC/DIV Adjusted 

Holdoff 8ns 

Trigger Level 50% 

Trigger Mode Auto 

Trigger Source Adjusted 

Trigger Slope Adjusted 

Trigger Type Edge 

Sync Adjusted 

Standard Adjusted 

Bandwidth Close 

Coupling DC 

VOLTS/DIV Adjusted 

Click on [Auto Scale] to enable the automatic setting function and open the automatic 

setting function menu. Please refer to Quick Measurement after Auto. 



  Quik Key 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               HRDO2000 User manual                                                              

191 

20.2 Default Setup                                        

Press the [Default Setup] button, and the oscilloscope will display waveforms for four 

channels. The following table provides settings for changing options, buttons, and 

controls under default settings. 

Table 20.2 Default Setup  

Horizontal 

Horizontal Time  

Base 
1us 

Horizontal Position 0s 

Delayed Sweep Off 

Timebase Mode YT 

Fine Off 

Horizontal Expansion Center 

Vertical 

Vertical Scale 1V 

Vertical Offset CH1: 3V, CH2: 1V, CH3: -1V, CH4: -3V 

CH1/CH2/CH3/CH4 CH1-CH4 On 

Channel Coupling DC 

BW Limit 20M 

Attenuation 1X 

Input Impedance 1MΩ 

Invert Off 

Channel Unit V 

Fine Off 

Ch-Ch Skew 0s 

Offset Cal 0V 

Acquire 

Acquisition Mode Normal 

Memory Depth 6.25k 
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Trigger 

Trigger Type Edge Trigger 

Source Selection CH1 

Edge Type Rising 

Trigger Holdoff 8ns 

Display 

Display Type Vector 

Persistence Time Min 

Intensity 100% 

Grid Line 

Gird Brightness 30% 

Show Scale Off 

Color Grade Off 

Brightness 100% 

AWG 

AWG Off 

Wave Sine 

Frequency 1KHz 

Amplitude 500mV 

Offset 0V 

Start Phase 0° 

Setting Type None 

Impedance HighZ 

Cursor 

Mode Off 

Manual 

Select X 

Source CH1 

AX -1us 

BX 1us 
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Track 

Source CH1 

AX -1us 

BX 1us 

Storage 

Save Image 

Format *.png 

Invert Off 

Color Color 

Window Show 

Save Wave 

Data Source Screen 

Format *.csv 

Window Show 

Save Setup 

File Type *.stp 

Window Show 

Load Wave 

File Type *.wfm 

Load Setup 

File Type *.stp 

Disk 

File Type *.* 

Utility 

Sound On 

Clock Source Import 

Touch Lock Off 

Screen Saver Off 

Pass/Fail 
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Enable Off 

Source CH1 

Aux Output Off 

Output Event Fail 

Polarity Positive 

Pulse 100ns 

Err Action None 

Stop Output Off 

Record 

Record Off 

Interval 100ms 

Frames 100 

Beeper None 

Play 

Mode single 

Sequence Sequential playback 

Interval 100ms 

Quick Settings 

Operation Save Image 

Format *.png 

Invert Off 

Color Color 

Math 

Operator A+B 

Operation Off 

Source A CH1 

Source B CH1 

Offset 0V 

Scale 500mV 

LA 
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State Off 

Decode 

Bus Type UART 

Bus Stat u s Off 

Baud 115.2kbps 

Tx CH1 

Threshold 0V 

Rx Off 

Polarity Positive 

Format Hex 

Position 100% 

Label Off 

Data 8bit 

Parity None 

Stop Bit 1bit 

Package Off 

Separator 0(NULL) 

Ref 

Source CH1 

VScale 1V 

VOffset 0V 

Color Blue 

Label REF1 
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21 Arbitrary Waveform Generator 

(Option) 

This series of oscilloscopes has a built-in function arbitrary waveform generator, which 

combines the oscilloscope and signal generator to make it more convenient for users to 

use. This chapter introduces the functions of the built-in signal generator in the 

oscilloscope. 

This chapter includes: 

 To Output Basic Waveforms 

 To Output the Arbitrary Waveform 

 Modulation 

 Burst 
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21.1 To Output Basic Waveforms                           

Click [G1] in the button area to enter the signal generator setting interface and select 

the output of the basic wave. 

1. Output sine wave: 

Click on the Wave menu tab and select sine wave from the pop-up menu. 

  

 

Figure 21.1 sine wave 

 Frequency: 

Click on the Frequency menu tab, and you can set the frequency value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

DC and noise: no frequency parameters. 
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 Amplitude: 

Click on the Amplitude menu label, and you can set the amplitude value directly by 

rotating the knob V0 or on the pop-up numeric keyboard. When the impedance is high, 

the setting range is 10mVpp~5Vpp; When the impedance is 50 Ω, the setting range is 

5mVpp~2.5Vpp. 

 Offset: 

Click on the Offset menu label, and you can set the offset value directly by rotating the 

knob V0 or on the pop-up numeric keyboard. 

 Start Phase: 

Click on the Start Phase menu tab, and you can set the phase value directly by rotating 

the knob V0 or on the pop-up numeric keypad. Set the range to 0 °~360 °. 

 Align Phase: 

Click on the Align Phase menu tab and reconfigure the two channels to output 

according to the set frequency and phase. For two signals with the same frequency or a 

multiple frequency relationship, pressing the same phase can align the two phases. Use 

an oscilloscope to collect waveforms from two channels, and after stable display, switch 

the channel switch state. The phase difference between the two waveforms will change. 

Press the same phase button, and the two waveforms will automatically recover the 

phase difference of the current phase. 

 Setting: 

Click on the Setting menu tab to select the types as None, Modulation, or Burst. 

 Impedance: 

Click on the Impedance menu tab to select the output impedance of the signal 

generator as high impedance or 50 Ω. 

2. Output square wave: 

Click on the Wave menu tab and select Square Wave from the pop-up menu. 
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Figure 21.2 square wave 

Please refer to the "Output Sine Wave" section for setting parameters. The fixed duty 

cycle of the square wave is 50%. 

3. Output Ramp wave: 

Click the Wave menu label, and select Ramp wave in the pop-up menu. 

 

Figure 21.3 Ramp wave 

Please refer to the "Output Sine Wave" section for setting parameters. 

Symmetry refers to the percentage of the period during which the sawtooth wave 

waveform is rising. Click on the Symmetry menu tab, and you can set the symmetry 

value directly by rotating the knob V0 or on the pop-up numeric keypad. 
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Figure 21.4 Definition of symmetry 

4. Pulse: 

Click on the Wave menu tab and select Pulse from the pop-up menu. 

 

Figure 21.5 pulse 

Please refer to the "Output Sine Wave" section for setting parameters. 

Click on the Pulse Width menu tab, and you can set the pulse width directly by rotating 

the knob V0 or on the pop-up numeric keyboard. 

Click on the Rise Time menu tab, and you can set the rising time by rotating the knob 

V0 or directly setting it on the pop-up numeric keyboard. 

Click on the Fall Time menu tab, and you can set the descent time by rotating the knob 

V0 or directly setting it on the pop-up numeric keypad. 

5. DC: 

Click on the Wave menu tab and select DC from the pop-up menu. 
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Figure 21.6 DC 

 Offset: 

Click on the Offset menu label, and you can set the offset value directly by rotating the 

knob V0 or on the pop-up numeric keyboard. 

 Impedance: 

Click on the Impedance menu tab to select the output impedance of the signal 

generator as high impedance or 50 Ω. 

6. Noise: 

Click on the Wave menu tab and select Noise from the pop-up menu. 

 

Figure 21.7 Noise 

 Amplitude: 

Click on the Amplitude menu label, and you can set the amplitude value directly by 

rotating the knob V0 or on the pop-up numeric keyboard. 
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 Set offset: 

Click on the Offset menu label, and you can set the offset value directly by rotating the 

knob V0 or on the pop-up numeric keyboard. 

 Impedance: 

Click on the Impedance menu tab to select the output impedance of the signal 

generator as high impedance or 50 Ω. 

7. Sinc: 

Click on the Wave menu tab and select Sinc from the pop-up menu. 

 

Figure 21.8 Sinc 

Please refer to the "Output Sine Wave" section for setting parameters. 

8. Exp.Rise: 

Click on the Wave menu tab and select Exponential Rise from the pop-up menu. 

 

Figure 21.9 Exp.Rise 

Please refer to the "Output Sine Wave" section for setting parameters. 

9. Exp.Fall: 

Click on the Wave menu tab and select Exponential Descent from the pop-up menu. 
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Figure 21.10 Exp.Fall 

Please refer to the "Output Sine Wave" section for setting parameters. 

10. ECG: 

Click on the Wave menu tab and select electrocardiogram from the pop-up menu. 

 

Figure 21.11 ECG 

Please refer to the "Output Sine Wave" section for setting parameters. 

11. Gauss: 

Click on the Wave menu tab and select Gaussian from the pop-up menu. 

 

Figure 21.12 Gauss 
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Please refer to the "Output Sine Wave" section for setting parameters. 

12. Lorentz: 

Click on the Wave menu tab and select Lorentz from the pop-up menu. 

 

Figure 21.13 Lorentz 

Please refer to the "Output Sine Wave" section for setting parameters. 

13. Haversine: 

Click on the Wave menu tab and select half vector from the pop-up menu. 

 

Figure 21.14 Haversine 

Please refer to the "Output Sine Wave" section for setting parameters. 

21.2 To Output the Arbitrary Waveform                     

This series of oscilloscopes supports customizing any waveform and saving it in internal 

or external memory. 

Click [G1] in the button area to enter the signal generator setting interface, click the 

Wave menu label, and select any wave from the pop-up menu. 
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1. Load channel: 

Click on the Load from CH menu tab to enter the Settings menu. 

 Channel selection: 

Click on the Channel menu tab to select channels CH1~CH4. 

 Region: 

Click on the Region menu tab to select the screen or cursor. 

If the waveform range is selected as the cursor, click on Cursor A and Cursor B, and 

rotate knob V0 to adjust the positions of the two light markings respectively. Alternatively, 

click on the Cursor AB and rotate the knob V0 to adjust the positions of both cursors 

simultaneously. 

 Load: 

Click on the Load menu tab to load the set channel signal. 

2. Load waveform: 

Click on the Load Stored menu tab to enter the Settings menu. 

Select the waveform from the internal or external memory in the disk management 

interface that pops up on the screen, in the format of *. arb. 

 Load: 

Click on the Load menu tab to load the selected channel signal. 

3. Creat: 

Click on the Create menu tab to enter the Settings menu, where users can create any 

wave according to their needs. 

 Frequency: 
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Click on the Frequency menu tab, and you can set the frequency value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

 Amplitude: 

Click on the Amplitude menu label, and you can set the amplitude value directly by 

rotating the knob V0 or on the pop-up numeric keyboard. 

 Offset: 

Click on the Offset menu label, and you can set the offset value directly by rotating the 

knob V0 or on the pop-up numeric keyboard. 

 Init Points: 

Click on the Init Points menu tab, and you can set the point by rotating the knob V0 or 

directly setting the point on the pop-up numeric keyboard. 

 Linear Interp: 

Click the Linear Interp menu tab, and you can choose to turn linear interpolation on or 

off. 

 Open: The waveform editor connects two defined points with a straight line. 

 Close: The waveform editor will maintain a constant voltage level between 

two points and establish a stepped waveform. 

 Edit Points: 

Click on the Edit Points menu tab to enter the point editing settings menu, and define 

the waveform by assigning a voltage value to it. 

 PointX: 

Click on the PointX menu label, and you can set the current point directly by 

rotating the knob V0 or on the pop-up numeric keyboard. 

 Coltage: 

Click on the Coltage menu tab, and you can set the voltage value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

 Insert: 

Click on the Insert menu tab to insert a new editable point at the midpoint of 

the current and next editing points, and the initialization points will 

automatically increase by 1. If you continue to press Insert, you can add 

editable points one by one. 

 Delete: 

Click the Delete menu tab to delete the current point from the waveform, and 

the remaining points are connected using interpolation. 

 Zoom: 

Click on the Zoom in menu tab to select whether to turn on or off the 

horizontal time base zoom in function. 

 Apply: 

Click on the Apply menu tab to output any currently edited waveform. 
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 Save any wave: 

Click on the Save menu tab to enter the Save Settings menu. 

Refer to the instructions in the "Store and Load" section. 

4. Edit: 

Click the Edit menu tab to enter the Settings menu, where users can edit the current 

waveform. 

 Frequency: 

Click on the Frequency menu tab, and you can set the frequency value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

 Amplitude: 

Click on the Amplitude menu label, and you can set the amplitude value directly by 

rotating the knob V0 or on the pop-up numeric keyboard. 

 Offset: 

Click on the Offset menu label, and you can set the offset value directly by rotating the 

knob V0 or on the pop-up numeric keyboard. 

 Linear Interp: 

Click the Linear Interp menu tab, and you can choose to turn linear interpolation on or 

off. 

 Open: The waveform editor connects two defined points with a straight line. 

 Close: The waveform editor will maintain a constant voltage level between 

two points and establish a stepped waveform. 

 Edit Points: 

Click on the Edit Points menu tab to enter the point editing settings menu, and define 

the waveform by assigning a voltage value to it. 

 PonitX: 

Click on the PointX menu label, and you can set the current point directly by 

rotating the knob V0 or on the pop-up numeric keyboard. 

 Coltage: 

Click on the Coltage menu tab, and you can set the voltage value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

 Insert: 

Click on the Insert menu tab to insert a new editable point at the midpoint of 

the current and next editing points, and the initialization points will 

automatically increase by 1. If you continue to press Insert, you can add 

editable points one by one. 

 Delete: 

Click the Delete menu tab to delete the current point from the waveform, and 
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the remaining points are connected using interpolation. 

 Zoom: 

Click on the Zoom in menu tab to select whether to turn on or off the 

horizontal time base zoom in function. 

 Apply: 

Click on the Apply menu tab to output any currently edited waveform. 

 Save any wave: 

Click on the Save menu tab to enter the Save Settings menu. 

Refer to the instructions in the "Store and Load" section. 

5. Setting: 

Click on the Setting menu tab and select None, Modulation, or Burst. 

6. Start Phase: 

Click on the Start Phase menu tab, and you can set the phase value directly by rotating 

the knob V0 or on the pop-up numeric keypad. 

7. Impedance: 

Click on the Impedance menu tab and select high resistance or 50 ohms. 

21.3 Modulation                                            

The signal generator of this series of oscilloscopes has three modulation methods: 

amplitude modulation, frequency modulation, and phase modulation. The modulated 

waveform consists of a carrier wave and a modulated wave. The carrier signal is a 

waveform signal output by the signal generator, and the modulation signal can be 

selected from the sine wave, square wave, triangular wave, and noise built-in in the 

signal generator. 

Click on the button area [G1], go to More -> Setting -> Type -> Modulation to enter the 

modulation settings menu. 

 

Click on the Type menu tab to select amplitude modulation (AM), frequency modulation 
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(FM), and phase modulation (PM). 

1. AM: 

Amplitude Modulation (AM) refers to the variation of the amplitude of the carrier wave 

with the modulation wave. 

 

Figure 21.15 AM 

 Modulation waveform: 

Click on the Waveform menu tab to select waveforms such as sine wave, square wave, 

triangular wave, and noise. 

 Frequency: 

Click on the Frequency menu tab, and you can set the frequency value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

 Modulation depth: 

Click on the AM Depth menu tab, and you can set the modulation depth by rotating the 

knob V0 or directly setting it on the pop-up numeric keyboard. The modulation depth 

represents the strength of amplitude modulation. At 0% modulation, the output 

amplitude is half of the carrier signal amplitude; At 100% modulation, the output 

amplitude is equal to the carrier signal amplitude; When the modulation is greater than 

100%, envelope distortion will occur, which needs to be avoided in actual circuits. 

2. FM: 

Frequency Modulation (FM) refers to the frequency of a carrier wave that changes with 

the modulation wave. 
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Figure 21.16 FM 

 Modulation waveform: 

Click on the Waveform menu tab to select waveforms such as sine wave, square wave, 

triangular wave, and noise. 

 Frequency: 

Click on the Frequency menu tab, and you can set the frequency value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

 Deviation: 

Click on the Deviation menu label, and you can set the deviation value by rotating the 

knob V0 or directly setting it on the pop-up numeric keyboard. 

3. PM: 

The modulation method in which the deviation of the carrier phase from its reference 

phase varies proportionally with the instantaneous value of the modulated signal is 

called phase modulation, or phase modulation. There is a close relationship between 

phase modulation and frequency modulation. During phase modulation, frequency 

modulation occurs simultaneously; During frequency modulation, phase modulation 

also occurs simultaneously, but the changing patterns of the two are different. 

 Modulation waveform: 

Click on the Waveform menu tab to select waveforms such as sine wave, square wave, 

triangular wave, and noise. 

 Frequency: 
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Click on the Frequency menu tab, and you can set the frequency value directly by 

rotating the knob V0 or on the pop-up numeric keypad. 

 Modulation depth: 

Click on the PM Depth menu tab, and you can set the modulation depth by rotating the 

knob V0 or directly setting it on the pop-up numeric keyboard. 

21.4 Burst                                                

The signal generator of this series of oscilloscopes supports outputting burst waveforms 

with a specified number of cycles. This series of oscilloscopes supports internal or 

manual control of burst waveform output; Supports two burst types: N-loop and infinite. 

The burst setting menu can be accessed through the following methods: 

Click on the button area [Burst] to enter the burst setting menu. 

Click on the button area [G1], go to More -> Setting -> Type -> Burst, and enter the 

Burst Settings menu. 

 

1. Burst Type: 

Click on the Burst Type menu tab to select N cycle or infinite. 

 N cycle: When receiving a trigger signal, outputs a burst waveform with a specific 

number of cycles. 

 Infinite: It is equivalent to setting the number of waveform cycles to infinity, and 

outputting a continuous waveform upon receiving the trigger signal. 

2. Cycles: 

Click on the Cycles number menu tab, and you can set the cycle number by rotating the 

knob V0 or directly setting it on the pop-up numeric keypad. The number of cycles can 

only be set when multiple cycles are selected for the burst type. 
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3. Trigger source: 

Click on the Tri Source menu tab to select either internal or manual. The signal 

generator generates a burst output when receiving a trigger signal, and then waits for 

the next trigger signal. 

 Internal: When triggered internally, the signal generator outputs continuous 

multiple cycles. 

 Manual: When manually triggered, each press of the manual trigger button 

immediately triggers a burst output in the corresponding channel. Under the infinite 

burst type, the number of cycles menu is disabled. 

4. Burst Period: 

Click on the Burst Period menu tab to set the cycle by rotating the knob V0 or directly 

setting the cycle on the pop-up numeric keypad. The burst period is the time from the 

beginning of one burst to the beginning of the next burst. 
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22 Remote Control                         

The oscilloscope can be remotely controlled in the following three methods: 

1. User-defined programming: 

Users can program and control the oscilloscope through the standard SCPI (Standard 

Commands for Programmable Instruments) command. For detailed instructions on 

commands and programming, please refer to the Programming Manual. 

2. Using IO software: 

Users can use IO software to send commands for remote control of the oscilloscope. It 

is recommended to use the PC software IO provided by Keysight. You can log in to the 

Keysight official website (www.keysight.com) to download the software. 

Operating steps: 

 Establish communication between the oscilloscope and the computer. 

 Run IO and search for oscilloscope resources. 

 Open the remote command control panel and send commands. 

This oscilloscope can communicate with a PC through the following interfaces: 

 Controlled through USB 

 Control through LAN 

 Controlled through RS232/485 

This chapter will provide a detailed introduction to how to use the IO software provided 

by Keysight to remotely control the oscilloscope through various interfaces. 

Note: 

Before connecting the communication cable, please turn off the instrument to 

avoid damaging its communication interface. 

22.1 Remote Control via USB                             

1. Connect the device 

Connect the oscilloscope (USB VIEW interface) to the PC (USB HOST interface) using 

a USB data cable. 

2. Install USB driver 

After the oscilloscope is correctly connected to the PC for the first time and turned on, 

the PC will automatically install the driver, as shown in the Device Manager: 

file:///F:/机器型号/2、2G4CH/2G4通道说明书/1/3/www.keysight.com
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3. Search for device resources 

Open IO and the software will automatically search for resources currently connected to 

the PC through a USB interface. You can also click Rescan to search. 

4. View Device Resources 

The searched resources will appear in the USB (USB0) directory, displaying the 

machine model, serial number, version information, and USB interface information. 

5. Control the instrument remotely 

Click on Interactive IO in the IO interface to open the remote command control panel, 

where you can send commands and read data. 

22.2 Remote Control via LAN                             

1. Connect the device 

Connect the oscilloscope to your local area network using a network cable. 

2. Configure network parameters 

Configure the network parameters of the oscilloscope according to the instructions in 

the section on LAN Configuration. 

3. Search for device resources 

Open IO and click Rescan to search for devices. 

4. View Device Resources 

The name of the oscilloscope found is displayed on LAN (TCPIP0). 

5. Control the instrument remotely 

Click on Interactive IO in the IO interface to open the remote command control panel, 

where you can send commands and read data. 

6. Load webpage 

The oscilloscope has a LAN interface and a built-in oscilloscope web server, which 

allows you to remotely: 

 You can view information about the oscilloscope, such as its model, serial number, 

IP address, firmware version, etc. 

 Use the remote front panel to control the oscilloscope. 

 Send SCPI commands. 

 View and modify the network configuration and status of the oscilloscope. 

Before you can use the web interface, you must turn on the oscilloscope and establish 

its LAN connection. 

1) Set up LAN connection for oscilloscope 

Before you can use the web interface, you must turn on the oscilloscope and 

establish its LAN connection. Whenever you modify the IP address of the 
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oscilloscope, it will disconnect the oscilloscope from the local area network. You 

need to use a new IP address to re-establish communication with the oscilloscope. 

Connect to the network manually: 

 Open [UTILITY]-> I/O -> LAN -> Static IP of the machine to obtain its IP 

address. 

 Insert the oscilloscope into the local area network and connect the LAN cable 

to the LAN port on the back panel of the oscilloscope. 

 Modify the network connection of the computer, set the IP address to 

192.168.1.XX (XX is different from the last two digits of the machine), and the 

subnet mask to 255.255.255.0. 

2) Accessing the web interface 

To access the web interface of the oscilloscope: 

 Connect the oscilloscope to the local area network, refer to the previous 

section. 

 Enter the IP address of the oscilloscope in the browser, and the interface will 

open the oscilloscope's web interface. 

3) Web page control 

Using the web interface to operate the oscilloscope: 

 Home: Provide specific information about the machine. 

 Control instruments: HTML5 controls and instrument IO. 

 Configure LAN: Edit network configuration. 

 Language : Supports both Chinese and English. 

 Help: Click to view quick help. 

a) Home:  

View information about the oscilloscope, such as model, serial number, host 

name, VISA tool address, and LAN information. 

b) Launch HTML5 Control: 

In the web interface of the oscilloscope, select to launch the HTML5 control, 

and the remote front panel will appear. 

In the remote front panel, you can click on the oscilloscope buttons for 

operation, but you cannot click on the oscilloscope screen for operation. 

c) Using instrument IO: 

In the web interface of the oscilloscope, select the instrument IO, open the IO 

interface, and send remote programming commands to the oscilloscope 

through SCPI. 

d) Configure LAN: 

In the web interface of the oscilloscope, select Configure LAN to display the 

current LAN configuration of the instrument or edit a new LAN configuration. 

Click 'Edit' to enter the network configuration editing process, where you can reset 

the new IP address. The instrument will use the new IP address to connect to the 

browser. 
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22.3 Remote Control via RS232                           

1. Connect the device 

Connect the oscilloscope to your local area network using an RS232 serial cable. 

Note:  

Please use RS232 cross serial cable. Refer to the following figure. 

 

2. Configure network parameters 

Configure the parameters of the oscilloscope according to the instructions in the section 

on controlling through RS232 Configuration. 

3. Search for device resources 

Open IO and click Rescan to search for devices. 

4. View Device Resources 

The name of the oscilloscope found is displayed in COM. 

5. Control the instrument remotely 

Click on Interactive IO in the IO interface to open the remote command control panel, 

where you can send commands and read data. 
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23 Troubleshooting                             

The following is a list of possible faults and troubleshooting methods that may occur 

during the use of an oscilloscope. When you encounter these faults, please follow the 

corresponding steps to handle them. If you cannot handle them, please contact Hantek 

and provide the equipment information of your machine. 

1. The display of waveform is ladder-like 

a) The horizontal time base might be too low. Increase the horizontal time base to 

improve the display effects.  

b) If the display type is "Vector", the lines between the sample points may cause 

ladder-like display results. 

2. After connecting the power cord, the button light does not light up 

a) Check if the power switch of the oscilloscope is turned on. 

b) Check if the fuse is intact. If a fuse needs to be replaced, please use a fuse that 

meets the specifications of this product. 

c) If the button board still does not light up, please contact Hantek technical support 

department in a timely manner. 

3. No waveform of the signal is displayed on the screen 

a) Check if the probe is correctly connected to the BNC connector of the signal input 

channel. 

b) Check if the channel is open (CH1~CH4 menu buttons). 

c) Detect whether the signal channel to be tested has signal output. 

d) If it is a DC signal and the amplitude is relatively large, please increase the 

amplitude range. 

e) You can press the automatic measurement button to automatically detect the 

signal first. 

If there is still no waveform display, please contact Hantai technical support department 

in a timely manner. 

4. The touch functions cannot be used normally 

a) Check if the touch screen function is turned on. If it is not, click [Touch Lock] in 

the button area to turn on the touch screen function. 

b) Check if there is any dirt on the screen or fingers. If there is, please clean it first. 

c) Check if the oscilloscope is close to a strong magnetic field. If it is close to a strong 

magnetic field, please stay away first. 

If you still cannot use the touch screen, please contact Hantek technical support 
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department in a timely manner. 

5. The USB storage device cannot be recognized 

a) Check if the USB drive is functioning properly. 

b) Confirm the capacity of the USB flash drive. It is recommended to use a USB flash 

drive that does not exceed (16G) for this oscilloscope. 

c) Confirm that the format of the USB drive is FAT32 format. 

d) Reopen the oscilloscope and reinsert the USB drive for inspection. 

If you still cannot use the USB drive, please contact Hantek Technical Support 

Department in a timely manner. 

6. The instrument cannot start normally  

a) Check if the power switch of the machine is turned on. 

b) Check if the power plug of the oscilloscope is properly connected. 

c) Check if the fuse is intact. If a fuse needs to be replaced, please use a fuse that 

meets the specifications of this product. 

d) Turn on the machine again and see if it can be turned on normally. 

If the machine still cannot be opened, please contact Hantek Technical Support 

Department in a timely manner. 
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24 Appendix                               

24.1 Appendix A: Accessories                            

Order information Order number 

Host model 

2.5GSa/S, 2Gpts, 100MHz  

4-channel oscilloscope + LA + AWG 
HRDO2104E 

2.5GSa/S, 2Gpts, 200MHz 

4-channel oscilloscope + LA + AWG 
HRDO2204E 

2.5GSa/S, 2Gpts, 350MHz 

4-channel oscilloscope + LA + AWG 
HRDO2354E 

2.5GSa/S, 2Gpts, 500MHz 

4-channel oscilloscope + LA + AWG 
HRDO2504E 

2.5GSa/S, 2Gpts, 100MHz  

4-channel oscilloscope  
HRDO2104C 

2.5GSa/S, 2Gpts, 200MHz 

4-channel oscilloscope 
HRDO2204C 

2.5GSa/S, 2Gpts, 350MHz 

4-channel oscilloscope 
HRDO2354C 

2.5GSa/S, 2Gpts, 500MHz 

4-channel oscilloscope 
HRDO2354C 

Standard accessories 

Oscilloscope probe (four) 

HT-100B (100MHz) 

HT-200B (200MHz) 

HT300B (350MHz) 

HT500B (500MHz) 

USB cable (One) Type C 

Power Cord Conforming to the Standard of the 

Destination Country (One) 
-- 
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24.2 Appendix B: Warranty summary                       

Qingdao Hantek Electronic Co., LTD. (hereinafter referred to as Hantek) undertakes that 

the host and accessories of its production shall be free from any material and process 

defects during the warranty period. 

During the warranty period, if the product is proved to be defective, Hantek will repair or 

replace the product free of charge. Please refer to the description on Hantek official 

website for detailed warranty regulations. For repair service or full warranty instructions, 

please contact Hantek repair center or local offices. 

Hantek disclaims warranties, express or implied, other than those provided in this 

summary or any other applicable warranty card, including, but not limited to, any implied 

warranties of merchantability and fitness for special purpose. In no event shall Hantek be 

liable for indirect, special or consequential damages.



   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Addr: #35 Building, No. 780 Baoyuan Road, High-tech Zone, Qingdao, Shandong, China 266114 

Switchboard: 400-036-7077 

Email: service@hantek.com 

Tel: (0086)532-55678770 & 55678772 & 55678773 

Zip code: 266114 

Website: www.hantek.com 
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